12345fsa
2 Bronze

nw 9.0.1.4 , cannot add package to repository

Jump to solution

Hi All,

I'm playing with sw distribution on a new 9.0.1 linux server .

I have created a new dir for the package , added some packages , which went OK.

Adding some subsequent package (nmsap) throw this error :

148729 16/11/2016 14:40:18  2 10 0 2856097536 397 0 mybackup.server nsrcpd NSR warning Failed to add product from location /root/nw_9.0.1.4/nmda: Error finding the permissions of file/directory : lgtonmda-9.0.1.2-1.x86_64.rpm. 
148729 16/11/2016 14:42:14  2 10 0 2856097536 397 0 mybackup.server nsrcpd NSR warning Failed to add product from location /root/nw_9.0.1.4/nmsap/linux: Error finding the permissions of file/directory : lgtonmsap-9.0.1.2-1.x86_64.rpm. 
33131 16/11/2016 14:42:28  2 10 0 2856097536 397 0 mybackup.server nsrcpd NSR warning Success adding product from:
0 16/11/2016 14:42:28  2 10 0 2856097536 397 0 mybackup.server nsrcpd NSR warning /root/nw_9.0.1.4/nmsap/aix
148729 16/11/2016 14:42:45  2 10 0 2856097536 397 0 mybackup.server nsrcpd NSR warning Failed to add product from location /root/nw_9.0.1.4/nmsap/linux: Error finding the permissions of file/directory : lgtonmsap-9.0.1.2-1.x86_64.rpm. 

the permission are Ok on the files , also tried chowning root:root , no luck.

any clue?

0 Kudos
1 Solution

Accepted Solutions
ElanC
3 Silver

Re: nw 9.0.1.4 , cannot add package to repository

Jump to solution

Hi

View solution in original post

3 Replies
ElanC
3 Silver

Re: nw 9.0.1.4 , cannot add package to repository

Jump to solution

Hi

View solution in original post

12345fsa
2 Bronze

Re: nw 9.0.1.4 , cannot add package to repository

Jump to solution

Hello ElanC ,

you are right !

The metafile refers to a different rpm package  , and also the versions does not match

# Metafile Product Section
OPERATING_SYSTEM=Linux
OS_PLATFORM=linux_x86_64
PRODUCT_NAME=NetWorker Module for SAP
PRODUCT_PLATFORM_NAME=NMSAP
PRODUCT_VERSION=9.0.1.2
DESCRIPTION=NetWorker Module for SAP Package
PACKAGE_NAME=NetWorker Module for SAP
PACKAGE_VERSION=9.0.1.2
PACKAGE_PLATFORM_NAME=lgtonmsap
PACKAGE_PLATFORM_VERSION=9.0.1.2
PACKAGE_FILE=lgtonmsap-9.0.1.2-1.x86_64.rpm
PACKAGE_SIZE=20000000
REQUIRED_PACKAGE_NAME=Client
REQUIRED_PACKAGE_VERSION=9.0
REQUIRED_PACKAGE_PLAT_NAME=lgtoclnt
REQUIRED_PACKAGE_PLAT_VERSION=9.0
-------------- End of Metafile -------------

ls  -l lgtonmsap-9.0.1.0-1.x86_64.rpm
-rw-r--r-- 1 root games 24238242 18 ago 21.46 lgtonmsap-9.0.1.0-1.x86_64.rpm

thank you for your help!

Andrea

0 Kudos
ElanC
3 Silver

Re: nw 9.0.1.4 , cannot add package to repository

Jump to solution

Cool. Thanks!!

0 Kudos