dman1977
1 Copper

rrxcap-app13:C:\ 39078:save: SYSTEM error: client `client name' is not properly configured on the NetWorker Server

I've been getting this error now for the last two-weeks and everything I try doesn't work.

rrxcap-app13:C:\ 39078:save: SYSTEM error: client `rrxcap-app13.ml.wpafb.af.mil' is not properly configured on the NetWorker Server

It's funny because it worked fine for 11 days with no error then suddenly for no reason It fails. I checked and rechecked all the DNS and networker settings. Nothing has change.

Has anyone seen this and know the fix.

Thanks,

Doug

0 Kudos
15 Replies
Highlighted

Re: rrxcap-app13:C:\ 39078:save: SYSTEM error: client `client name' is not properly configured on the NetWorker Server

It does look like a network issue to me, particularly as you state you have had no change to your Networker configuration.

0 Kudos
tonyalbers
2 Iron

Re: rrxcap-app13:C:\ 39078:save: SYSTEM error: client `client name' is not properly configured on the NetWorker Server

Try to put the hostnames of server and client in the local hosts files, this will tell you if the problem is indeed DNS related(it will go away) or maybe related to client name or identifcation.

Also, from the server try the following:

nsradmin -p nsrexec -s rrxcap-app13.ml.wpafb.af.mil   [enter]

nsradmin> p type:nsrla      [enter]

(output)

nsradmin>q   [enter]

What you want is what it says under "name:"  this is the name the client uses to identify itself with towards the server. This must be the same as configured on the server or at least a known alias on the server.

/tony

0 Kudos
Jejje1
1 Nickel

Re: rrxcap-app13:C:\ 39078:save: SYSTEM error: client `client name' is not properly configured on the NetWorker Server

We have the same thing a few times a day in our enviroment. nothing changed on client but still this message.

our solution is to just "re-create" the client.

1. save client-id.

2. delete client

3. recreate client with same schedule, group, name, client-id and so on.

and then for SOME REASON it seems to work again.

would also know why networker does this sometimes.

0 Kudos

Re: rrxcap-app13:C:\ 39078:save: SYSTEM error: client `client name' is not properly configured on the NetWorker Server

Surely it is better to troubleshoot the problem than workaround it like this...  The error usually refers to an issue with name resolution - check aliases configured for this client, verify nslookups for hostname, all aliases and IP is consistent on both client and server, ensure HOSTS files do not have any incorrect entries...

0 Kudos
Jejje1
1 Nickel

Re: rrxcap-app13:C:\ 39078:save: SYSTEM error: client `client name' is not properly configured on the NetWorker Server

of course. we have been troubleshooting. for hours and hours. even had a few cases with EMC..

we have had this issue on ALOT of clients. randomly. and we can verify that no one have been logging in to this machine since this error started appearing.

and no changes to network/hosts-file etc. have also been verified.

almost as if networker for some reason all of a sudden "forgets" the client.

but the "solution" or "workaround" i provided seems to work.

but if some can tell me what could be wrong if i can RE-CREATE the client excactly as it was before and then all of a sudden it works?

0 Kudos

Re: rrxcap-app13:C:\ 39078:save: SYSTEM error: client `client name' is not properly configured on the NetWorker Server

Next time you get the error message run:

savegrp -vvvvpc clientname groupname

full nslookups from client and server

- and post the results here. Hopefully someone can help you, or at least define the problem a little more clearly for EMC's support to investigate further.

0 Kudos
ble1
6 Indium

Re: rrxcap-app13:C:\ 39078:save: SYSTEM error: client `client name' is not properly configured on the NetWorker Server

dman1977 wrote:

I've been getting this error now for the last two-weeks and everything I try doesn't work.

rrxcap-app13:C:\ 39078:save: SYSTEM error: client `rrxcap-app13.ml.wpafb.af.mil' is not properly configured on the NetWorker Server

It's funny because it worked fine for 11 days with no error then suddenly for no reason It fails. I checked and rechecked all the DNS and networker settings. Nothing has change.

Has anyone seen this and know the fix.

Thanks,

Doug

This is typical message when you backup client <hostname> and alias for for that client in NW resources is missing mentioned entry which is <hostname>.<domain>.  (perhaps unrelated, once I had customer who had also problem like this and at first sight they had alias field set correctly to learn after closer inspection that issue started after they created copy of client and during that process NMC crashed - that created corrupted alias field which you could only see with cat -vet against actual resource located inside nsrdb - removing whole alias field, saving it, and then adding it back did the trick).

0 Kudos
Thierry101
3 Silver

Re: rrxcap-app13:C:\ 39078:save: SYSTEM error: client `client name' is not properly configured on the NetWorker Server

Hi all

seeing the exact issue...probe is successful...but backup fails

C:\Users\svc-networkerbackup>savegrp -vv -p -c clientsrv -G grp

32451:savegrp: clientsrv:All            level=incr

7236:savegrp: Group will not limit job parallelism

32494:savegrp: clientsrvSmiley Tonguerobe              started

savefs -s NWKRSRV -c clientsrv -g grpName -p -o VSSSmiley Very HappyISASTER_RECOVERY=off; -l full -R -v

77567:savegrp: grpName * clientsrv:All  See the file x:\nsr\tmp\sg\grpName\sso.00000a for outp

7341:savegrp: clientsrv:All succeeded.

7076:savegrp: --- Probe Summary ---

clientsrv:All    level=full, dn=-1, mx=0, vers=ssbrowse, p=4

clientsrv:All      level=full, pool=pool, save as of 12/7/2011 12:18:43 PM

clientsrv:VSS SYSTEM FILESET:\ level=incr, dn=0, mx=1, vers=ssbrowse, p=4

clientsrv:VSS SYSTEM FILESET:\ level=incr, pool=pool, save as of 11/29/2011 6:09:46 PM

clientsrv:VSS OTHER:\ level=incr, dn=1, mx=1, vers=ssbrowse, p=4

clientsrv:VSS OTHER:\ level=incr, pool=pool, save as of 11/29/2011 6:09:53 PM

clientsrv:VSS USER DATA:\ level=incr, dn=2, mx=1, vers=ssbrowse, p=4

clientsrv:VSS USER DATA:\ level=incr, pool=pool, save as of 11/29/2011 6:09:51 PM

clientsrv:VSS SYSTEM SERVICES:\ level=incr, dn=3, mx=1, vers=ssbrowse, p=4

clientsrv:VSS SYSTEM SERVICES:\ level=incr, pool=pool, save as of 11/29/2011 6:09:52 PM

clientsrv:VSS SYSTEM BOOT:\ level=incr, dn=4, mx=1, vers=ssbrowse, p=4

clientsrv:VSS SYSTEM BOOT:\ level=incr, pool=pool, save as of 11/29/2011 6:10:03 PM

clientsrv:E:\     level=incr, dn=5, mx=1, vers=ssbrowse, p=4

clientsrv:E:\      level=incr, pool=pool, save as of 11/29/2011 6:10:23 PM

clientsrvSmiley Very Happy:\     level=incr, dn=6, mx=1, vers=ssbrowse, p=4

clientsrvSmiley Very Happy:\      level=incr, pool=pool, save as of 11/29/2011 6:10:30 PM

clientsrv:C:\     level=incr, dn=7, mx=1, vers=ssbrowse, p=4

clientsrv:C:\      level=incr, pool=pool, save as of 11/29/2011 6:10:42 PM

clientsrv:index  level=full, dn=-1, mx=0, vers=ssbrowse, p=4

clientsrv:index    level=full, pool=pool, save as of 12/7/2011 12:18:43 PM

7241:savegrp: nsrim run recently, skipping

Backup Result

--------------------------

1 retry attempted

81030:save: Most VSS Save Operations values are ignored on this OS platform.

39078:save: SYSTEM error: client `xx.xx.xx.xx' is not properly configured on the NetWorker Server

 

5777:save: Cannot open save session with NWKRSRV

<ERROR> :  Failed with error(s)

Things done

---------------------

+ delete create resource

+ delete peer info

+ rename ./tmp and nsrladb

+ tried removed the aliases in globals field..but it got filled up auto after save...still fails however

+ rpcinfo, nslookup, ping all ok

Was working before...

Any other hints appreciated...thanks..

0 Kudos
coganb
3 Cadmium

Re: rrxcap-app13:C:\ 39078:save: SYSTEM error: client `client name' is not properly configured on the NetWorker Server

Hi,

You could try putting the IP address of the client in its aliases field. 

-Bobby

0 Kudos