Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

85684

May 27th, 2012 09:00

6224 Multicast flooding help

I'm a noob on the hardware side and would appreciate some guidance from someone with more knowledge than myself on the intricacies of multicast routing.
 
This should be a simple setup, and it works for our needs,  but I want to prevent the multicast packet flooding that is occurring on VLAN 20.
In the docs I've found examples on setting up igmp snooping so I've tried those, but with no luck.  The multicast data keeps showing up on all the ports of VLAN 20.  I also tried setting up a 33rd VLAN and tried to route the multicast data from VLAN 10 to VLAN 20 with no luck.
 
Details:
This 6224P is the only switch on this stand alone network.  The multicast data is coming in on interface 1/g3 from 192.168.21.150 to multicast address 231.168.21.150.  There are two computers on 1/g11 and 1/g12 that join the multicast  to receive the data and I would like to prevent the multicast from travelling back out the rest of VLAN 20.  The two computer are also communicating to other devices on the VLAN.  There's two devices broadcasting data as well as 3 other devices being controlled via standard TCP/IP connections.
 
The trunked ports were setup as a simple link to a back up switch with the same config in the event of a failure.
 
The switch is handling the load just fine, but the other devices on VLAN 20 are a bit overwhelmed by the multicast data.
 
Any help or advice is greatly appreciated.
 
-C
 
 
 
!Current Configuration:
!System Description "Powerconnect 6224P, 3.2.0.7, VxWorks 6.5"
!System Software Version 3.2.0.7
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 20,30
exit
hostname "projections_1"
stack
member 1 4
exit
ip address 192.168.101.1 255.255.255.0
ip routing
username "admin" password 7275a1e8ba6325ecfc03ebb61a4b9192 level 15 encrypted
!
interface ethernet 1/g1
switchport mode general
exit
!


interface ethernet 1/g2
switchport access vlan 20
exit
!
interface ethernet 1/g3
switchport access vlan 20
exit
!
interface ethernet 1/g4
switchport access vlan 20
exit
!
interface ethernet 1/g5
switchport access vlan 20
exit
!
interface ethernet 1/g6
switchport access vlan 20
exit
!
interface ethernet 1/g7


switchport access vlan 20
exit
!
interface ethernet 1/g8
switchport access vlan 20
exit
!
interface ethernet 1/g9
switchport access vlan 20
exit
!
interface ethernet 1/g10
switchport access vlan 20
exit
!
interface ethernet 1/g11
switchport access vlan 20
exit
!
interface ethernet 1/g12
switchport access vlan 20


exit
!
interface ethernet 1/g13
switchport access vlan 20
exit
!
interface ethernet 1/g14
switchport access vlan 20
exit
!
interface ethernet 1/g15
switchport access vlan 30
exit
!
interface ethernet 1/g16
switchport access vlan 30
exit
!
interface ethernet 1/g17
switchport access vlan 30
exit


!
interface ethernet 1/g18
switchport access vlan 30
exit
!
interface ethernet 1/g19
switchport access vlan 30
exit
!
interface ethernet 1/g20
switchport access vlan 30
exit
!
interface ethernet 1/g21
switchport access vlan 30
exit
!
interface ethernet 1/g22
switchport access vlan 30
exit
!


interface ethernet 1/g23
switchport mode trunk
switchport trunk allowed vlan add 20,30
exit
!
interface ethernet 1/g24
switchport mode trunk
switchport trunk allowed vlan add 20,30
exit
snmp-server community public rw
exit

5 Practitioner

 • 

274.2K Posts

May 29th, 2012 06:00

You are correct IGMP snooping will be what you want to use. The following article describe how to setup IGMP snooping.

www.dell.com/.../app_note_18.pdf

www.dell.com/.../app_note_6.pdf

IGMP snooping commands start on page 333

support.dell.com/.../cli_en.pdf

Commands should look something similar to this.

console> enable

console# configure

Console(config)# ip igmp snooping

console(config)#bridge multicast filtering

console(config)# end

console(config)# int vlan 20

console(config-vlan)#ip igmp snooping 20

console(config)#bridge multicast filtering

console(config)# end

console(config)# copy running-config startup-config

Hope this information helps, keep us updated.

Thanks.

4 Posts

May 30th, 2012 13:00

Thank you very much for the reply.

I've tried the config changes you suggested.  In the app notes it
references setting "bridge multicast filtering" on the interface as
well as global.  On the 6224, there is no "bridge multicast filtering"
on the interface.

Here's the config with the changes, multicast packets are still
flooding all ports on VLAN 20.

-Craig

projections_2#show run
!Current Configuration:
!System Description "Powerconnect 6224P, 3.2.0.7, VxWorks 6.5"
!System Software Version 3.2.0.7
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 10,20,30
ip igmp snooping 20
exit
hostname "projections_2"
stack
member 1 4
exit
ip address 192.168.102.1 255.255.255.0
ip routing
username "admin" password 7275a1e8ba6325ecfc03ebb61a4b9192 level 15 encrypted
bridge multicast filtering
ip igmp snooping
ip multicast
!
interface ethernet 1/g1
switchport mode general
exit
!
interface ethernet 1/g2
description 'Induction_to_Duality'
switchport access vlan 20
exit
!
interface ethernet 1/g3
switchport access vlan 20
exit
!
interface ethernet 1/g4
switchport access vlan 20
exit
!
interface ethernet 1/g5
switchport access vlan 20
exit
!
interface ethernet 1/g6
switchport access vlan 20
exit
!
interface ethernet 1/g7
switchport access vlan 20
exit
!
interface ethernet 1/g8
switchport access vlan 20
exit
!
interface ethernet 1/g9
switchport access vlan 20
exit
!
interface ethernet 1/g10
switchport access vlan 20
exit
!
interface ethernet 1/g11
switchport access vlan 20
exit
!
interface ethernet 1/g12
switchport access vlan 20
exit
!
interface ethernet 1/g13
switchport access vlan 20
exit
!
interface ethernet 1/g14
switchport access vlan 20
exit
!
interface ethernet 1/g15
switchport access vlan 30
exit
!
interface ethernet 1/g16
switchport access vlan 30
exit
!
interface ethernet 1/g17
switchport access vlan 30
exit
!
interface ethernet 1/g18
switchport access vlan 30
exit
!
interface ethernet 1/g19
switchport access vlan 30
exit
!
interface ethernet 1/g20
switchport access vlan 30
exit
!
interface ethernet 1/g21
switchport access vlan 30
exit
!
interface ethernet 1/g22
switchport access vlan 30
exit
!
interface ethernet 1/g23
switchport mode trunk
switchport trunk allowed vlan add 30
exit
!
interface ethernet 1/g24
switchport mode trunk
switchport trunk allowed vlan add 30
exit
snmp-server community public rw
exit

5 Practitioner

 • 

274.2K Posts

May 30th, 2012 14:00

Sorry about that, lets use the bridge multicast forbidden forward-unregistered, command In the VLAN 20 interface.

console(config)#interface vlan 20

console(config-if)#ip igmp

console(config-if)#bridge multicast forbidden forward-unregistered

console(config-if)#exit

console(config)#interface range ethernet all

console(config-if)#ip igmp snooping

Keep us updated,

Thanks.

4 Posts

June 1st, 2012 11:00

Almost. 

- I can't add "ip igmp" to the interface VLAN 20, I get an error about an invalid action on the interface. So I tried it without and also at the global level.

- With the bridge multicast forbidden forward-unregistered, the flooding stops, but now the clients that want to join the multicast don't ever get passed the packets.

Cheers!

 

-C

Here's the current config.

projections_2#show running-config
!Current Configuration:
!System Description "Powerconnect 6224P, 3.2.0.7, VxWorks 6.5"
!System Software Version 3.2.0.7
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 10,20,30
ip igmp snooping 20
exit
hostname "projections_2"
stack
member 1 4
exit
ip address 192.168.102.1 255.255.255.0
ip routing
interface vlan 20
bridge multicast forbidden forward-unregistered
exit
username "admin" password 7275a1e8ba6325ecfc03ebb61a4b9192 level 15 encrypted
bridge multicast filtering
ip igmp snooping
ip multicast
ip igmp
!
interface ethernet 1/g1
ip igmp snooping
switchport mode general
exit
!
interface ethernet 1/g2
description 'Induction_to_Duality'
ip igmp snooping
switchport access vlan 10
exit
!
interface ethernet 1/g3
ip igmp snooping
switchport access vlan 20
exit
!
interface ethernet 1/g4
ip igmp snooping
switchport access vlan 20
exit
!
interface ethernet 1/g5
ip igmp snooping
switchport access vlan 20
exit
!
interface ethernet 1/g6
ip igmp snooping
switchport access vlan 20
exit
!
interface ethernet 1/g7
ip igmp snooping
switchport access vlan 20
exit
!
interface ethernet 1/g8
ip igmp snooping
switchport access vlan 20
exit
!
interface ethernet 1/g9
ip igmp snooping
switchport access vlan 20
exit
!
interface ethernet 1/g10
ip igmp snooping
switchport access vlan 20
exit
!
interface ethernet 1/g11
ip igmp snooping
switchport access vlan 20
exit
!
interface ethernet 1/g12
ip igmp snooping
switchport access vlan 20
exit
!
interface ethernet 1/g13
ip igmp snooping
switchport access vlan 20
exit
!
interface ethernet 1/g14
ip igmp snooping
switchport access vlan 20
exit
!
interface ethernet 1/g15
ip igmp snooping
switchport access vlan 30
exit
!
interface ethernet 1/g16
ip igmp snooping
switchport access vlan 30
exit
!
interface ethernet 1/g17
ip igmp snooping
switchport access vlan 30
exit
!
interface ethernet 1/g18
ip igmp snooping
switchport access vlan 30
exit
!
interface ethernet 1/g19
ip igmp snooping
switchport access vlan 30
exit
!
interface ethernet 1/g20
ip igmp snooping
switchport access vlan 30
exit
!
interface ethernet 1/g21
ip igmp snooping
switchport access vlan 30
exit
!
interface ethernet 1/g22
ip igmp snooping
switchport access vlan 30
exit
!
interface ethernet 1/g23
ip igmp snooping
switchport mode trunk
switchport trunk allowed vlan add 30
exit
!
interface ethernet 1/g24
ip igmp snooping
switchport mode trunk
switchport trunk allowed vlan add 30
exit
!
interface ethernet 1/xg1
ip igmp snooping
exit
!
interface ethernet 1/xg2
ip igmp snooping
exit
!
interface ethernet 1/xg3
ip igmp snooping
exit
!
interface ethernet 1/xg4
ip igmp snooping
exit
snmp-server community public rw
exit

4 Posts

June 1st, 2012 16:00

Disabling IP Routing globally now makes this configuration work.  From what I've learned so far, that sets the switch in to Layer 3 and the snooping setup is Layer 2. Please correct me if I'm wrong ;)

5 Practitioner

 • 

274.2K Posts

June 1st, 2012 17:00

Great to hear you got it working, and thank you for letting us know what worked for you. I am certain we can use the information in the future to help others.

Thanks.

4 Posts

March 7th, 2013 11:00

Hi.

I have a similar problem with 6224.

We have IP routing activated in globally and in vlan.

If i have "bridge multicast forbidden forward-unregistered" enabled in VLAN i cannot "see" multicast in ports with IGMP.

So, if i disable "bridge multicast forbidden forward-unregistered" and put forwarding unregistered it works.

The other way to put this working is, continue with forbidden but disabling ip routing in globally!! But i want to keep ip routing activated-

How can i put this working with "bridge multicast forbidden forward-unregistered" and ip routing?

Thanks

5 Practitioner

 • 

274.2K Posts

March 7th, 2013 11:00

We would be happy to help look over your configuration and offer some suggestions. Please post up your current running configuration, along with a description of how your network is setup and what you are trying to achieve. We can look through things and see what recommendations we may have.

Thanks.

4 Posts

March 8th, 2013 03:00

We have some multicast video streamers in port 1 - 4, and an host in port 19 for example.

If i do a "bridge multicast forbidden forward-unregistered" in VLAN 12, i cannot see the multicast in out interfaces.

!Current Configuration:

!System Description "PowerConnect 6224, 3.3.5.5, VxWorks 6.5"

!System Software Version 3.3.5.5

!Cut-through mode is configured as disabled

!

configure

vlan database

vlan 12

ip igmp snooping 12

ip igmp snooping maxresponse 12 1

ip igmp snooping querier 12

ip igmp snooping querier election participate 12

vlan routing 12 1

exit

hostname "SwVideo"

stack

member 1 1

exit

ip address 192.168.122.2 255.255.255.0

exit

ip routing

interface vlan 1

bridge multicast forbidden forward-unregistered

exit

interface vlan 12

bridge multicast forbidden forward-unregistered

name "VIDEO"

routing

ip address 10.3.0.21 255.255.192.0

ip igmp

ip igmp version 2

ip igmp query-interval 200

ip igmp robustness 4

ip igmp last-member-query-count 5

ip pimdm

exit

username "test" password 4e95563e70e9f790a6009edf9b28b8a3 level 15 encrypted

no spanning-tree

bridge multicast filtering

snmp-server enable traps pim

ip igmp snooping

ip igmp snooping querier

ip igmp snooping querier address 10.3.0.21

ip igmp snooping querier query-interval 20

ip multicast

ip igmp

ip pimsm

!

interface ethernet 1/g1

description 'MULTICAST SOURCE'

ip igmp snooping

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g2

description 'MULTICAST SOURCE'

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g3

description 'MULTICAST SOURCE'

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g4

description 'MULTICAST SOURCE'

ip igmp snooping

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g5

description 'MULTICAST SOURCE'

ip igmp snooping

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g6

description 'MULTICAST SOURCE'

ip igmp snooping

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g7

description 'MULTICAST SOURCE'

ip igmp snooping

switchport access vlan 12

exit

!

interface ethernet 1/g8

description 'MULTICAST SOURCE'

ip igmp snooping

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g9

shutdown

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g10

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g11

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g12

ip igmp snooping

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g13

spanning-tree disable

spanning-tree portfast

exit

!

interface ethernet 1/g14

shutdown

spanning-tree disable

spanning-tree portfast

exit

!

interface ethernet 1/g15

spanning-tree disable

spanning-tree portfast

exit

!

interface ethernet 1/g16

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g17

ip igmp snooping

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g18

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g19

description 'MULTICAST OUT'

ip igmp snooping

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g20

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g21

ip igmp snooping

spanning-tree disable

spanning-tree portfast

switchport mode trunk

switchport trunk allowed vlan add 12

exit

!

interface ethernet 1/g22

ip igmp snooping

spanning-tree disable

spanning-tree portfast

switchport access vlan 12

exit

!

interface ethernet 1/g23

description 'MULTICAST OUT'

ip igmp snooping

spanning-tree disable

spanning-tree portfast

switchport mode trunk

switchport trunk allowed vlan add 12

exit

!

interface ethernet 1/g24

description 'MULTICAST OUT'

ip igmp snooping

spanning-tree disable

spanning-tree portfast

switchport mode trunk

switchport trunk allowed vlan add 12

exit

exit

Thanks for your help

5 Practitioner

 • 

274.2K Posts

March 8th, 2013 13:00

From the configuration you are showing, it would seem you are doing layer 2 multicasting and not layer 3? With layer 2 you don’t need to have the igmp snooping and pim commands in place, just the bridge multicast commands.

With bridge multicast forbidden forward-unregistered enabled, it is going to block any non registered multicast addresses. If the multicast source is registered, then the application/client should just need to send a join message. If the client sends out a join message that registers his client to igmp, Then it should get multicast traffic after sending the join message.

By using the command bridge multicast forbidden forward-unregistered, are you trying to prevent multicast traffic flood, or something else?

4 Posts

March 9th, 2013 04:00

With layer2 multicasting can i remove ip igmp from global and from vlan? Right?

The idea of this scenario is to have about 200 multicast video source streams in 1-4 interfaces and about 5000 users in multicast out. I have to prevent that any other user act as multicast source (a normal IPTV scenario).

5 Practitioner

 • 

274.2K Posts

March 11th, 2013 09:00

Thanks for clearing up some of the goals we are trying to accomplish here. With the idea that we want to restrict/limit the source streams, we will need to leave it at layer 3 with the ip igmp commands. And use the ip mroute command to add source addresses.

Here the command to configure a specific device as a multicast source

ip mroute source-address source-mask rpf-address preference

no ip mroute source-address source

• source-address — The IP address of the multicast data source.

• source-mask — The IP subnet mask of the multicast data source.

• rpf-address — The IP address of the next hop towards the source.

• preference — The cost of the route (Range: 1 - 255).

Example

console(config)#

console(config)#ip mroute 1.1.1.1 255.255.0.0

192.168.20.1 34

Once added, only the source addresses specified should be able to broadcast.

4 Posts

March 11th, 2013 09:00

Thank you very much.

And regarded to the other configurations? Like PIM, filtering multicast, etc? should i leave it configured or not?

5 Practitioner

 • 

274.2K Posts

March 11th, 2013 11:00

PIM SM or DM can be left in place to help in routing the multicast packets. And will depend on the topology of your network.

"PIM DM builds source-based multicast distribution trees. In dense mode, a PIM DM router or multilayer switch assumes that all other routers or multilayer switches forward multicast packets for a group. "

"PIM-SM uses shared trees and shortest-path-trees (SPTs) to distribute multicast traffic to multicast receivers in the network. In PIM-SM, a router or multilayer switch assumes that other routers or switches do not forward multicast packets for a group"

The bridge multicast forbidden forward-unregistered command is going to allow registered addresses to  pass like OSPF BGP etc. I would leave this command out and use the ip mroute to specify your multicast source.

No Events found!

Top