zee2009
1 Copper

6224 general or trunk mode

Hi

 

I am having a bit of a mare getting a pair of stacked 6224s trunking VLAN information with an HP gbe2c blade module.  What I need to achieve:

- Two tagged VLANs 101 and 102 tagged through to the HP switch and in turn tagged right down to a blade with the server software used to present virtual interfaces on each VLAN.  HP config clearly not for this forum, this for info only.

- Since this is a flat network, i.e. everything else is untagged VLAN1, need to pass untagged traffic right the way through too

On the Powerconnect, I have read lots of posts regarding untagged VLAN 1 traffic and trunk ports on the 6224.  It seems whatever I am doing wrong that untagged traffic doesn't get through when using a trunk port, i.e. on the uplink ports to either side of the gbe2c

However, if I set the uplink ports as switchport mode general then all I get is default VLAN (i.e. untagged traffic - it seems anyway).  I need both together (untagged VLAN1 and tagged VLAN 101 and 102).

Uplink interface now to the gbe2c:

 

interface ethernet 1/g12

witchport mode general

no switchport general acceptable-frame-type tagged-only

switchport general ingress-filtering disable

switchport general allowed vlan add 101-102 tagged

exit

interface ethernet 3/g12

switchport mode general

no switchport general acceptable-frame-type tagged-only

switchport general ingress-filtering disable

switchport general allowed vlan add 101-102 tagged

exit

As above, untagged traffic is now passed (as opposed to when I used a trunk port) but the other switch doesn't 'see' the VLANs, i.e. I have

interface vlan 101

name "xxxxxx"

routing

ip address  172.16.10.254  255.255.255.0

exit

interface vlan 102

name "xxxxx"

routing

ip address  172.17.10.254  255.255.255.0

exit

But I can't reach either address above from the HP.

If you spot anything that precludes VLANs 101 or 102 being tagged correctly on these ports in above config would appreciate it since this is driving me mad!  Or if there is a way with a trunk port to pass untagged traffic that would also work. 

At least if I can find out one side of the equation is right can take it from there...

 

TIA

Zeee

 

 

 

0 Kudos
5 Replies
bh1633
3 Argentium

Re: 6224 general or trunk mode

enable routing globally on the PowerConnect stack.

console> enable

console# configuration

console(config)# ip routing

If that is not your problem, please post your entire config and any other information you have.

0 Kudos
Highlighted
zee2009
1 Copper

Re: 6224 general or trunk mode

Thanks for your reply.  Complete config:

 

!Current Configuration:
!System Description "Dell 24 Port Gigabit Ethernet, 2.1.0.13, VxWorks5.5.1"
!System Software Version 2.1.0.13
!
configure
vlan database
vlan  101-102
vlan association subnet 172.16.10.0 255.255.255.0 101
vlan association subnet 172.17.10.0 255.255.255.0 102
exit
stack
member 1 1
member 3 1
exit
ip address 192.168.0.2 255.255.250.0
ip name-server 192.168.0.10
ip name-server 192.168.0.11
ip routing

ip route 0.0.0.0 0.0.0.0 192.168.0.254
interface vlan 101
name "St1"
routing
ip address  172.16.10.254  255.255.255.0
exit
interface vlan 102
name "St2"
routing
ip address  172.17.10.254  255.255.255.0
exit

username "itsupport" password <removed> level 15 encrypted
no spanning-tree
!
interface ethernet 1/g1
channel-group 1 mode auto
exit
!


interface ethernet 1/g2
channel-group 1 mode auto
exit
!
interface ethernet 1/g3
channel-group 2 mode auto
exit
!
interface ethernet 1/g4
channel-group 2 mode auto
exit
!
interface ethernet 1/g11
switchport mode general
switchport general pvid 101
no switchport general acceptable-frame-type tagged-only
switchport general ingress-filtering disable
switchport general allowed vlan add 101
exit
!
interface ethernet 1/g12
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general ingress-filtering disable
switchport general allowed vlan add 101-102 tagged
exit
!
interface ethernet 3/g1
channel-group 1 mode auto
exit
!
interface ethernet 3/g2
channel-group 1 mode auto
exit
!
interface ethernet 3/g3
channel-group 2 mode auto
exit
!
interface ethernet 3/g4
channel-group 2 mode auto
exit


!
interface ethernet 3/g12
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general ingress-filtering disable
switchport general allowed vlan add 101-102 tagged
exit
!
interface port-channel 1
switchport mode trunk
switchport trunk allowed vlan add 1,101-102
exit
!
interface port-channel 2
switchport mode trunk
switchport trunk allowed vlan add 1,101-102
exit

exit

 

Ports 1 -2 and 3-4 on switch 1 and 3 in the stack are into a storage device (EMC Celerra) to which the tagging works fine. The Celerra allows tagging VLAN1, when I tried the same config into the blade chassis switch (HP gbe2c) it didn't work, don't think it likes tagging VLAN1.  Hence trying general mode port to allow untagged and tagged traffic in. 

ethernet 1/g11 is a physical server NIC in that VLAN - works fine.

Ports 12 on switch 1 and 3 go to the HP blade chassis.  Currently it cannot see VLAN 101 or 102, unable to ping 172.16.10.254 from within the chassis.  It is processing untagged traffic fine, can see LAN ok.  Am trying to ascertain if there is something broken above or if it's on the blade switch the issue(s) exist.

Thanks again

 

Zee

0 Kudos
bh1633
3 Argentium

Re: 6224 general or trunk mode

I think it is the blade server switch.

Please post the output of "show vlan".

 

0 Kudos
zee2009
1 Copper

Re: 6224 general or trunk mode

Thanks once again for replying, much appreciated.

Show VLAN output below:

VLAN       Name                         Ports          Type      Authorization

-----  ---------------                  -------------  -----     -------------

1      Default                          ch1-24,        Default   Required

                                        1/g3-1/g24,

                                        1/xg3-1/xg4,

                                        3/g3-3/g24,

                                        3/xg3-3/xg4

101    St1                         ch1-2,         Static    Required

                                        1/g11-1/g12,

                                        3/g12

102    St2                         ch1-2,1/g12,   Static    Required

                                        3/g12

 

console#

Thanks again!

 

Zee

0 Kudos
bh1633
3 Argentium

Re: 6224 general or trunk mode

I do not see anything obvious, so I will just tell you how I think 1/g12 and 1/g13 are behaving and maybe you can figure out if this is what you expect:

interface ethernet 1/g12
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general ingress-filtering disable
switchport general allowed vlan add 101-102 tagged
exit

- will egress tagged vlan 102 and 103 traffic.

- will ingress tagged vlan 102 and 103 traffic

- I believe the pvid is set to 1 by default, so untagged egress traffic will be treated as a vlan 1 traffic

- I am not sure what happens to vlan 1 egress traffic on this port.  I think this port will not egress vlan 1 traffic, so you should explicitly add it to vlan 1 untagged if that is your intention.

Regarding not being able to ping the PowerConnect interfaces from the HP chassis, is there a route to the PowerConnect switch from the blades?  Can you ping the PowerConnect switch from the blade server switches?  Can you ping the blade server switches from the blade servers?

0 Kudos