Highlighted
jasonL2
1 Nickel

6248 connect to Cisco on VLAN

Hi,

I am trying to connect a 6248 to a Cisco router. 

I can ping 10.0.10.254 from the Cisco side of the network but I can't ping 10.0.10.253.
I can ping 10.0.10.253 from the Dell side of the network but I can't ping 10.0.10.254.

 

The port on the cisco is configured like this witht two IP addresses:

!
interface FastEthernet0/1
  description Internal LAN
  ip address 192.168.9.254 255.255.255.0 secondary
  ip address 192.168.1.254 255.255.255.0
  no ip redirects
  no ip unreachables
  no ip proxy-arp
  ip route-cache flow
  duplex auto
  speed auto
  no cdp enable
!
interface FastEthernet0/1.10
  description NEW LINK to switches
  encapsulation dot1Q 10
  ip address 10.0.10.254 255.255.255.248
  no ip redirects
  no ip unreachables
  no ip proxy-arp
  no cdp enable
!

ip route 10.0.0.0 255.255.0.0 10.0.10.253

 

The 6248 is configured like this:

interface vlan 10
name "Connection to Cisco"
routing
ip address  10.0.10.253  255.255.255.248

interface ethernet 3/g37
spanning-tree portfast
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 101
switchport general allowed vlan add 10 tagged
exit

 

 

 

 

 

0 Kudos
7 Replies
Moderator
Moderator

Re: 6248 connect to Cisco on VLAN

Here is the document I would use to help setup a LAG between your cisco and powerconnect.  

www.dell.com/.../pwcnt_link_aggregation.pdf

www.dell.com/.../pwcnt_m6220_cisco.pdf

The documnent outlines the basics of getting a connection between the two devices. Once you have the devices connected and communicated, then you can proceed with any other configurations on that port.

Some things to make notes of:

The port speeds need to match on both sides.

It looks like on the cisco side you have a static route setup?

But on the powerconnect side there is no static route setup and switchport mode is general. Usually when connecting two VLAN aware devices together trunk mode is used.

It looks like you have portfast enabled on the port that connects the two devices.

Portfast is used for non-switch devices

• Clients

• Servers

• Printers

Let me know if this info does not help out, and I can do some more research into the subject.

Thanks.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
jasonL2
1 Nickel

Re: 6248 connect to Cisco on VLAN

Thanks Daniel,

What is the syntax for adding a static route on the 6248 ?

Your help is greatly appreciated.

0 Kudos
Moderator
Moderator

Re: 6248 connect to Cisco on VLAN

OK, did some more research on this. And it looks like you can keep the portfast enabled on the port.

I said Trunk mode, but it turns out Access mode would be better suited.

Vlan 10 should only have the two router ports in it, and no other ports connected to anything else.

Then setup the static route on each end to allow traffic to flow.

On the Powerconnect it is the same kind of command.

ip route 10.0.0.0 255.255.0.0 10.0.10.254

You would need to do this for each VLAN that needed access to the other switch.

You could also try

Ip route 0.0.0.0 0.0.0.0 10.0.10.(253/254)

To encompass all traffic.

Let us know what your updated configuration looks like and if it works.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
jasonL2
1 Nickel

Re: 6248 connect to Cisco on VLAN

Still no luck.  This is what the config looks like now.  VLAN 10 is only on the port directly connected to the Cisco.  Set the route as shown above.   When I switch to Access mode on the port - all traffic stops - so i set it to General.

show ip int

Routing Interfaces:

                                            Netdir   Multi

Interface    IP Address      IP Mask         Bcast    CastFwd

----------   --------------- --------------- -------- --------

vlan 101     10.0.101.254    255.255.255.0   Disable  Disable

vlan 102     10.0.102.254    255.255.255.0   Disable  Disable

vlan 10      10.0.10.253     255.255.255.248 Disable  Disable

vlan 1       192.168.1.201   255.255.255.0   Disable  Disable

vlan 103     10.0.103.254    255.255.255.0   Disable  Disable

vlan 104     10.0.104.254    255.255.255.0   Disable  Disable

show ip route

Route Codes: R - RIP Derived, O - OSPF Derived, C - Connected, S - Static

      B - BGP Derived, IA - OSPF Inter Area

      E1 - OSPF External Type 1, E2 - OSPF External Type 2

      N1 - OSPF NSSA External Type 1, N2 - OSPF NSSA External Type 2

S      0.0.0.0/0 [1/0] via 192.168.1.254,   vlan 1

S      10.0.0.0/16 [1/0] via 10.0.10.254,   vlan 10

C      10.0.10.248/29 [0/0] directly connected,   vlan 10

C      10.0.101.0/24 [0/0] directly connected,   vlan 101

C      10.0.102.0/24 [0/0] directly connected,   vlan 102

C      10.0.103.0/24 [0/0] directly connected,   vlan 103

C      10.0.104.0/24 [0/0] directly connected,   vlan 104

C      192.168.1.0/24 [0/0] directly connected,   vlan 1

Show VLAN

1      Default                          ch1-24,1/g5,   Default   Required

                                       1/g10-1/g24,

                                       1/g26-1/g48                                      

10     Connection to Cisco              1/g39          Static    Required

0 Kudos
Moderator
Moderator

Re: 6248 connect to Cisco on VLAN

Lets try getting rid of the static route between the two, it may be causing issues in this case.

We could do something like this.

Powerconnect:

switchport mode general

switchport general allowed vlan add 10 tagged (Add required multiple vlan number which you want to pass thru this channel)

This would be for the cisco, and may change some based on your model. So I would double check. But this is the basic idea.

switch

switch trunk encap dot

switch mode trunk

switch trunk allowed vlan 100

end

Let us know how this changes things.

Thanks.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
jasonL2
1 Nickel

Re: 6248 connect to Cisco on VLAN

Hi Daniel,

This is working now!  Thank you very much for all your work.

Jason

 

 

Here are the configurations on both sides that got it working.

DELL 6248

ip routing
ip route 10.0.100.0 255.255.255.0 10.0.100.254

interface vlan 10
name "Connection to Cisco"
routing
ip address  10.0.10.253  255.255.255.248
exit

interface ethernet 1/g39
spanning-tree cost 200000
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 10 tagged
exitip routing
ip route 10.0.100.0 255.255.255.0 10.0.100.254

interface vlan 10
name "Connection to Cisco"
routing
ip address  10.0.10.253  255.255.255.248
exit

interface ethernet 1/g39
spanning-tree cost 200000
switchport mode general
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 10 tagged
exit

CISCO

 interface FastEthernet0/1.10
 description NEW LINK to switches
 encapsulation dot1Q 10
 ip address 10.0.10.254 255.255.255.248
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no cdp enable

ip route 10.0.0.0 255.255.0.0 10.0.10.253

0 Kudos
Moderator
Moderator

Re: 6248 connect to Cisco on VLAN

That is great to hear! I am sure this information will help others in the future.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos