Basscom
1 Copper

6248P VOIP And Trunk Issue

Jump to solution

Hi,

I am swapping out a old Linksys switch that has our phones and I am looking to VLAN our phones and PCs on the 6248P switch.

I have setup the 6248P to have VLAN1 as PC's and VLAN101 as the Voice. Tagged 101 on the port 40 which I am testing and left VLAN1 as untagged.

I have enabled Voice VLAN and assigned the VLAN ID to 101 then on the port settings change VLAN mode general and assigned PVID to 101.

Port 47 is the trunking port and I have set this as the trunk port however the phone does not get a IP Address from the Cisco 800.  I am just changing the link from the Linksys to the dell to test but it does not work.

Can you advise me on the settings the for Trunk and if that's correct on what I have done.

I am quite a newb on networking but hopefully it makes sense above

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
Anonymous
Not applicable

RE: 6248P VOIP And Trunk Issue

Jump to solution

On the phone you may need to check and be sure that LDDP-MED is enabled. Then enabled VLAN and set the VLAN ID on the phone to VLAN 101. Here is a link on how to achieve these settings.

http://bit.ly/1MG4x2h

Once those setting are set the phone will advertise to the switch and should be placed on the voice VLAN. If the phone does not hear an acknowledgement back, it will then send tagged frames for VLAN 101. Either way the end result will be that the phone is on VLAN 101.

Let us know if this works.

Cheers

0 Kudos
8 Replies
Highlighted
Anonymous
Not applicable

RE: 6248P VOIP And Trunk Issue

Jump to solution

Here are some points to keep in mind when enabling Voice VLAN.

  • Voice VLAN is enabled on a per port basis. A port can participate in one Voice VLAN at a given instance of time.
  • For the Voice VLAN to be operational on the port so that the connected IP phone can correctly communicate on the Voice VLAN:
    • Voice VLAN should be configured on the interface.
    • LLDP-MED needs to be operational on the port.
    • Configured Voice VLAN should be one of the active VLANs from the dot1q database.
    • The port should be authorized and link is active.
    • The port should not be part of a Guest VLAN or LAG interface.
  • Voice VLAN becomes non-operational if the Voice VLAN ID is deleted from the dot1q database.
  • Voice VLAN uses LLDP-MED to pass on the VLAN ID, 802.1p Priority, and DSCP values to the IP phone.
  • The Voice VLAN operates in two modes – trusted mode and untrusted mode. The default mode is trusted mode.
  • In untrusted mode, the CoS value is not trusted for 802.1p or 802.1q tagged traffic, and all untagged traffic is forwarded with CoS value of 0.
  • In trusted mode, the CoS values of the 802.1p or 802.1q tagged traffic are forwarded based on the embedded priority info.
  • All untagged traffic except the Voice VLAN traffic (if untagged) is associated to the default priority of the port.
  • When Voice VLAN is enabled on a port, then the port is configured as an edge port (dot1s configuration) and when Voice VLAN is disabled, then the edge port remains configured.
  • Voice VLAN can be enabled on a port only if it is configured as “General”.

And here is an example of what the port configuration would look like for the phone connection.

console(config)# interface ethernet 1/g10

console(config-if)# spanning-tree portfast

console(config-if)# switchport mode general

console(config-if)# switchport general pvid 1

console(config-if)# switchport general allowed vlan add 1

console(config-if)# switchport general allowed vlan add 101 tagged

console(config-if)# lldp transmit-mgmt

console(config-if)# lldp notification

console(config-if)# lldp med

console(config-if)# lldp med confignotification

console(config-if)# lldp med transmit-tlv inventory

console(config-if)# voice vlan 101

console(config-if)# voice vlan auth disable

For your switch to switch connection the configuration would be:

console(config)# interface ethernet 1/e47

console(config-if)# switchport mode trunk

console(config-if)# switchport trunk allowed vlan add 101

 

If that is not allowing traffic to traverse the connection, you can try General mode.

 

console(config)# interface ethernet 1/e7

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 101 tagged

Let us know if this helps out.

0 Kudos
Basscom
1 Copper

RE: 6248P VOIP And Trunk Issue

Jump to solution

That's awesome - I am not in the office today but back in on Tuesday so will attempt the change then. and will let you know. many thanks for giving the whole config!!

0 Kudos
Basscom
1 Copper

RE: 6248P VOIP And Trunk Issue

Jump to solution

Hi,  I tested this today and it partly worked.  However the Cisco 800 is managed by the phone company and does give a DHCP range of 172.20.132.x when plugged into the old switch however when plugging into the dell switch i pickup my dhcp range for the computers which the server is dishing out.

0 Kudos
Anonymous
Not applicable

RE: 6248P VOIP And Trunk Issue

Jump to solution

Just to confirm, do the workstations plug into the phones? It sounds like the phones ended up on the untagged VLAN 1. What model phone is being used?

0 Kudos
Basscom
1 Copper

RE: 6248P VOIP And Trunk Issue

Jump to solution

Yes that's correct. Model phone is Cisco SPA504G.  I have spoken to the hosted phone provider and they don't support this with Dell switches so I may have to leave it!

0 Kudos
Anonymous
Not applicable

RE: 6248P VOIP And Trunk Issue

Jump to solution

On the phone you may need to check and be sure that LDDP-MED is enabled. Then enabled VLAN and set the VLAN ID on the phone to VLAN 101. Here is a link on how to achieve these settings.

http://bit.ly/1MG4x2h

Once those setting are set the phone will advertise to the switch and should be placed on the voice VLAN. If the phone does not hear an acknowledgement back, it will then send tagged frames for VLAN 101. Either way the end result will be that the phone is on VLAN 101.

Let us know if this works.

Cheers

0 Kudos
Basscom
1 Copper

RE: 6248P VOIP And Trunk Issue

Jump to solution

Hi,

That worked perfectly - thanks very much for all your help and quick assistance!!!

0 Kudos
Anonymous
Not applicable

RE: 6248P VOIP And Trunk Issue

Jump to solution

Good to hear, thanks for the update.

0 Kudos