cwigney
1 Copper

Can not get 802.1x working on a PowerConnect 5448

Hi all,

I have been working on this forever and i cannot get 802.1x working on the PowerConnect 5448 switch.

My client is a wired Windows XP3 client.

Client:

Using PEAP

I have validate server cert ticked

Authentication is Secured Password (EAP-MSCHAP V2)

Disabled Fast Recconect

Switch:

Radius

IP Address of server set

Priority 1

Authentication Port 1812

I have set the key string

Usage type all (I have tried 802.1x)

All other parameters default

Port Based Authentication

It is enabled for my client port

Method is Radius, NOne

Guest Vlan disabled

Admin Interface control: Auto

Auth Type: 802.1x only

All other parameters default

Server

I am using Windows 2008 R2 and the Netwok Policy Server (NPS)

I have set up the connection request policy and the network policy

The network policy includes a computer based condition and another policy includes a user base condition

Problem:

I set the port to authorized. I log the client into the domain. I then set the port to Auto. The client immediately becomes unauthorized. On a reboot I sometimes see the client is authorized. The username shows as host\computername. If I was to reboot the machine or login to the machine then the port becomes unauthorized and remains that way.

As I said I have spent weeks on this and have got no-one. I would be so appreciative if someone could help me. More than happy to provide any additional info required.

Thanks in Advnace

Chris

 

 

0 Kudos
1 Reply
8 Krypton

Re: Can not get 802.1x working on a PowerConnect 5448

Since this works some of the time for you, it might be a spanning tree issue.   Make sure that your client ports are set to portfast.

If this does not help, please post you entire config and any additional information you think is relevant.

0 Kudos