panthrax
1 Copper

Can't get vlan trunks working on PowerConnect 5224

Hi! Having some issues getting trunking to work on a PC 5224. Should be a fairly simple procedure, but I'm obviously doing something wrong. Once I have the interfaces set up, I can ping the default gateway and a switch on the same subnet as the IP address I have set on the Dell switch (10.100.103.9) can be pinged. However, if I ping outside of the subnet or to the internet from the Dell switch, it fails, and ping into the Dell switch from outside the subnet it fails. Can someone let me know what I'm doing wrong and how to fix it?

Relevant configs, let me know if you need more info:

Dell:

vlan database
vlan 1 name DefaultVlan media ethernet state active
vlan 32 name Corporate media ethernet state active
vlan 50 name Server media ethernet state active
vlan 103 name Mgmt media ethernet state active

!
!
interface ethernet 1/24
switchport allowed vlan add 1 untagged
switchport native vlan 1
switchport mode trunk
switchport allowed vlan add 1,32,50,103 tagged

!
!
!
interface vlan 103
ip address 10.100.103.9 255.255.255.0
!
!
!
!
!
!
ip default-gateway 10.100.103.1
!

Cisco:

interface GigabitEthernet1/0/46
description To xxxxxxxxx
switchport mode trunk
end

Tags (3)
0 Kudos
9 Replies
Anonymous
Not applicable

RE: Can't get vlan trunks working on PowerConnect 5224

In order for the separate VLANs to be able to communicate with each other there needs to be a layer 3 device setup to perform VLAN routing. Do you have a device setup on the network that can perform VLAN routing?

 

Here are some good white pages that help touch on VLANs and routing.

http://www.dell.com/downloads/global/products/pwcnt/en/app_note_38.pdf

http://www.dell.com/downloads/global/products/pwcnt/en/app_note_8.pdf

http://www.dell.com/downloads/global/products/pwcnt/en/app_note_4.pdf

 

Keep us updated.

0 Kudos
panthrax
1 Copper

RE: Can't get vlan trunks working on PowerConnect 5224

Hi Daniel, thanks for the reply. Yes, I have a L3 device upstream that handles routing. The 5224 is connected to a Cisco 2960, which is then connected to a 3750 which does routing for us. Again, I'm able to ping into and out of the 2960 (so routing is fine), but when I'm sitting on the 5224, all I can ping is the DFGW and things on the same subnet. Can't get past the dfgw.

0 Kudos
Anonymous
Not applicable

RE: Can't get vlan trunks working on PowerConnect 5224

Thanks for the extra clarification. I don’t think will resolve your issue, but one area we can clean up is VLAN 1. currently it is set to be native vlan, untagged and tagged. We should remove it from being tagged. And when we set a vlan as native vlan it already sends it as untagged. So should just need these commands on the Trunk.

 

switchport mode trunk

switchport native vlan 1

switchport allowed vlan add ,32,50,103 tagged

 

What are the port settings for the 2960?

0 Kudos
panthrax
1 Copper

RE: Can't get vlan trunks working on PowerConnect 5224

Ran through those commands, and it's still showing vlan 1 untagged and tagged.

Config for the 2960 is:

interface GigabitEthernet1/0/46

description To xxxxxxxxx
switchport mode trunk
end

0 Kudos
Anonymous
Not applicable

RE: Can't get vlan trunks working on PowerConnect 5224

And all the same VLANs are created on the 2960?

32,50,103?

 

You may need to place no in front of the commands we want to remove.

No switchport allowed vlan add 1

or

switchport allowed vlan remove 1

 

The clients plugging into the 5224 should also be set to have a gateway of the IP address that is assigned to the specific VLAN on the 3750. The only IP address on the 5224 should be for the native VLAN for management.

0 Kudos
panthrax
1 Copper

RE: Can't get vlan trunks working on PowerConnect 5224

Yep, those vlans are created on the 2960.

Console(config-if)#sw allowed vlan remove 1
Failed to remove from egress list on ethernet 1/24

Console(config-if)#no sw allowed vlan add 1
                                                                       ^
% Invalid input detected at '^' marker.

I currently don't have any clients plugged in. I'm only trying to ping out from the 5224 directly. Management vlan is 103, but native vlan is showing as 1. I'm unable to change the native vlan as well:

Console(config-if)#sw native vlan 103
Failed to set pvid on ethernet 1/24

0 Kudos
Anonymous
Not applicable

RE: Can't get vlan trunks working on PowerConnect 5224

The Native VLAN is not always routable with other vlans on the PowerConnect switches. So pinging from the switch itself is not the best method to check connectivity. I suggest placing a client on a port in access mode for one of the other VLANs. Set the gateway to the IP address for the VLAN it in access mode for. Then attempt connection to another client on one of the other switches.

0 Kudos
panthrax
1 Copper

RE: Can't get vlan trunks working on PowerConnect 5224

Success! I think that was it. Stuck my PC on a port, configured it for a couple different VLANs, and I was able to reach everything I wanted through the trunk port out to the network. Awesome. Thank you so much for your help. I'll stick it into production, and see how it goes. Thanks again.

0 Kudos
Highlighted
Anonymous
Not applicable

RE: Can't get vlan trunks working on PowerConnect 5224

Excellent! glad to hear the good news.

0 Kudos