sandy2810
1 Copper

Command to remove "switchport general allowed vlan" from Interface

Jump to solution

Guys I am new to configuring this switch. I would need to know how to remove "switchport general allowed vlan" from the interface configuration. We were testing something and I had initially configured this port as general with the allowed vlan command. Later we configured the port to trunk. The GUI shows only trunk configuration on the port, the CLI however shows trunk and the "switchport general allowed vlan" configured.

I tried the no switchport general allowed vlan command but seems like this command does not exist. How can I get rid of this command?

Regards

0 Kudos
1 Solution

Accepted Solutions
skehoe
1 Copper

Re: Command to remove "switchport general allowed vlan" from Interface

Jump to solution

Enter the following command to remove the general allowed statement from the interface config.

Switchport general allowed vlan remove 115,209

0 Kudos
4 Replies
Anonymous
Not applicable

Re: Command to remove "switchport general allowed vlan" from Interface

Jump to solution

Where are you seeing that the port is still in a general mode configuration, after issuing  the command to set it to trunk? Any screen shots, or copy of where you are seeing this may help.

I did a test on this and I was able to change from general to trunk without any issues.

First I set one of the interfaces to switchport general mode.

(config)# interface gigabitethernet 1/0/2

(config-if)# switchport mode general

(config-if)# switchport general allowed vlan add 22

Then ran a show command to see the status of the port, and it showed to be in general mode.

#show interfaces switchport gigabitethernet 1/0/2

Name: gi1/0/2

Switchport: enable

Administrative Mode: general

Operational Mode: down

Access Mode VLAN: 1

Access Multicast TV VLAN: none

Trunking Native Mode VLAN: 1

Trunking VLANs Enabled: 1,22

                       2-21,23-4094 (Inactive)

Then went back and changed from general to trunk mode.

(config)# interface gigabitethernet 1/0/2

(config-if)# switchport mode trunk

Then ran the show command again, and it seemed to change modes just fine.

#show interfaces switchport gigabitethernet 1/0/2

Name: gi1/0/2

Switchport: enable

Administrative Mode: trunk

Operational Mode: down

Access Mode VLAN: 1

Access Multicast TV VLAN: none

Trunking Native Mode VLAN: 1

Trunking VLANs Enabled: 1,22

                       2-21,23-4094 (Inactive)

You can use the #no switchport, command to disable it all together.

Ensuring the switch is up to date on firmware can also help ensure the switch is running smoothly.

<ADMIN NOTE: Broken link has been removed from this post by Dell>

 

Thanks

0 Kudos
sandy2810
1 Copper

Re: Command to remove &amp;quot;switchport general allowed vlan&amp;quot; from Interface

Jump to solution

interface Te1/0/13

switchport mode trunk

switchport general allowed vlan add 115,209

switchport trunk native vlan 115

switchport trunk allowed vlan except xxxxxxxx

exit

As you can see above, the mode says its trunk. I would however need to get rid of that general allowed vlan config. I shall try setting the port to no switchport and then enter only the trunk configuration again.

Thanks

0 Kudos
Anonymous
Not applicable

Re: Command to remove &amp;amp;quot;switchport general allowed vlan&amp;amp;quot; from Interface

Jump to solution

What is the outputn of the show interface command?

0 Kudos
skehoe
1 Copper

Re: Command to remove &amp;amp;amp;quot;switchport general allowed vlan&amp;amp;amp;quot; from Interface

Jump to solution

Enter the following command to remove the general allowed statement from the interface config.

Switchport general allowed vlan remove 115,209

0 Kudos