Start a Conversation

Unsolved

This post is more than 5 years old

93363

February 7th, 2012 10:00

Configure Powerconnect 7048 VLAN, VLAN routing, and DHCP.

OK, I am currently in the process of updating our network infrastructure. Currently we are sub netting our network with, lets say, not standard RFC1918 IP address. My plan is to change our IP scheme to 10.1/24 and implement VLANs as we have a lot of broadcast traffic on our network and we are looking to implement VoIP in the very near future. I wanted to create 4 user VLANs for different parts of the building, a VLAN for SERVERs and GATEWAY, and a VLAN for PRINTERS. I wanted to have all VLANs communicate with each other and have the 4 user VLANs relay DHCP packets to our single windows 2008 DHCP server.

I have never set anything up like this before. I have read numerous forums and documentation on setting everything up. And I feel I have a good handle on setting it up, or so I thought.

The company purchased 2 Dell powerconnect 7048 for its L3 switch. I have read the documentation and was able to create the VLANs, but i am a little confused with the VLAN routing and setting up DHCP relay. I have read the documentation but it seems a little confusing to me.

I was pretty much following this documentation for setting it up. I know its not the same switch, but the basics i think are there and I ran through it and it seems fine, up until you get to the part about DHCP relay. And I am a little confused with the Trunk ports, but that is an HP issue as our L2 switches are all HP Porcurves.

Any help or advise would be appreciated. Thanks

Here is a copy of my current config

!Current Configuration:
!System Description "PowerConnect 7048, 4.1.0.19, VxWorks 6.6"
!System Software Version 4.1.0.19
!System Operational Mode "Normal"
!
configure
vlan database
vlan 2-4,6,8,10,20,30,40,80,100,110
vlan routing 1 1
vlan routing 10 2
vlan routing 20 3
vlan routing 30 4
vlan routing 40 5
vlan routing 80 6
vlan routing 100 7
vlan routing 110 8
vlan routing 8 9
vlan routing 6 10
vlan routing 4 11
vlan association subnet 10.1.8.0 255.255.255.0 8
vlan association subnet 10.1.10.0 255.255.255.0 10
vlan association subnet 10.1.20.0 255.255.255.0 20
exit
vlan 2
name "iSCSI"
exit
vlan 3
name "vMOTION"
exit
vlan 4
name "TIME CLOCKS"
exit
vlan 6
name "WIRELESS"
exit
vlan 8
name "PRINTERS"
exit
vlan 10
name "1st USERS"
exit
vlan 20
name "MMH"
exit
vlan 30
name "BILLING"
exit
vlan 40
name "IT"
exit
vlan 80
name "VPN USERS"
exit
vlan 100
name "SECURITY"
exit
vlan 110
name "PHONES"
exit
slot 1/0 5    ! PowerConnect 7048
slot 1/1 9    ! CX4 Card
slot 2/0 5    ! PowerConnect 7048
slot 2/1 9    ! CX4 Card
stack
member 1 5    ! PCT7048
member 2 5    ! PCT7048
exit
interface out-of-band
ip address 192.168.2.1 255.255.255.0 0.0.0.0
exit
ip domain-name "irmmgmt.com"
ip name-server "10.1.1.10"
ip name-server "10.1.1.11"
ip routing
ip default-gateway 10.1.1.254
ip route 0.0.0.0 0.0.0.0 10.1.1.254 253
ip helper-address 10.1.1.10 domain
ip helper-address 10.1.1.11 dhcp
interface vlan 1
ip address 10.1.1.100 255.255.255.0
exit
interface vlan 4
ip address 10.1.4.254 255.255.255.0
ip local-proxy-arp
exit
interface vlan 6
ip address 10.1.6.254 255.255.255.0
ip local-proxy-arp
exit
interface vlan 8
ip address 10.1.8.254 255.255.255.0
ip local-proxy-arp
exit
interface vlan 10
ip address 10.1.10.254 255.255.255.0
exit
interface vlan 20
ip address 10.1.20.254 255.255.255.0
exit
interface vlan 30
ip address 10.1.30.254 255.255.255.0
ip local-proxy-arp
exit
interface vlan 40
ip address 10.1.40.254 255.255.255.0
ip local-proxy-arp
exit
interface vlan 80
ip address 10.1.80.254 255.255.255.0
ip local-proxy-arp
exit
interface vlan 100
ip address 10.1.100.254 255.255.255.0
ip local-proxy-arp
exit
interface vlan 110
ip address 10.1.110.254 255.255.255.0
ip local-proxy-arp
exit
dhcp l2relay
!
interface Gi1/0/44
switchport mode trunk
exit
exit

5 Practitioner

 • 

274.2K Posts

February 7th, 2012 12:00

I will try my best to help out.

Trunk Links attach two VLAN aware switches (or other VLAN aware devices) together and allows for multiple VLAN frames to cross one link.

Looks like you have Gi1/0/44 going to the layer 2 switch?

On the HP switch, is the port connected to the 70xx set to trunk mode also?

The DHCP command looks ok to me.

Are your clients able to ping the DHCP server?

Are the client ports set to portfast?

Page 329 goes over DHCP

support.dell.com/.../CLI_UG.pdf

5 Practitioner

 • 

274.2K Posts

February 7th, 2012 13:00

Yes they probably should.

• Portfast Allows immediate transition to a forwarding state

• Port still participates in STP

• Used for non-switch devices

• Clients

• Servers

• Printers

• Prevents unnecessary timeouts from DHCP servers

• Portfast configuration ignored when port is connected to another switch

February 7th, 2012 13:00

Yes, port Gi1/0/44 is connected to a L2 HP switch. I am pretty sure I have the HP switch port configured as a trunk port. I will have to double check.

The switches are not live yet, but I will be testing this weekend to verify that everything is working.

I do not have portfast enabled. I am guessing that I should?

February 7th, 2012 13:00

OK. i will configure that as well. So it seems like the only thing i need is to make sure the port on the HP switch is a trunk port, Enable Portfast, and verify that DHCP works?

I just want to make sure that this works. I have about a 2 hour window on Saturday to test and then we go live with this the following weekend. I just want to eliminate as many issues as possible before going live.

5 Practitioner

 • 

274.2K Posts

February 7th, 2012 13:00

From what I can see that is correct. Maybe someone else on the forums will take a glance at it also and give a double take.

Support is open on Saturdays, so if you start to implement it and something seems off. feel free to give them a call.

1-800-981-3355

Keep us updated.

February 7th, 2012 13:00

Excellent. Thank you very much

4 Posts

February 8th, 2012 05:00

The switches are not live yet, but I will be testing this weekend to verify that everything is working.

February 8th, 2012 06:00

Another Question. My servers and firewall are going to be on VLAN 1 along with the L3 switch, should the servers have the ip address of the L3 switch as the default gateway or can i just give them the ip of our firewall?

5 Practitioner

 • 

274.2K Posts

February 10th, 2012 11:00

You should not have any issues just giving them the IP of the firewall.

February 10th, 2012 13:00

Thank you. I will be testing tomorrow and will let you know how it goes.

May 9th, 2012 13:00

This was never implemented. There were too many issues. Now I am in a situation that I have to implement this and get  this working. The issue I was having was that users were unable to access the internet. That seems to have been a firewall issue which I think i have down now. I am really hoping that this works. Does anyone else have any advice about implementing VLANs in a network.

5 Practitioner

 • 

274.2K Posts

May 9th, 2012 13:00

Here are some good white pages that go over VLANs.

What is VLAN routing?

www.dell.com/.../app_note_38.pdf

VLAN-Based Network Segmentation

www.dell.com/.../app_note_8.pdf

VLAN Interoperability

www.dell.com/.../app_note_4.pdf

Those documents should help answers questions you have, and help get an idea on planning and implementing.

Let us know if you have any specific questions.

Thanks.

August 22nd, 2012 07:00

This solutions still is not working. I am at a point where i need to have this done as soon as possible. After researching i found that VLAN 1 is not routable. Right now we are just subnetting our network. No VLANs for data. We are implementing VOIP and an MPLS for our California office. Right now i am just trying to get everything working. and routable. Should i just change the management VLAN on the switch and move everything else to that VLAN?

Example: Currently all Devices on on VLAN1, Should I move the management of the switch to, lets say VLAN2 , and move all switches and ports to VLAN2? I have an ASA 5520 with is the degault gateway for all of our devices. I have move the ASA to VLAN2 I should still be able to set the default gateway of the ASA on our network correct?

5 Practitioner

 • 

274.2K Posts

August 22nd, 2012 07:00

DM sent, look forward to your reply.

Thanks

No Events found!

Top