Start a Conversation

Unsolved

This post is more than 5 years old

19956

May 29th, 2009 09:00

Connect two PowerConnect 5424’s to a Nortel 1612

Situation:  Connect two PowerConnect 5424’s to a Nortel 1612

Criteria:

PowerConnect #1 (name=PWY)

VLan 10 on ports 13-18
VLan 172 on ports 2-12
VLan 192 on port 19

PowerConnect #2 (name=MH)

VLan 172 on ports 2-9
VLan 192 on port 19

PWY’s ports 23 and 24 are connected to ports 6 and 7 on a Nortel 1612 via Fibre and are aggregated for load balancing and to provide VLans 10,and 192.  Ports 21 and 22 are connected to MH’s ports 21 and 22 via fibre and aggregated for load balancing and to provide VLans 172 and 192.

The Nortel ‘s ports 6 and 7 provide VLans 1,10,64,and 192 (yes, you can have multiple VLans served up on a single port with a Nortel Enterprise class switch).

Problem:

When I leave all the ports on the PowerConnects set to VLan 1 the computers attached to them can all talk to each other.  When I set up the VLans, all communications stops.  The VLans are required for security and to keep traffic managed.

How can I make this happen?

Thanks in advance

-mike

909 Posts

May 29th, 2009 09:00

post your config files please.

909 Posts

May 29th, 2009 10:00

I cannot see those files.  Can you just cut and paste them?

9 Posts

May 29th, 2009 10:00

Here ya go..

---MH---

interface range ethernet g(3,23-24)
switchport mode trunk
exit
vlan database
vlan 172,192
exit
interface range ethernet g(2,4-9)
switchport access vlan 172
exit
interface ethernet g3
switchport trunk native vlan 172
exit
interface ethernet g19
switchport access vlan 192
exit
interface vlan 172
name iSCSI
exit
interface vlan 192
name Heartbeat
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
port-channel load-balance layer-3
iscsi target port 860 address 0.0.0.0 
iscsi target port 3260 address 0.0.0.0 
interface vlan 1
ip address 10.23.0.31 255.255.255.0 
exit
ip default-gateway 10.23.0.1
username RWA password d41d8cd98f00b204e9800998ecf8427e level 15 encrypted
---PWY---
interface range ethernet g(13,23-24)
switchport mode trunk
exit
vlan database
vlan 10,172,192
exit
interface range ethernet g(2-12)
switchport access vlan 10
exit
interface range ethernet g(14-18)
switchport access vlan 172
exit
interface ethernet g13
switchport trunk native vlan 172
exit
interface ethernet g19
switchport access vlan 192
exit
interface vlan 10
name Internal
exit
interface vlan 172
name iSCSI
exit
interface vlan 192
name Heartbeat
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0 
iscsi target port 3260 address 0.0.0.0 
interface vlan 1
ip address 10.23.0.30 255.255.255.0 
exit
ip default-gateway 10.23.0.1
username RWA password d41d8cd98f00b204e9800998ecf8427e level 15 encrypted

909 Posts

May 29th, 2009 11:00

 

On PowerConnect you must explicitly add vlans to trunk ports.   So try this:

interface range ethernet g(3,23-24)
switchport mode trunk

switchport trunk allowed vlan add all
exit
--------------------

"switchport trunk allowed vlan add all" adds all the currently defined vlans to the trunk.   If vlans are added to the vlan database later, your will have to run this command again or add them specifically to the trunk.

9 Posts

May 29th, 2009 12:00

Awesome.... now I have the two Dell's talking to each other... but they still do not talk to the Nortel.  Any help there?

just a point... I am able to ping the Nortel from the Dell switches but and not able to ping the Dells from the Nortel....  just added info.

9 Posts

May 29th, 2009 14:00

Guess maybe I left some wording out..... 

This is the situation that I need:

Port #1 on all switches are left as VLan1 for management purposes.

PowerConnect #1 (name=PWY)

VLan 10 on ports 13-18
VLan 172 on ports 2-12
VLan 192 on port 19

PowerConnect #2 (name=MH)

VLan 172 on ports 2-9
VLan 192 on port 19

PWY’s ports 23 and 24 are connected to ports 6 and 7 on a Nortel 1612 via Fibre and are aggregated for load balancing and to provide VLans 10,and 192.  Ports 21 and 22 are connected to MH’s ports 21 and 22 via fibre and aggregated for load balancing and to provide VLans 172 and 192.

The Nortel ‘s ports 6 and 7 provide VLans 1,10,64,and 192 (yes, you can have multiple VLans served up on a single port with a Nortel Enterprise class switch).

 

The config files I sent were of what I tried to set up to make it work.  So here are the current config files:

PWY:

interface range ethernet g(13,21-24)
switchport mode trunk
exit
vlan database
vlan 10,172,192
exit
interface range ethernet g(2-12)
switchport access vlan 10
exit
interface range ethernet g(21-24)
switchport trunk allowed vlan add 10
exit
interface range ethernet g(14-18)
switchport access vlan 172
exit
interface ethernet g13
switchport trunk native vlan 172
exit
interface range ethernet g(21-24)
switchport trunk allowed vlan add 172
exit
interface ethernet g19
switchport access vlan 192
exit
interface range ethernet g(21-24)
switchport trunk allowed vlan add 192
exit
interface vlan 10
name Internal
exit
interface vlan 172
name iSCSI
exit
interface vlan 192
name Heartbeat
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0 
iscsi target port 3260 address 0.0.0.0 
interface vlan 1
ip address 10.23.0.30 255.255.255.0 
exit
ip default-gateway 10.23.0.1
username RWA password d41d8cd98f00b204e9800998ecf8427e level 15 encrypted
MH:

interface range ethernet g(23-24)
switchport mode trunk
exit
vlan database
vlan 172,192
exit
interface range ethernet g(2-9)
switchport access vlan 172
exit
interface range ethernet g(23-24)
switchport trunk allowed vlan add 172
exit
interface ethernet g19
switchport access vlan 192
exit
interface range ethernet g(23-24)
switchport trunk allowed vlan add 192
exit
interface vlan 172
name iSCSI
exit
interface vlan 192
name Heartbeat
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
port-channel load-balance layer-3
iscsi target port 860 address 0.0.0.0 
iscsi target port 3260 address 0.0.0.0 
interface vlan 1
ip address 10.23.0.31 255.255.255.0 
exit
ip default-gateway 10.23.0.1
username RWA password d41d8cd98f00b204e9800998ecf8427e level 15 encrypted
Man, you do not know how much I do appreciate your help!!!  Thanks a million!

909 Posts

May 29th, 2009 14:00

Your config files do not agree with your description.  You said:

"PWY’s ports 23 and 24 are connected to ports 6 and 7 on a Nortel 1612 via Fibre and are aggregated for load balancing and to provide VLans 10,and 192.  Ports 21 and 22 are connected to MH’s ports 21 and 22 via fibre and aggregated for load balancing and to provide VLans 172 and 192.

The Nortel ‘s ports 6 and 7 provide VLans 1,10,64,and 192 (yes, you can have multiple VLans served up on a single port with a Nortel Enterprise class switch)."

The config file differences:

-  ports 21 and 22 are not configured.  So they are not aggregated and they are not in vlans 172 and 192.  They are access ports in vlan 1 on both switches. and there is a loop between the PowerConnects that has bee fixed by spanning tree.

- ports 23 and 24 are not aggregated.  If the Nortel ports 6 and 7 are aggregated, then the PowerConnect might see a loop and traffic on one of the 2 links from the Nortel would be dropped.

So,  I suggest this:


interface range ethernet g21-22
channel-group 1 mode on
exit
interface port-channel 1
switchport mode trunk

switchport trunk allowed vlan add all
exit

interface range ethernet g23-24
channel-group 2 mode on
exit
interface port-channel 2
switchport mode trunk

switchport trunk allowed vlan add all
exit

909 Posts

June 1st, 2009 10:00

Your comments interleaved wiith configurations below:

! PowerConnect #1 (name=PWY):
vlan database
vlan 10,172,192
exit

! VLan 10 on ports 13-18
interface range ethernet g(13-18)
switchport access vlan 10
exit

! VLan 172 on ports 2-12

interface range ethernet g(2-12)
switchport access vlan 172
exit

! VLan 192 on port 19

! PWY’s ports 23 and 24 are connected to ports 6 and 7 on a Nortel 1612 via Fibre and are aggregated for load balancing

interface range ethernet g(23-24)
channel-group 1 mode on
exit

! and to provide VLans 10,and 192. 
interface port-channel 1

switchport mode trunk

switchport trunk allowed vlan add 10,192

exit

!Ports 21 and 22 are connected to MH’s ports 21 and 22 via fibre and aggregated for load balancing

interface range ethernet g(21-22)
channel-group 2 mode on
exit

! to provide VLans 172 and 192. 
interface port-channel 2

switchport mode trunk

switchport trunk allowed vlan add 172,192

exit

--------------------------------------------------------------

! PowerConnect #2 (name=MH)

 

vlan database
vlan 172,192
exit

!VLan 172 on ports 2-9

interface range ethernet g(2-9)
switchport access vlan 172
exit


! VLan 192 on port 19

 

interface ethernet g(19)
switchport access vlan 192
exit

interface ethernet g(19)
switchport access vlan 192
exit

!Ports 21 and 22 are connected to MH’s ports 21 and 22 via fibre and aggregated for load balancing

interface range ethernet g(21-22)
channel-group 2 mode on
exit

 

! to provide VLans 172 and 192. 
interface port-channel 2

 

switchport mode trunk

switchport trunk allowed vlan add 172,192

exit

interface ethernet g(19)
switchport access vlan 192
exit

No Events found!

Top