1 Copper

DNS Issue with PC6248


I am having an issue with name resolution on a PowerConnect 6248 specifically around the SNTP function.  I have taken the switch down to a very basic config; no VLANs , no routing, just basic IP settings for the switch.  I have tried several different NTP sources, all with the same result.  When configuring the time server as an IP address the time sync works just fine. When configuring the time server as an FQDN I see the following messages in the buffer log:

Failed to Resolve DNS address for Server (null)

This message repeats every 64 seconds which is my currently configured poll cycle.

Here are some details on the switch:

Management Standby Preconfig Plugged-in Switch Code
SW Status Status Model ID Model ID Status Version
--- ---------- --------- ------------- ------------- ------------- -----------
1 Mgmt Sw PCT6248 PCT6248 OK


console#show running-config
!Current Configuration:
!System Description "PowerConnect 6248,, VxWorks 6.5"
!System Software Version
!Cut-through mode is configured as disabled
sntp unicast client enable
sntp server 0.us.pool.ntp.org
clock timezone -7 minutes 0 zone "ARIZ"
member 1 2
ip address x.x.x.x
ip default-gateway x.x.x.x
ip name-server
username "user" password --- level 15 encrypted


The fact that has me completely stumped is that when I ping the NTP server on the switch console, name resolution is successful and I receive good replies from the server.

Any suggestions are appreciated!


0 Kudos
4 Replies

RE: DNS Issue with PC6248

I do not recall ever running into any issues like this. What is the status of the the command # show sntp configuration.

Do you have any other switches/devices configured like this and working?

Have you considered doing a packet capture on the switch uplink interface? You could then filter for sntp packets and get a better understanding of what communication is taking place.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
1 Nickel

RE: DNS Issue with PC6248

0.us.pool.ntp.org will resolve to 4 random IPs that are in the Public NTP pool. I suspect the switch is expecting one IP address for the configuration line sntp server 0.us.pool.ntp.org and can't handle the multiple IP addresses that are returned.  You can probably confirm by pointing to a FQDN NTP time server and see if that resolves the issue.  Feel free to test using one of mine: ntp0.intrax.com (, which is a stratum 1 in the Public NTP pool.  You probably don't want to leave it like that long-term however because I'm on the east coast and you probably want one closer to Arizona.

I have a different switch than you do so the lines below may not be applicable.  For my switch, I also have these configuration lines in my switch:

  • clock source sntp
  • sntp server A.B.C.D poll

1 Nickel

RE: DNS Issue with PC6248

Does this idea suggested by @Joel_McClung help? I'm experiencing exactly the same issue btw (also trying to use the ntp.org pool - but the German one).

It seems to be a common problem on PCT 6248 or more switches from the 6200 series, even on the latest and greatest firmware version.

Happy New Year (even if it's already a few days old) and best regards


EDIT: I'm with Joel - it could be the Round Robin method to randomly choose NTP Servers, but I don't think so anymore after trying to use three German timeservers from different universities. I can also see a

Failed to Resolve DNS address for Server (null)"

in the debug log, but those servers are definitely not using Round Robin. 

Even if I only specify one address (e.g. times.tubit.tu-berlin.de) it will fail. Does it only accept numeric IPs?


I'm my own CTO! Smiley Happy Dell PowerConnect 6248 + HP ProLiant SE326M1 R2
0 Kudos
1 Copper

RE: DNS Issue with PC6248

Use the IP address for the NTP server instead. worked for me. only problem is it can't add the offset correctly to the DAY, only to the time. So if it's 10pm, and I have an offset of +13, the time gets updated to 11am correctly however the date still stays as the previous day.
0 Kudos