Highlighted
Mike J Smith
1 Copper

Dell 5448 and 5424 Switch - Completely Remove iSCSI optimization.

I have Dell 5448 and 5424 switches that were used for LAN/iSCSI traffic but now will be used exclusively for LAN traffic. A network consultant I work with recommended removing all iSCSI optimization to improve switch performance for LAN traffic.

I have read the following article: http://en.community.dell.com/techcenter/storage/w/wiki/configuring-a-powerconnect-5424-or-5448-switch-for-use-with-an-iscsi-storage-system.aspx

If I disable the global iSCSI optimization and remove the default iSCSI targets of 860 and 3260, will I need to reboot the switch or are the changes live instantly?

Are there any other configuration settings I need to check to be sure the iSCSI optimization is completely disabled?  I have Jumbo Frames and Flow Control disabled.

The changes will be done via the web interface and not the CLI. Will that make any difference?

0 Kudos
6 Replies
Moderator
Moderator

Re: Dell 5448 and 5424 Switch - Completely Remove iSCSI optimization.

Once you apply the changes to the Web GUI they will take place immediately on the running configuration. If you want the configuration to be consistent through a reboot, you will need to copy the running config to the startup config.

Files can be copied and deleted from the Copy Files page. To open the Copy Files page, click

System→ File Management→ Copy Files in the tree view.

Once you get the changes made, feel free to post up your current config and we can look through it for any suggested changes,

Cheers

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
Mike J Smith
1 Copper

Re: Dell 5448 and 5424 Switch - Completely Remove iSCSI optimization.

Here are the results from the following commands:

show running-config

show iscsi

show vlan

If I read the "show vlan" results correctly, there are no vlans setup on the switch other than the default? Again, my goal is to remove iscsi optimization and optimize this switch for LAN traffic between workstations and servers.

console# show running-config

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

iscsi target port 860 address 0.0.0.0

iscsi target port 3260 address 0.0.0.0

interface vlan 1

ip address ***Removed

exit

username and password  *** Removed

snmp-server community Dell_Network_Manager rw view DefaultSuper

Default settings:

Service tag: *** Removed

SW version 2.0.0.35 (date  27-Jan-2009 time  18:13:34)

Gigabit Ethernet Ports

=============================

no shutdown

speed 1000

duplex full

negotiation

flow-control off

mdix auto

no back-pressure

interface vlan 1

interface port-channel 1 - 8

spanning-tree

spanning-tree mode STP

qos basic

qos trust cos

console#

console# show iscsi

iSCSI enabled

iSCSI vpt is 5, Remark

iSCSI aging time: 5 min.

Maximum number of connections: 256

iSCSI targets and TCP ports:

----------------------------

TCP     Target IP     Name

Port    Address

----    ---------     ----

 860    0.0.0.0

3260    0.0.0.0

console#

console# show vlan

Vlan       Name                   Ports                Type     Authorization

---- ----------------- --------------------------- ------------ -------------

1           1               g(1-48),ch(1-8)          other       Required

console#

0 Kudos
Moderator
Moderator

Re: Dell 5448 and 5424 Switch - Completely Remove iSCSI optimization.

iscsi optimization is still enabled on this config. You should be able to run this command to disable the optimization.

#no iSCSI enabled

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
Mike J Smith
1 Copper

RE: Dell 5448 and 5424 Switch - Completely Remove iSCSI optimization.

Here is the config after the iscsi was disabled.

console# show running-config
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0
iscsi target port 3260 address 0.0.0.0
no iscsi enable
interface vlan 1
ip address *** removed
exit
username password *** removed

Default settings:
Service tag: *** removed

SW version 2.0.0.35 (date  27-Jan-2009 time  18:13:34)

Gigabit Ethernet Ports
=============================
no shutdown
speed 1000
duplex full
negotiation
flow-control off
mdix auto
no back-pressure

interface vlan 1
interface port-channel 1 - 8

spanning-tree
spanning-tree mode STP

qos basic
qos trust cos
console# show iscsi

iSCSI disabled
iSCSI vpt is 5, Remark
iSCSI aging time: 5 min.

Maximum number of connections: 256

iSCSI targets and TCP ports:
----------------------------

TCP     Target IP     Name
Port    Address
----    ---------     ----
  860    0.0.0.0
 3260    0.0.0.0
console#

0 Kudos
Moderator
Moderator

RE: Dell 5448 and 5424 Switch - Completely Remove iSCSI optimization.

Looking good. If you wanted to remove those iscsi targets you could run the command

no iscsi target port tcpport-1 [tcp-port-2… tcp-port-8] [address ip-address]

How is the switch running?

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
Mike J Smith
1 Copper

RE: Dell 5448 and 5424 Switch - Completely Remove iSCSI optimization.

Switch seems to be running good.  I am new to all this so I am not sure if I have the switch in its optimal condition in order to move network traffic along at the best possible rate. I think I have it, just not 100 % sure.

0 Kudos