Highlighted
jimbennin
2 Bronze

Dell 6224 Class of Service Setup

We have several Dell 6200 series switches running 3.3.5.5. We are putting in several Avaya G430 Gateway units at various locations and are attempting to configure the switches to utilize Class of Service Queing in order to handle DSCP 46 class 5 traffic marked with hi priority. 

Part of this process is setting up 3 laptops with the ability to generate simulated VOIP traffic to and from each site.  To date,  we haven't been able to get a good clean test and it's as if our COS settings are not applying.  We've mapped the Class 5 to Hardware queue 6 and also mapped DSCP to queue 6 within the DSCP mapping table.  We've also configured STRICT priority globally on all interface for que 6.

In general,  we have 3 VLAN's that are setup to route between one another as well as site to site.  What could I be missing?  Are there any other mechanisms within the switches that would supersede the COS settings? 

0 Kudos
8 Replies
Moderator
Moderator

Re: Dell 6224 Class of Service Setup

Can you show us your current configuration? We can look at it and see how things are currently configured and see if we can offer some suggested changes.

Thanks

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
jimbennin
2 Bronze

Re: Dell 6224 Class of Service Setup

Below is a SHOW RUN from our main router

***-***-6224E#show running-config

!Current Configuration:

!System Description "PowerConnect 6224, 3.3.5.5, VxWorks 6.5"

!System Software Version 3.3.5.5

!Cut-through mode is configured as disabled

!

configure

vlan database

vlan 2,10,20,30,40,50,60,99,700,999

vlan routing 2 1

vlan routing 99 2

vlan routing 1 3

exit

snmp-server location "DAFTER CORE 2 POST RACK"

snmp-server contact "CEC IT DEPARTMENT"

hostname "***-***-6224E"

sntp unicast client enable

sntp server 10.24.43.15

clock summer-time recurring USA

clock timezone -5 minutes 0 zone "UTC"

stack

member 1 1

--More-- or (q)uit

member 2 1

exit

ip address 192.168.2.1 255.255.255.0

ip address vlan 999

ip routing

ip route 192.168.101.0 255.255.255.0 10.99.99.8

ip route 10.24.45.0 255.255.255.0 10.99.99.2

ip route 10.24.243.96 255.255.255.224 10.99.99.4

ip route 10.24.243.64 255.255.255.224 10.99.99.3

ip route 10.24.8.0 255.255.255.224 10.99.99.6

ip route 10.24.8.32 255.255.255.224 10.99.99.5

ip route 172.21.2.0 255.255.255.0 172.21.1.9

ip route 172.21.3.0 255.255.255.0 10.99.99.3

ip route 172.21.4.0 255.255.255.0 10.99.99.4

ip route 0.0.0.0 0.0.0.0 10.24.43.252

ip route 10.24.46.0 255.255.255.0 10.99.99.7

ip route 172.27.2.0 255.255.255.0 10.99.99.7

ip route 172.25.2.0 255.255.255.0 10.99.99.5

ip route 172.26.2.0 255.255.255.0 10.99.99.6

interface vlan 1

routing

--More-- or (q)uit

ip address 10.24.43.253 255.255.255.0

exit

interface vlan 2

name "VOIP"

routing

ip address 172.21.1.254 255.255.255.0

bandwidth 10000

ip mtu 1500

exit

interface vlan 10

name "DATA"

exit

interface vlan 20

name "FUTVOIP"

exit

interface vlan 30

name "RADIO"

exit

interface vlan 40

name "VIDEO"

exit

--More-- or (q)uit

interface vlan 50

name "SCADA"

exit

interface vlan 60

name "WIFI"

exit

interface vlan 99

name "PFN"

routing

ip address 10.99.99.1 255.255.255.0

exit

interface vlan 700

name "LIGHTHOUSE"

exit

interface vlan 999

name "Management"

exit

username "administrator" password 6ded2ffeeafe66e184083d614a0d83c2 level 15 encrypted

classofservice dot1p-mapping 5 6

classofservice trust ip-dscp

classofservice ip-dscp-mapping 46 6

--More-- or (q)uit

cos-queue strict 6

!

interface ethernet 1/g1

channel-group 1 mode auto

switchport voice detect auto

description 'LAG_to_CORE'

exit

!

interface ethernet 1/g2

channel-group 1 mode auto

switchport voice detect auto

description 'LAG_to_CORE'

exit

!

interface ethernet 1/g3

switchport voice detect auto

exit

!

interface ethernet 1/g4

switchport voice detect auto

exit

--More-- or (q)uit

!

interface ethernet 1/g5

switchport voice detect auto

exit

!

interface ethernet 1/g6

switchport voice detect auto

exit

!

interface ethernet 1/g7

switchport voice detect auto

exit

!

interface ethernet 1/g8

switchport voice detect auto

exit

!

interface ethernet 1/g9

switchport voice detect auto

exit

!

--More-- or (q)uit

interface ethernet 1/g10

switchport voice detect auto

exit

!

interface ethernet 1/g11

switchport voice detect auto

exit

!

interface ethernet 1/g12

switchport voice detect auto

exit

!

interface ethernet 1/g13

switchport voice detect auto

exit

!

interface ethernet 1/g14

switchport voice detect auto

exit

!

interface ethernet 1/g15

--More-- or (q)uit

negotiation 100f

switchport voice detect auto

exit

!

interface ethernet 1/g16

switchport voice detect auto

description 'TrunktoDAFAVAYA6224'

switchport access vlan 2

exit

!

interface ethernet 1/g17

no negotiation

switchport voice detect auto

description 'G430LAN'

switchport access vlan 2

exit

!

interface ethernet 1/g18

switchport voice detect auto

description 'ClearChannel'

switchport access vlan 2

--More-- or (q)uit

exit

!

interface ethernet 1/g19

switchport voice detect auto

exit

!

interface ethernet 1/g20

switchport voice detect auto

exit

!

interface ethernet 1/g21

switchport voice detect auto

exit

!

interface ethernet 1/g22

switchport voice detect auto

exit

!

interface ethernet 1/g23

switchport voice detect auto

exit

--More-- or (q)uit

!

interface ethernet 1/g24

switchport voice detect auto

description 'PFN'

switchport access vlan 99

exit

!

interface ethernet 1/xg1

switchport voice detect auto

exit

!

interface ethernet 1/xg2

switchport voice detect auto

exit

!

interface ethernet 1/xg3

switchport voice detect auto

exit

!

interface ethernet 1/xg4

switchport voice detect auto

--More-- or (q)uit

exit

!

interface ethernet 2/g1

channel-group 1 mode auto

description 'LAG_to_CORE'

exit

!

interface ethernet 2/g2

channel-group 1 mode auto

description 'LAG_to_CORE'

exit

!

interface ethernet 2/g3

channel-group 2 mode auto

description 'LAGtoTELCO'

exit

!

interface ethernet 2/g4

channel-group 2 mode auto

description 'LAGtoTELCO'

exit

--More-- or (q)uit

!

interface ethernet 2/g5

channel-group 3 mode auto

description 'LAGtoRCDS'

exit

!

interface ethernet 2/g6

channel-group 3 mode auto

description 'LAGtoRCDS'

exit

!

interface port-channel 1

switchport voice detect auto

description 'lag_1'

exit

!

interface port-channel 2

switchport voice detect auto

exit

!

interface port-channel 3

--More-- or (q)uit

switchport voice detect auto

exit

!

interface port-channel 4

switchport voice detect auto

exit

!

interface port-channel 5

switchport voice detect auto

exit

!

interface port-channel 6

switchport voice detect auto

exit

!

interface port-channel 7

switchport voice detect auto

exit

!

interface port-channel 8

switchport voice detect auto

--More-- or (q)uit

exit

!

interface port-channel 9

switchport voice detect auto

exit

!

interface port-channel 10

switchport voice detect auto

exit

!

interface port-channel 11

switchport voice detect auto

exit

!

interface port-channel 12

switchport voice detect auto

exit

!

interface port-channel 13

switchport voice detect auto

exit

--More-- or (q)uit

!

interface port-channel 14

switchport voice detect auto

exit

!

interface port-channel 15

switchport voice detect auto

exit

!

interface port-channel 16

switchport voice detect auto

exit

!

interface port-channel 17

switchport voice detect auto

exit

!

interface port-channel 18

switchport voice detect auto

exit

!

--More-- or (q)uit

interface port-channel 19

switchport voice detect auto

exit

!

interface port-channel 20

switchport voice detect auto

exit

!

interface port-channel 21

switchport voice detect auto

exit

!

interface port-channel 22

switchport voice detect auto

exit

!

interface port-channel 23

switchport voice detect auto

exit

!

interface port-channel 24

--More-- or (q)uit

switchport voice detect auto

exit

!

interface port-channel 25

switchport voice detect auto

exit

!

interface port-channel 26

switchport voice detect auto

exit

!

interface port-channel 27

switchport voice detect auto

exit

!

interface port-channel 28

switchport voice detect auto

exit

!

interface port-channel 29

switchport voice detect auto

--More-- or (q)uit

exit

!

interface port-channel 30

switchport voice detect auto

exit

!

interface port-channel 31

switchport voice detect auto

exit

!

interface port-channel 32

switchport voice detect auto

exit

!

interface port-channel 33

switchport voice detect auto

exit

!

interface port-channel 34

switchport voice detect auto

exit

--More-- or (q)uit

!

interface port-channel 35

switchport voice detect auto

exit

!

interface port-channel 36

switchport voice detect auto

exit

!

interface port-channel 37

switchport voice detect auto

exit

!

interface port-channel 38

switchport voice detect auto

exit

!

interface port-channel 39

switchport voice detect auto

exit

!

--More-- or (q)uit

interface port-channel 40

switchport voice detect auto

exit

!

interface port-channel 41

switchport voice detect auto

exit

!

interface port-channel 42

switchport voice detect auto

exit

!

interface port-channel 43

switchport voice detect auto

exit

!

interface port-channel 44

switchport voice detect auto

exit

!

interface port-channel 45

--More-- or (q)uit

switchport voice detect auto

exit

!

interface port-channel 46

switchport voice detect auto

exit

!

interface port-channel 47

switchport voice detect auto

exit

!

interface port-channel 48

switchport voice detect auto

exit

banner motd acknowledge

snmp-server community cecsnmp ro ipaddress 10.24.43.180

snmp-server community public ro ipaddress 192.168.101.251

exit

***-***-6224E#qu

0 Kudos
jimbennin
2 Bronze

Re: Dell 6224 Class of Service Setup

With  a packet sniffer setup to monitor the sending DSCP marked device,  i'm not seeing the IP4 packets as having the necessary markings....so i've either got a port config issue on my dell or the test box isn't correctly configured to send data.

0 Kudos
jimbennin
2 Bronze

Re: Dell 6224 Class of Service Setup

Does anyone know if my Dell 6224 could be stripping off the DSCP Marked packets and setting them to a default 0x00 instead of 0x2e (46)?  Using wireshark,  i'm only seeing 0x00 on a port mirroring one of the sending systems configured to send UDP packets marked via DSCP = 46.  The switch is configured globally via GUI for Trust Mode = IP DSCP.  

0 Kudos
Moderator
Moderator

Re: Dell 6224 Class of Service Setup

I have been trying to look into this some and not really getting anywhere. One idea was to remove the voice auto setting on the ports and then check the packets again. I am not sure if the voice auto setting is conflicting against the global COS settings.

Another idea if that does not work, is to enable a voice VLAN which will prioritize traffic without having to manually set it.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
jimbennin
2 Bronze

Re: Dell 6224 Class of Service Setup

I did both of the suggested steps with no change...thank you for the suggestions though!

0 Kudos
jimbennin
2 Bronze

Re: Dell 6224 Class of Service Setup

Good news...it's not the switch configuration, it is the Panasonic Toughbook CF53 that is NOT properly marking the DCSP on the packets.  Thank you for any support you've provided

0 Kudos
Moderator
Moderator

Re: Dell 6224 Class of Service Setup

Good job getting this figured out. We have been looking at various settings to try but not making any headway. So it's good to know it was a factor outside the switch.

Thanks again for keeping us updated.

Cheers.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos