Start a Conversation

Unsolved

This post is more than 5 years old

M

23103

February 15th, 2013 00:00

Dell 6248 - iscsi is enable with vlan ports1-20 , can i use remaining ports for inter vlan routing ?

 
Hi 
I need to configure inter vlan routing but already we have configure vlan 11 for ISCSI  traffic from port  1 to 21
and i want to use reaming ports for inter vlan communications .
 
Here iSCSI traffic was in 172.16.X.X 255.255.248.0
and vlan traffic will be 192.168.X.X. 255.255.255.0
 
can i reconfigure device :
 
configure

vlan database

vlan 150,200,250

exit

stack

member 1 2

exit

ip address 192.168.222.2

ip default-gateway 192.168.222.1


no logging on

interface vlan 201

name "Vlan201"

routing

ip address 192.168.201.1 255.255.255.0

exit

interface vlan 202

name "Vlan202"

routing

ip address 192.168.202.1 255.255.255.0

exit

interface vlan 203

name "Vlan203"

routing

ip address 192.168.222.1 255.255.255.0

exit
 
Along with old configuration?
Please any one can help me ?
 
 
 
Our Present configuration:
show running-config 
!Current Configuration:
!System Description "PowerConnect 6248, 3.3.4.1, VxWorks 6.5"
!System Software Version 3.3.4.1
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 11
exit
hostname "EQL-SAN-SWITCH"
stack
member 1 2
exit
ip address 172.16.16.50 255.255.248.0
ip default-gateway 172.16.16.8
interface vlan 11
name "ISCSI"
exit
username "admin" password 5f4dcc3b5aa765d61d8327deb882cf99 level 15 encrypted
no spanning-tree
!
interface ethernet 1/g1
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g2
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g3
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g4
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g5
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g6
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g7
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g8
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g9
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g10
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g11
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g12
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g13
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g14
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g15
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g16
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g17
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g18
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g19
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
!
interface ethernet 1/g20
spanning-tree portfast
mtu 9216
switchport access vlan 11
exit
exit

EQL-SAN-SWITCH#show vlan

VLAN Name Ports Type Authorization
----- --------------- ------------- ----- -------------
1 Default ch1-48, Default Required
1/g21-1/xg4
11 ISCSI 1/g1-1/g20 Static

5 Practitioner

 • 

274.2K Posts

February 15th, 2013 05:00

You can absolutely add additional VLANs to your configuration.

Create the VLANs you want to add to the switch.

console(config)# vlan database

console(config-vlan)# vlan 150

console(config-vlan)# exit

You can then name VLAN and enable routing on any of the VLANs you want to route.

console(config)# interface vlan 150

console(config-if)# name Marketing

console(config-if)# routing

console(config-if)# end

Then say you have a workstation you want to be in that VLAN, you would place the interface in access mode for the VLAN you want it to participate in.

console(config)# interface ethernet 1/e24

console(config-if)# switchport mode access

console(config-if)# switchport access vlan 150

You still need a layer 3 device on the network to perform routing. If the 6248 is what you intend to use as layer 3 device. Then you will need to enable routing on it.

console(config)# ip routing

And assign IP addresses to each of the VLANs.

console(config)# interface vlan 150

console(config-if)#ip address 172.16.100.1 /24

If another device on the network is performing the routing. Then you will need to setup a General port mode connection to that device, allowing the VLANs across it.

console(config)# interface ethernet 1/e7

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 150 tagged

console(config-if)# switchport general pvid 1

console(config-if)# end

The layer 3 device on the network will also need to have the VLANs added to it, and IP addresses assigned to those VLANs.

Here are some documents with great information on VLAN routing.

www.dell.com/.../app_note_38.pdf

www.dell.com/.../app_note_8.pdf

www.dell.com/.../app_note_4.pdf

Hope this information helps.

February 17th, 2013 23:00

can you guided me how to set above configuration

want to create trunk port like 10.10.10.1 /24 and inter connect to L2 Switch 2848

IN 6248:

Step 1:Making  FastEthernet0/24 as trunk port

Step2:creating vlan interface

interface Vlan10
ip address 10.1.10.1 255.255.255.0

IN 2848:

Port 2 to 20 i want to add in vlan and default gateway as 10.1.10.1, Create trunk port and connect it to 6248 Fa0/24 port as uplink

5 Practitioner

 • 

274.2K Posts

February 18th, 2013 05:00

IN 6248:

Step 1:Making  FastEthernet0/24 as trunk port

 

console(config)# interface ethernet 1/e24

console(config-if)# switchport mode trunk

console(config-if)# switchport trunk allowed vlan add 10 tagged

console(config-if)# end

 

 

Step2:creating vlan interface

interface Vlan10

ip address 10.1.10.1 255.255.255.0

 

console(config)# vlan database

console(config-vlan)# vlan 10

console(config-vlan)# exit

console(config)# interface vlan 10

console(config-if)#ip address 10.1.10.1 /24

 

 

IN 2848:

Port 2 to 20 i want to add in vlan and default gateway as 10.1.10.1, Create trunk port and connect it to 6248 Fa0/24 port as uplink

 

Page 124 of the owners manual will guide you through the process of creating a VLAN and defining VLAN members.

http://support.euro.dell.com/support/edocs/network/pc28xx/en/ug/pdf/ug_en.pdf

 

Thanks.

No Events found!

Top