Highlighted
gnicklaw
1 Copper

Dell 6248 switch connect to a Cisco Router

I am still new to the dell 6248 but have set up many Cisco router to Cisco switches.

I have one port on the Cisco router, FE0 set to 10.12.10.1, need to set the Dell 6248 port 23 to 10.12.10.2, connection to the Cisco Router but cannot seem to assign an IP address  to it. How does the Dell 6248 connect to the router?

The internal addresses are 10.10.10.0/16

I have also set up a vlan on the 6248 to VLAN 10, address 10.10.11.1, set ports g1-g22 to this VLAN, ports g47 & g48 are LAG ports connected to the 6224 on ports g23 & g24 are LAG ports

On a 6224 have set VLAN 11, ports g1-g22 to this VLAN.

I have the LAG ports working between the switches.

The configuration below is working as far as the Interface VLAN 10 can only ping devices on the vlan.

interface ethernet 1/g1
switchport mode general
switchport general pvid 10
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 10

interface ethernet 1/g2
spanning-tree portfast
switchport mode general
switchport general pvid 10
switchport general allowed vlan add 10 tagged
exit

Need some advice.

0 Kudos
8 Replies
Moderator
Moderator

Re: Dell 6248 switch connect to a Cisco Router

When assigning an IP address you are giving a VLAN the IP address, not a specific port. The command will look like this.

console(config)#ip address 131.108.1.27 255.255.255.0

If you do this globally then it assigns the IP address to the management VLAN, which is VLAN 1 by default. If you perform the command from a specific VLAN interface, then it assigns that specific VLAN the IP address.

The PowerConnect 6248 will connect to the router using a port configured in General mode. Set the PVID that you want set, and allow the VLANs you want to traverse to the router.

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 11 tagged

console(config-if)# switchport general pvid 10

Check that a default gateway has been set globally.

console(config)#ip default-gateway 10.10.20.1

Make sure that all VLANs on the PowerConnect are on the Cisco and vice versa.

You may need to set a static route helping traffic find that next hop in the network.

Example:

console(config)#ip route 10.10.20.0{IP Address} 255.255.255.0{Subnet mask} 10.10.10.1{next hop}

More information on this can be found on page 725 of the cli guide.

support.dell.com/.../cli_en.pdf

I am not real clear as to the topology you have setup. It seems like this is what you have?

6224 has ports 23 and 24 in a LAG, which then connect to ports 47 and 48 in a LAG on the 6248?

6248 has port 23 that connects to the Cisco router?

6224----6248----Cisco?

If you can confirm how the network is setup, and pull the running configs from the switches, we would be happy to help look it over.

Thanks.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
gnicklaw
1 Copper

Re: Dell 6248 switch connect to a Cisco Router

The router is connected only to the 6248 switch, port g22

So if I read this correct, the port g22 connected to the router is to have a VLAN assigned to it and an IP address. Current VLANS used are 1, 10 and 11 so this could be VLAN 15.

I wou;ld assign VLAN 15 the IP Address 10.12.10.2, then add g22 port to this VLAN. The Router port is 10.12.10.1. Would the default gateway be 10.12.10.1, the router port?

I think I also need to set the VLANS as routable.

Here is most of the configuration excluding client information, pw and snmp

configure

vlan database

vlan 10-11

exit

ip address 10.12.10.4 255.255.254.0

ip default-gateway 10.12.12.1

name "VLAN-10-Servers"

exit

interface vlan 11

name "VLAN-10-Clients"

exit

interface ethernet 1/g47

channel-group 1 mode on

switchport mode general

exit

interface ethernet 1/g48

channel-group 1 mode on

switchport mode general

exit

interface port-channel 1

description 'sw2sw'

switchport mode general

exit

0 Kudos
Moderator
Moderator

Re: Dell 6248 switch connect to a Cisco Router

Port 22 connects the router and the 6248, but I see no configuration for that port. Can you please show us the configuration for port 22.

Yes the default gateway will be the Cisco address.

The basic commands for VLAN routing look like this.

console(config)#ip routing

console(config)#interface vlan 10

console(config-if-vlan2)#routing

console(config-if-vlan2)#exit

console(config)#interface vlan 11

console(config-if-vlan3)#routing

console(config-if-vlan3)#exit

console(config)#interface vlan 15

console(config-if-vlan4)#routing

console(config-if-vlan4)#end

The management VLAN is not routable.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
gnicklaw
1 Copper

Re: Dell 6248 switch connect to a Cisco Router

Thus far there is no configuration on port g/22 to connect to the Cisco router. This is the part I am not sure about.

This is my understanding:

set port g/22 as follows

create VLAN 15, assign IP Address of 10.12.10.2 ( Router is 10.12.10.1)

assign port g/22 to this vlan as a trunk accepting VLANS 10 & 11

interface ethernet 1/g22

switchport mode trunk

switchport trunk pvid 10

switchport trunk allowed vlan add 10 11 tagged

in the Cisco:

interface FestEthernet0/0/0

ip address 10.12.10.1 255.255.254.0

ip access-group 100 in

ip nat inside

ip virtual-reassembly

duplex auto

speed 1000

no cdp enable

!

!

interface GigabitEthernet0/1.10

encapsulation dot1Q 10

!

interface GigabitEthernet0/1.11

encapsulation dot1Q 11

!

interface GigabitEthernet0/1.15

encapsulation dot1Q 615

ip route 10.10.10.0 .0.0 255.255.0.0 10.12.10.2

0 Kudos
Moderator
Moderator

Re: Dell 6248 switch connect to a Cisco Router

You can use Trunk mode but it will not be able to pass traffic on the management VLAN.

So you currently have no connection from the 6248 to the cisco? But are planning on using port 22?

There is no command for trunk pvid, this is used for general mode.

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 11,15  tagged

console(config-if)# switchport general pvid 10

Lets set the connection up and see if we have communication.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
gnicklaw
1 Copper

Re: Dell 6248 switch connect to a Cisco Router

I have set up the switch with each method mentioned but still having issues with PC's on a Vlan to get to the router. The PC's can only ping the vlan ip address.

The switch can ping all the devices when SSH in

I have scraped the config and started again.

Dell switches 6248 and 6224

interface vlan 10

name Server

routing

exit

interface vlan 11

name Client

routing

exit

interface vlan 15

name sw2router

routing

exit

interface ethernet 1/g2-1/g45

description Clients

spanning-tree portfast

switchport mode general

switchport general pvid 10

switchport general allowed vlan add11 tagged

exit

interface ethernet 1/g46

description Connection to Router interface FastEthernet0/0

spanning-tree portfast

switchport mode general

switchport general pvid 11

switchport general allowed vlan add 11,10 tagged

exit

Any help is greatly appreciated

0 Kudos
Moderator
Moderator

Re: Dell 6248 switch connect to a Cisco Router

Here are the few things I have noticed in the config.

Routing is enabled on the VLANs, but I don’t see it enabled on the switch itself.

console(config)#ip routing

I don’t see any ip addresses assigned to VLANs, was this intentional?

What type of client devices are plugging into ports 2-45? Most of the time client devices are plugged into access mode ports. Except for in specific situations like VOIP.

The connection from switch to router is on port 46 and looks good in general mode. But I do not see VLAN 15 on this connection, which was made for the connection between the switch and router.

Spanning tree portfast should be used on access mode ports, not general ports that connect the switch to another networking device.

You may need to place a static route in place, which helps tell the traffic to the next hop in the network. And vice versa on the Cisco set a static route direct traffic back to the 6248.

ip route 0.0.0.0 0.0.0.0 10.12.10.1

Here is another forum user that just recently worked through a very similar situation, and included the running config they used. This can be used as a reference to compare with your config.

en.community.dell.com/.../19480511.aspx

Thanks.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
gnicklaw
1 Copper

Re: Dell 6248 switch connect to a Cisco Router

Sorry, I dumped the configuration and started from scratch.

Clients will be on the 6248 switch

Servers will be on the 6224 switch

The switches have a 2 port LAG between them 6248 ports 47-48, 6224 ports 23-24

The 6248 switch port 46 will be the port to the router

VLAN 15 was going to be on port 46 connected to the router if this is the correct way for a Dell 6248 to connect

interface vlan 10

name Server

ip address 10.10.10.1 255.255.0.0

routing

exit

interface vlan 11

name Client

ip address 10.11.10.1 255.255.255.0

routing

exit

interface vlan 15

name sw2router

ip address 10.12.10.1 255.255.255.0

routing

exit

0 Kudos