ITsurfer
1 Copper

Dell N1524P Switch & Cisco UC320W Configuration

Jump to solution

Hey Guys, 

I was hoping someone has a solution to a current issue I have in regards to a Dell N1524P Switch and a Cisco UC320W IP Phone Controller. 

I have the Dell switch set up as below on all ports:

- Port Mode General

- Untagged traffic is VLAN 1 - Data

- Tagged traffic is VLAN 100 - IP Phone

- Global command for Voice VLAN is activated

Also the switch is configured with ISDP which allows CDP traffic to be compatible. When I look at the ISDP neighbor table it sees the devices using CDP protocol. 

"

switchport mode general

switchport general allowed vlan add 100 tagged

voice vlan 100
"

Data traffic gets sent to the Dell Sonic Wall while the Voice traffic goes out the WAN port of the Cisco UC320W which has it's own dedicated line for voice. 

I found an article that states Port Fast should be on, I will be trying that in a couple days when back on site. The switch is replacing an older Cisco ESW-540-24P where currently the IP phone system works. 

Any ideas?

Thanks so much guys!

0 Kudos
1 Solution

Accepted Solutions
ITsurfer
1 Copper

Re: Dell N1524P Switch & Cisco UC320W Configuration

Jump to solution

Issue was BPDU guard......The dell has it on globally while the BPDU guard is per port basis on the Cisco switch we were replacing. I turned off the global BPDU guard and my settings worked great. 🙂

 

Final settings for the IP phones UC320W and Dell N1524P switch to work were as follows for all ports:

switchport voice vlan
spanning-tree bpdu flooding

ip igmp snooping unregistered floodall

interface Gi1/0/1
spanning-tree portfast
spanning-tree guard loop
switchport mode general
switchport general allowed vlan add 100 tagged
switchport voice vlan 100
storm-control broadcast
exit

0 Kudos
5 Replies
Highlighted
Moderator
Moderator

Re: Dell N1524P Switch & Cisco UC320W Configuration

Jump to solution

Hi,

So what is the issue that you are having with it? Are you wanting the traffic to route differently?

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
ITsurfer
1 Copper

Re: Dell N1524P Switch & Cisco UC320W Configuration

Jump to solution

Hi Josh, 

Let me add a little more detail to my original post. 

Topology is as so:

  • Cisco UC320W has a dedicated internet connection for voice traffic

  • Sonic Wall has a dedicated internet connection for data traffic

  • Cisco ESW-540-24P switch sits in between the sonic wall and the Cisco UC320W

  • In testing, the Dell N1524P was connected to the Cisco ESW-540-24P but the IP phones were not able to pull the config settings from the UC320W nor any computer could get data traffic.

  • Plugging the IP phone into the Cisco ESW-540-24P did pull config from UC320W and works.

  • The Dell switch has ISDP on and enabled on all Ports for Cisco CDP inter-operability.

  • Port on Dell N1524P to Cisco ESW-540-24P and all other ports on the Dell have the below settings: "switchport mode general

switchport general allowed vlan add 100 tagged

voice vlan 100"

  • Port on Cisco ESW-540-24P to Dell N1524P has the settings with: " Switchport mode Trunk Tagged 100 VLAN

Untagged VLAN 1"

Any ideas why the phone can't get any config info from the UC320W? Also appears data traffic does not work, as the laptop can't get an ip address from the DHCP server that sits directly connected to the Cisco ESW-540-24P.

I did read a requirement that port fast needs to be set to on, the Dell switch was not set that way yet. I will be back on site tomorrow. To take out the Cisco ESW-540-24P from the topology and put in the Dell N1524P in it's place. Any suggesting for proper settings on the Dell to allow Cisco IP phones to work with the UC320W? The UC320W will be directly connected to the Dell switch.

0 Kudos
Moderator
Moderator

Re: Dell N1524P Switch & Cisco UC320W Configuration

Jump to solution

Does it support LLDP-MED? That typically is where compatibility issues exist.

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
ITsurfer
1 Copper

Re: Dell N1524P Switch & Cisco UC320W Configuration

Jump to solution

Does operational Status need to be enabled? because everything else says enabled.

 

operational_status.PNG

0 Kudos
ITsurfer
1 Copper

Re: Dell N1524P Switch & Cisco UC320W Configuration

Jump to solution

Issue was BPDU guard......The dell has it on globally while the BPDU guard is per port basis on the Cisco switch we were replacing. I turned off the global BPDU guard and my settings worked great. 🙂

 

Final settings for the IP phones UC320W and Dell N1524P switch to work were as follows for all ports:

switchport voice vlan
spanning-tree bpdu flooding

ip igmp snooping unregistered floodall

interface Gi1/0/1
spanning-tree portfast
spanning-tree guard loop
switchport mode general
switchport general allowed vlan add 100 tagged
switchport voice vlan 100
storm-control broadcast
exit

0 Kudos