Highlighted
ZianPaul
2 Iron

Dell PowerConnect N3024 - LACP and Layer 3 interface

Hi,

Hope someone can help me on this.

I know the N3024 is a layer 3 switch.

 

Can you combine two switch ports via LACP and configure the interface as Layer 3 Port ?

 

Thanks,

Paul

Tags (1)
0 Kudos
7 Replies
Moderator
Moderator

RE: Dell PowerConnect N3024 - LACP and Layer 3 interface

On the N3024 the routing command is given globally.

console(config)#ip routing

Once routing is enabled you then assign IP addresses to each VLAN. Having an IP addresses assigned to the VLAN will enable the VLAN to be routed.

When connecting the N3024 to another switch, whether a single connection or LAG, In most cases you will set that LAG to switchport mode Trunk. The Trunk will allow traffic from multiple VLANs across it.

I hope this info helps you. If not please let me know.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
ZianPaul
2 Iron

RE: Dell PowerConnect N3024 - LACP and Layer 3 interface

Hi,

Thanks for the answer.

However, what I need is to combine to Ethernet Ports into a Port Channel and convert it to a Layer 3 Interface.

In simple terms can I have Layer 3 Port Channels on N3024 ?

Thanks,

Paul

0 Kudos
Moderator
Moderator

RE: Dell PowerConnect N3024 - LACP and Layer 3 interface

On the switch you do not enable routing for individual ports/port channels. It is enabled globally. Once routing is enabled globally on the switch, if the traffic coming in on that port channel is associated with a VLAN that has an IP address, it will be routed.

Can you give us some more insight on what will be connecting to the other end of the port channel?

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
ZianPaul
2 Iron

RE: Dell PowerConnect N3024 - LACP and Layer 3 interface

Hi,

This is my scenario:

I have three sites

Site A: N3024 (to be acquired)

Site B: Catalyst 3750x

Site C: Catalyst 3750x

Site B & C are connected by 2x lines of Single Mode Fiber Cables.

Site A & B will soon be connected via 2x lines of Single Mode Fiber.

on Site B PO1 is a Layer 3 Port Channel (static route to Site C)

on Site C PO1 is a Layer 3 Port Channel (static route to Site B)

The reason for Port Channel in the event a fiber line goes down connectivity will be uninterrupted.

Port Channel has to be  configured as Layer 3 because each sites has localized VLANs. VLANs between sites should be keep local and not traverse the fiber link.

We do not want to implement dynamic routing. Since, we only have few computers per site.

We plan to get a N3024 for Site A and connect it to 3750x @ Site B.

I know N3024 supports LACP and so does 3750x.

However, can you configure Port Channels as Layer 3 interfaces on N3024?

Can you assign an IP address to a port channel on a N3024 ?

Thanks,

Paul

0 Kudos
Moderator
Moderator

RE: Dell PowerConnect N3024 - LACP and Layer 3 interface

To be sure i understand correctly, you do not want clients on the various VLANs  to be able to communicate with each other? However you still want the switches themselves to be able to communicate with each other? Is to manage the switches remotely? What is your end goal?

The port channel is easy to configure. Place the ports into the channel group. Active means LACP. Then to configure the LAG you enter the port-channel interface.

console(config)# interface gigabitethernet 1/0/5

console(config-if-Gi1/0/5)# channel-group 1 mode active

console(config)# exit

console(config)# interface gigabitethernet 1/0/6

console(config-if-Gi1/0/6)# channel-group 1 mode active

console(config)# exit

console(config)# interface port-channel 1

console(config-if-po1)#

Enable routing.

console(config)#ip routing

Create a VLAN that will be used to interconnect the Cicso and PowerConnect.

console(config)#vlan 22

Assign an IP address to VLAN 22

console(config)#interface vlan 22

console(config-if-vlan15)#ip address 192.168.10.10 255.255.255.0

Place the port channel into access mode for VLAN 22

console(config)# interface port-channel 1

console(config-if)#switchport mode access

console(config-if)#switchport access vlan 22

With that setup the port channel will be in VLAN 22. Since VLAN 22 has an IP addresses it is routable. Other VLANs on the switch without an IP address will be isolated and not be able to be routed.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
ZianPaul
2 Iron

RE: Dell PowerConnect N3024 - LACP and Layer 3 interface

Hi,

This is what I mean of Layer 3 - Port Channel Interface. Will I be able to do this on N3024?

This example shows how to add a Layer 3 Ethernet interface 1/5 to channel group 4 in on mode:

switch# config t

switch (config)# interface ethernet 1/5

switch(config-if)# no switchport

switch(config-if)# channel-group 4

This example shows how to create a Layer 3 port-channel interface and assign the IP address:

switch# config t

switch(config)# interface port-channel 4

switch(config-if)# ip address 192.0.2.1/8

Thanks,

Paul

0 Kudos
Moderator
Moderator

RE: Dell PowerConnect N3024 - LACP and Layer 3 interface

On Cisco that is how you assign an IP address to an interface and enable routing on the interface.

On the PowerConnect switches it is done a little different. Instead of assigning a physical interface with an IP address, you assign the VLAN an IP address. Then place the physical ports into the VLAN.

As an example, if you wanted to have each port in a different subnet. You would create 24 VLANs, Assign IP addresses to each VLAN, and then place a port into the specific VLANs.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos