Robert Clemens
1 Nickel

Dell PowerConnect N3048 (v6.2.1.6) DHCP relay issues

I have a Dell N3048 running 6.2.1.6 (latest at time of post). I have multiple vlans and one dhcp server on one of those vlans. I utilize the ip helper-address x.x.x.x dhcp on a vlan that needs dhcp relay and this works..... kind of. Switch is in layer 3 routing mode.

interface vlan 5
ip address 10.1.5.1 255.255.255.0
ip helper-address 10.1.2.12 dhcp

10.1.2.12 is my dhcp server on vlan 2. It is reachable (routable) from vlan 5 and connections between each is fine. As I said some dhcp packets get through while most do not. I'm trying to think of any misc questions that one would ask to avoid "chasing the rabbit". There are no firewalls in between the networks. Both servers that I tested are connected directly to the N3048. All devices using ip helper dhcp experience the same issue so it is not a particular machine. The only device in common of the issue is the Dell N3048. Issue did not persist on old powerconnect switch. I do have layer2 switches below the N3048 and issue persists on them. Again this only started when I replaced my old dell powerconnect switch with the N3048. Remember that this issue is intermittent and almost certainly has to exclusively involve the N3048.

Most of my dhcp packets are never sent to the server but every now and again some are. I put wireshark on my dhcp server to see what it is seeing and used a dhcp test software to simulate dhcp requests.

I can't find any log (even enabled debugging level) that gives any issue. I've always done dhcp relay on many different switches so I'm familiar with the setup. 

I've tried hammering the dhcp server with dhcp tests and from the same subnet it is blazing fast and replies every time. I don't see any local dhcp logs showing anything. And again wireshark doesn't even register incoming dhcp packets as I would suspect because the vlan5 computer is not receiving an offer when the dhcp server sees nothing but is getting an offer when the dhcp server sees a discover packet every time.

Any ideas?

Config dump. (Don't mind the version, this dump is accurate but from the previous firmware)

!Current Configuration:
!System Description "Dell Networking N3048, 6.2.0.5, Linux 3.6.5-1289203e"
!System Software Version 6.2.0.5
!
configure
vlan 2-5,7-8
exit
vlan 2
name "MAIN_DATA"
exit
vlan 3
name "PUBLIC_WIFI"
exit
vlan 4
name "XXXXXXXXXXXXXX"
exit
vlan 5
name "VOIP"
exit
vlan 7
name "DMZ_SERVERS"
exit
vlan 8
name "DMZ_VPN"
exit
slot 1/0 3 ! Dell Networking N3048
sntp unicast client enable
sntp server 10.1.2.12
sntp server 10.1.2.8 priority 2
clock summer-time recurring USA
clock timezone -6 minutes 0 zone "CDT"
stack
member 1 4 ! N3048
exit
interface out-of-band
ip address 10.1.10.2 255.255.255.0 10.1.10.3
exit
ip domain-name "XXXXXXXXXXXXXXXXXXXX"
ip name-server "10.1.2.12"
ip name-server "10.1.2.8"
logging console debugging
logging cli-command
logging web-session
logging file warnings
logging email
logging email from-addr XXXXXXXXXXXXXXXXXXXXXXX
logging email message-type urgent to-addr XXXXXXXXXXXXXXXXXXXXX
logging email message-type non-urgent to-addr XXXXXXXXXXXXXXXXXX
mail-server "XXXXXXXXXXXXXXXX"
security none
username XXXXXXXXXXXXXXXX
password XXXXXXXXXXXXXXX
exit
ip access-list TESTACL
exit
ip routing
interface vlan 2
ip address 10.1.2.2 255.255.255.0
exit
interface vlan 5
ip address 10.1.5.1 255.255.255.0
ip helper-address 10.1.2.12 dhcp
exit
ip route list here.. REMOVED
username "admin" password XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX privilege 15 encrypted
monitor session 1 destination interface Gi1/0/36
monitor session 1 source interface Gi1/0/35
monitor session 1 mode
ip ssh server
ip ssh protocol 2
spanning-tree priority 0
!
interface Gi1/0/1
switchport access vlan 5
exit
!
interface Gi1/0/2
switchport access vlan 5
exit
!
interface Gi1/0/3
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/4
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/5
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/6
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/7
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/8
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/9
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/10
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/11
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/12
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/13
channel-group 1 mode on
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/14
channel-group 1 mode on
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/15
channel-group 2 mode on
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/16
channel-group 2 mode on
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/17
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/18
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/19
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/20
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/21
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/22
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/23
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/24
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/25
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/26
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/27
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/28
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/29
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/30
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/31
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/32
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/33
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/34
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/35
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/36
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/37
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/38
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/39
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/40
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/41
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/42
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface Gi1/0/43
speed 100
switchport access vlan 2
exit
!
interface Gi1/0/44
switchport access vlan 8
exit
!
interface Gi1/0/45
spanning-tree guard root
switchport mode trunk
switchport trunk native vlan 2
switchport trunk allowed vlan 2-5
exit
!
interface Gi1/0/46
spanning-tree guard root
switchport mode trunk
switchport trunk native vlan 2
switchport trunk allowed vlan 2-5
exit
!
interface Gi1/0/47
spanning-tree guard root
switchport mode trunk
switchport trunk native vlan 2
switchport trunk allowed vlan 2-5
exit
!
interface Gi1/0/48
switchport mode trunk
switchport trunk native vlan 2
switchport trunk allowed vlan 2,5
exit
!
interface port-channel 1
description "ESX1"
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface port-channel 2
description "ESX2"
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
switchport general allowed vlan add 3-5,7-8 tagged
exit
!
interface port-channel 128
switchport mode general
switchport general pvid 2
switchport general allowed vlan add 2
exit
snmp-server engineid local XXXXXXXXXXXXXXXXXXX
enable password XXXXXXXXXXXXXXXXXXXXXXXXXX encrypted
line telnet
no exec-banner
no login-banner
no motd-banner
exit
exit

0 Kudos
4 Replies
Moderator
Moderator

RE: Dell PowerConnect N3048 (v6.2.1.6) DHCP relay issues

Hi,

Is it just VLAN 5 that has issues or all of the other VLANs? Trying adding dhcp l2relay and see if that helps. Page 362 http://downloads.dell.com/Manuals/Common/PowerConnect-Nxxx6.2_CLIRef_en-us.pdf

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
Robert Clemens
1 Nickel

RE: Dell PowerConnect N3048 (v6.2.1.6) DHCP relay issues

I had already tried dhcp l2relay but as this is processing in layer3 that won't help and didn't help when I tried it. This is the only other vlan that does dhcp assignment. Also remember that it is actually working, just not consistently.

I can create a new dhcp pool/vlan and see if the same result occurs.

0 Kudos
Highlighted
Robert Clemens
1 Nickel

RE: Dell PowerConnect N3048 (v6.2.1.6) DHCP relay issues

Can't get dhcp relay to work. I moved dhcp relay to a firewall device to test on a subnet and it works beautifully.

I ended up setting up a dhcp server on the voip subnet.

No idea why I can't get this switch to helper the dhcp reliably. Again, dhcp packets sometimes are sent so it's not a "it's completely broken" setup.

Debugging log level provided no information.

0 Kudos
Moderator
Moderator

RE: Dell PowerConnect N3048 (v6.2.1.6) DHCP relay issues

I will report the issue, but due to the inconsistent nature I am not sure what the timeframe for a solution will be.

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos