Highlighted
OneDogGP
1 Copper

Filtering Multicast Traffic

I've got a handful of PowerConnect switches on our network and am experiencing major slowness as a result of our IP security cameras that talk to our phone system.  I moved them off onto their own Vlan, but when our 3524P switch is connected to our 6224 (routing) switch, ping response times between networks go way up and sometimes fail. (And if I disconnect the uplink from the 3524P they go back to normal)  I've tried to setup mulitcast filtering, but that hasn't seemed to help.  Does anyone have any ideas that I can try to fix this?  I basically just want the multicast traffic to stay on the 3524P switch, but still have connectivity from the other networks to be able to talk to the .130 network.  Thanks in advance for any help you can give.

Layout: 

6224 Config:


SWITCH1#show run
!Current Configuration:
!System Description "PowerConnect 6224, 3.3.7.3, VxWorks 6.5"
!System Software Version 3.3.7.3
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 5,10,20,30,40,50
ip igmp snooping 40
vlan routing 10 1
vlan routing 20 2
vlan routing 30 3
vlan routing 40 4
vlan routing 50 5
vlan routing 5 6
vlan association subnet 192.168.99.0 255.255.255.0 5
vlan association subnet 192.168.100.0 255.255.255.0 10
vlan association subnet 192.168.110.0 255.255.255.0 20
vlan association subnet 192.168.120.0 255.255.255.0 30
vlan association subnet 192.168.130.0 255.255.255.0 40
vlan association subnet 192.168.140.0 255.255.255.0 50


vlan association subnet 192.168.250.0 255.255.255.0 1
exit
hostname "SWITCH1"
stack
member 1 1
exit
ip address 192.168.250.10 255.255.255.0
ip default-gateway 192.168.250.1
ip routing
ip route 0.0.0.0 0.0.0.0 192.168.99.2
interface vlan 5
name "Internet"
routing
ip address 192.168.99.1 255.255.255.0
exit
interface vlan 10
name "ServerVlan"
routing
ip address 192.168.100.1 255.255.255.0
ip rip
exit

interface vlan 20
name "GeneralOfficeVlan"
routing
ip address 192.168.110.1 255.255.255.0
ip rip
exit

interface vlan 40
bridge multicast forbidden forward-unregistered
name "SecurityVlan"
routing
ip address 192.168.130.1 255.255.255.0
ip rip
exit

spanning-tree priority 8192
ip igmp snooping
!
interface ethernet 1/g1
switchport access vlan 5
exit

interface ethernet 1/g22
switchport mode trunk
switchport trunk allowed vlan add 10,20
exit
!
interface ethernet 1/g23
switchport mode trunk
switchport trunk allowed vlan add 40
exit
exit

3524P Config:

console# show run
bridge multicast filtering
interface ethernet g3
switchport mode trunk
exit
vlan database
vlan 40
exit
interface range ethernet e(1-24)
switchport access vlan 40
exit
interface ethernet g3
switchport trunk allowed vlan add 40
exit
interface vlan 40
name SecurityVlan
exit
interface vlan 1
ip igmp snooping
exit
interface vlan 40
ip igmp snooping
exit

Default settings:
Service tag:

SW version

Fast Ethernet Ports
==========================
no shutdown
speed 100
duplex full
negotiation
flow-control off
mdix auto
no back-pressure

Gigabit Ethernet Ports
=============================
no shutdown
speed 1000
duplex full
negotiation
flow-control off
mdix auto
no back-pressure

interface vlan 1
interface port-channel 1 - 15

spanning-tree
spanning-tree mode STP

qos basic
qos trust cos

0 Kudos
3 Replies
Moderator
Moderator

RE: Filtering Multicast Traffic

Hi,

What version is the firmware of the 3524? Here is a document on a similar setup on older hardware. http://www.dell.com/downloads/global/products/pwcnt/en/app_note_6.pdf

 

Try adding the ports statically on the 3524 with the bridge multicast address command

ftp://ftp.dell.com/Manuals/all-products/esuprt_ser_stor_net/esuprt_powerconnect/powerconnect-3548_re...

page 115

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
OneDogGP
1 Copper

RE: Filtering Multicast Traffic

Sorry for the delayed response.  The 3524 shows:

console# show version
SW version 2.0.0.40 ( date 06-Dec-2009 time 12:06:16 )
Boot version 2.0.0.00 ( date 03-Sep-2008 time 17:31:01 )
HW version 00.00.02
console#

0 Kudos
Moderator
Moderator

RE: Filtering Multicast Traffic

No problem, it is out of date and the latest version did include some security updates that are recommended. http://www.dell.com/support/drivers/us/en/555/DriverDetails/Product/powerconnect-3524?driverId=G3NHK...

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos