Highlighted
alvincura
1 Copper

Force10 S4820T trunk with PowerConnect N4064

Hello,

I have reviewed the Force 10 documentation, but it introduces concepts with which I am not familiar and it is hard to make sense of it.

Simply, I want to pass VLAN trunk from an N4064 to an S4820T.  For two N4064, it is as simple as set the port connecting both switches with "switchport mode trunk".  The S4820T is giving me tons of trouble.

Please help?

0 Kudos
8 Replies
Anonymous
Not applicable

RE: Force10 S4820T trunk with PowerConnect N4064

On the S4820T the port will need to be placed into hybrid mode. This mode allows one VLAN to be untagged, and multiple VLANs to be tagged.

Example:

FTOS(conf)# interface gi 0/1
FTOS(conf-if)# portmode hybrid
FTOS(conf-if)# switchport
FTOS(conf-if)# no shutdown

FTOS(conf)# interface vlan 1
FTOS(conf-if)# untagged gi 0/1
FTOS(conf-if)# no shut

FTOS(conf)# interface vlan 2
FTOS(conf-if)# tagged gi 0/1
FTOS(conf-if)# no shut

Here are a couple links with some further info that may be useful.

http://dell.to/1hCj2Jc

http://bit.ly/1LiEZpi

Keep us posted

0 Kudos
alvincura
1 Copper

RE: Force10 S4820T trunk with PowerConnect N4064

Thanks muchly.  I will schedule the outage and give it a try.

Stay tuned and best regards!

0 Kudos
alvincura
1 Copper

RE: Force10 S4820T trunk with PowerConnect N4064

Hi there,

So I've put them into portmode hybrid.  However, GVRP is still not propagating VLANs, and the OSPF sessions are not seeing the neighbors.

-----

interface fortyGigE 0/56

no ip address

mtu 9216

portmode hybrid

switchport

flowcontrol rx on tx off  

mac access-group BLOCK in

gvrp enable

no shutdown

router ospf 13

router-id 10.21.0.13

network 10.21.48.0/20 area 10.21.48.0

network 10.20.0.0/16 area 0

network 10.21.64.0/20 area 10.21.64.0

network 10.21.96.0/19 area 10.21.96.0

network 10.21.128.0/18 area 10.21.128.0

network 10.21.192.0/18 area 10.21.192.0

bfd all-neighbors

#show ip ospf neighbor

#show ip ospf database

           OSPF Router with ID (10.21.0.13) (Process ID 13)

-----

Now, a PowerConnect N4064 plugged into the same core switch says this:

#show running-config interface fo1/0/2

gvrp enable

spanning-tree portfast

switchport mode trunk

lldp transmit-tlv sys-desc sys-cap

lldp transmit-mgmt

no lldp tlv-select dcbxp ets-config

no lldp tlv-select dcbxp ets-recommend

no lldp tlv-select dcbxp pfc

no lldp tlv-select dcbxp application-priority

router ospf

router-id 10.21.0.21

network 10.20.0.0 255.255.0.0 area 0.0.0.0

network 10.20.0.0 0.0.255.255 area 0.0.0.0

network 10.21.48.0 0.0.15.255 area 10.21.48.0

network 10.21.64.0 0.0.15.255 area 10.21.64.0

network 10.21.96.0 0.0.31.255 area 10.21.96.0

network 10.21.128.0 0.0.63.255 area 10.21.128.0

network 10.21.192.0 0.0.63.255 area 10.21.192.0

redistribute connected subnets

exit

#show ip ospf neighbor

  Router ID     Priority IP Address      Interface   State            Dead

                                                                      Time

---------------- -------- --------------- ----------- ---------------- ------

172.31.20.1      1        10.20.0.1       Vl1         Two Way/DR-OTHER 34

10.21.0.1        1        10.20.250.116   Vl1         Full/DR-OTHER    33

10.21.0.32       1        10.20.250.152   Vl1         Full/DR-OTHER    35

#show ip ospf database

               Router Link States (Area 0.0.0.0)

Link Id         Adv Router      Age   Sequence Chksm  Options Rtr Opt

--------------- --------------- ----- -------- ------ ------- -------

10.21.0.1       10.21.0.1       924   80000518 6c63   -E----  ---EB

10.21.0.21      10.21.0.21      1206  80000025 6338   -E----  ---E-

10.21.0.32      10.21.0.32      1005  8000051b 6efb   -E----  ---EB

172.31.20.1     172.31.20.1     878   80000312 584f   -E----  -----

               Network Link States (Area 0.0.0.0)

Link Id         Adv Router      Age   Sequence Chksm  Options Rtr Opt

--------------- --------------- ----- -------- ------ ------- -------

10.20.250.116   10.21.0.1       444   800004b2 7aff   -E----

               Network Summary States (Area 0.0.0.0)

Link Id         Adv Router      Age   Sequence Chksm  Options Rtr Opt

--------------- --------------- ----- -------- ------ ------- -------

10.21.48.0      10.21.0.1       564   80000510 bc22   -E----

10.21.48.0      10.21.0.32      345   80000510 02bd   -E----

10.21.64.0      10.21.0.1       205   80000022 f6ca   -E----

10.21.96.0      10.21.0.1       624   80000021 970b   -E----

10.21.128.0     10.21.0.1       145   80000022 436e   -E----

10.21.192.0     10.21.0.1       205   80000022 80f0   -E----

               Summary ASBR States (Area 0.0.0.0)

Link Id         Adv Router      Age   Sequence Chksm  Options Rtr Opt

--------------- --------------- ----- -------- ------ ------- -------

10.21.0.1       10.21.0.32      1664  8000050f 4996   -E----

10.21.0.32      10.21.0.1       1104  8000050f cc13   -E----

               AS External States

Link Id         Adv Router      Age   Sequence Chksm  Options Rtr Opt

--------------- --------------- ----- -------- ------ ------- -------

10.21.0.0       10.21.0.1       444   80000022 95d7

0 Kudos
Anonymous
Not applicable

RE: Force10 S4820T trunk with PowerConnect N4064

Do you have communication across the connection now? Are clients on the S4820T able to communicate with the rest of the network?

Is RSTP being used? GVRP looks like it is enabled on the interface, is it also enabled globally?

Dell(conf)#protocol gvrp

Dell(config-gvrp)#no disable

Dell(config-gvrp)#show config

!

protocol gvrp

no disable

Dell(config-gvrp)#

Page 662 of the configuration guide has an OSPF configuration check list. I would go through this check list to help ensure there was not a skipped step during configuration.

http://dell.to/1Ptvjyw

0 Kudos
alvincura
1 Copper

RE: Force10 S4820T trunk with PowerConnect N4064

Still no GVRP love, I'm afraid.

Dell(conf)#protocol gvrp

Dell(config-gvrp)#no disable

Dell(config-gvrp)#show config

!

protocol gvrp

no disable

Dell(config-gvrp)#do show vlan

Codes: * - Default VLAN, G - GVRP VLANs, R - Remote Port Mirroring VLANs, P - Primary, C - Community, I - Isolated

      O - Openflow

Q: U - Untagged, T - Tagged

  x - Dot1x untagged, X - Dot1x tagged

  o - OpenFlow untagged, O - OpenFlow tagged

  G - GVRP tagged, M - Vlan-stack, H - VSN tagged

  i - Internal untagged, I - Internal tagged, v - VLT untagged, V - VLT tagged

   NUM    Status    Description                     Q Ports

*   1      Active    Production Supernet             U Te 0/0-47

                                                    U Fo 0/48,52,56,60

   200    Inactive

0 Kudos
Anonymous
Not applicable

RE: Force10 S4820T trunk with PowerConnect N4064

Can you grab the output from the following show command.

Dell# show gvrp statistics int fortyGigE 0/56

This should show us the GVRP statistic on that interface. See if there are any failed registrations.

0 Kudos
alvincura
1 Copper

RE: Force10 S4820T trunk with PowerConnect N4064

#show gvrp statistics int fo0/56

Interface Fo 0/56

Join Empty Received: 0

Join In Received: 180

Empty Received: 0

LeaveIn Received: 0

LeaveEmpty Received: 0

LeaveAll Received: 15

JoinEmpty Sent: 0

JoinIn Sent: 168

Empty Sent: 0

LeaveEmpty Sent: 0

leaveIn Sent: 0

leaveAll Sent: 0

Invalid Messages/Attributes skipped:: 0

Failed Registrations: 0

#show vlan

Codes: * - Default VLAN, G - GVRP VLANs, R - Remote Port Mirroring VLANs, P - Primary, C - Community, I - Isolated

      O - Openflow

Q: U - Untagged, T - Tagged

  x - Dot1x untagged, X - Dot1x tagged

  o - OpenFlow untagged, O - OpenFlow tagged

  G - GVRP tagged, M - Vlan-stack, H - VSN tagged

  i - Internal untagged, I - Internal tagged, v - VLT untagged, V - VLT tagged

   NUM    Status    Description                     Q Ports

*   1      Active    SJC Production Supernet (old s  U Te 0/0-47

                                                    U Fo 0/48,52,56,60

   200    Active                                    T Fo 0/56

   248    Active                                    T Fo 0/56

   264    Active                                    T Fo 0/56

   296    Active                                    T Fo 0/56

   2128   Active                                    T Fo 0/56

   2164   Active                                    T Fo 0/56

0 Kudos
Anonymous
Not applicable

RE: Force10 S4820T trunk with PowerConnect N4064

Alvincura, I sent you a friends request here on the forums. The request includes my email address along with some additional information I would like to gather from the switches.

thanks

0 Kudos