Highlighted
sebazab
1 Nickel

High CPU Powerconnect 6224P - envMontask and boxs Req

Jump to solution

Hi All,

One of our Powerconnect Switch has very high CPU usage about 96% average,

There are only two processes that generate this usage: envMonTask and boxs Req each about 46-48%

As they are monitoring processes I am not sure what can cause such cpu usage and how to fix it,

I remember recently 10Gb module was installed when the switch was on and after that nothing has been rebooted, could that be the reason?

Switch configuration attached:

____________________________________________________________________________________

!Current Configuration:
!System Description "PowerConnect 6224P, 3.3.7.3, VxWorks 6.5"
!System Software Version 3.3.7.3
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 999,4000-4001
exit
hostname "249_Backup_sw"
stack
member 1 4
exit
ip address 192.168.64.249 255.255.255.0
ip default-gateway 192.168.64.250
interface vlan 999
name "VoIP"
exit
interface vlan 4000
name "VSA"
exit
interface vlan 4001
name "VSphere_Mgt"
exit
username "admin" password 07f86f689c0022bdbccc20f02ea5818c level 15 encrypted
voice vlan
monitor session 1 destination interface 1/g16
monitor session 1 source interface 1/g7
monitor session 1 mode
!
interface ethernet 1/g7
switchport mode general
switchport general allowed vlan add 999 tagged
voice vlan 999
exit
!
interface ethernet 1/g15
switchport access vlan 999
exit
!
interface ethernet 1/g16
switchport mode general
switchport general pvid 999
switchport general allowed vlan add 999 tagged
exit
!
interface ethernet 1/g18
switchport mode trunk
switchport trunk allowed vlan add 4000-4001
exit
!
interface ethernet 1/g19
switchport mode trunk
switchport trunk allowed vlan add 4000-4001
exit
!
interface ethernet 1/g20
switchport mode trunk
switchport trunk allowed vlan add 4000-4001
exit
!
interface ethernet 1/g21
switchport mode trunk
switchport trunk allowed vlan add 4000-4001
exit
!
interface ethernet 1/g22
switchport mode trunk
switchport trunk allowed vlan add 4000-4001
exit
!
interface ethernet 1/g23
switchport mode trunk
switchport trunk allowed vlan add 4000-4001
exit
!
interface ethernet 1/g24
switchport mode trunk
switchport trunk allowed vlan add 4000-4001
exit
!
interface ethernet 1/xg1
switchport mode general
switchport general allowed vlan add 999 tagged
exit

___________________________________________________________________________________

Port mirroring is set-up on one port


Thank you for your help

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator

RE: High CPU Powerconnect 6224P - envMontask and boxs Req

Jump to solution

The rear modules are not designed for adding with the switch on, so even if that is not the cause of this, unplugging the switch before adding modules is the recommended method for adding them. EnvMontask and BoxReq are for monitoring fans and temperature, so adding a module could be causing this. With this being a PoE switch it could be a device drawing too much power.

 

Reloading probably is the best first step to take. Beyond that, removing the module and updating firmware would be the next steps. It probably is not a connected device, but disconnecting cables and seeing if it causes a change in CPU usage could also be helpful.

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
4 Replies
Moderator
Moderator

RE: High CPU Powerconnect 6224P - envMontask and boxs Req

Jump to solution

Hi,

If you turn off port mirroring does it lower the cpu usage? Was it one of the rear modules that was added or a SFP into a combo port? Are you able to do a reload of the switch? What do the ports on this switch connect to?

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
sebazab
1 Nickel

RE: High CPU Powerconnect 6224P - envMontask and boxs Req

Jump to solution

Hi Josh,

Yes, it was one of the rear modules,

Some ports are connected to backup vlan other ones to idrac, 

One port is connected to avaya ip office and that port is mirrored

As it is live environment I am thinking about reloading but just want to narrow the problem first so can be sure it is absolutely necessary

We don't have any problems with network traffic so far but the switch response is extremely slow what makes management very difficult to perform

Kind Regards,

Seb

0 Kudos
Moderator
Moderator

RE: High CPU Powerconnect 6224P - envMontask and boxs Req

Jump to solution

The rear modules are not designed for adding with the switch on, so even if that is not the cause of this, unplugging the switch before adding modules is the recommended method for adding them. EnvMontask and BoxReq are for monitoring fans and temperature, so adding a module could be causing this. With this being a PoE switch it could be a device drawing too much power.

 

Reloading probably is the best first step to take. Beyond that, removing the module and updating firmware would be the next steps. It probably is not a connected device, but disconnecting cables and seeing if it causes a change in CPU usage could also be helpful.

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
sebazab
1 Nickel

RE: High CPU Powerconnect 6224P - envMontask and boxs Req

Jump to solution

Hi Josh,

Yes, reboot fixed the problem and  EnvMontask dissapeared,

Average now is about 8%

Thank you for your help 

 

0 Kudos