jawdrop
1 Copper

Installing OMNM 5.2 SP1 on Ubuntu 10.0.4

I get to the db install and keep getting the following error. I've tried installing the ia32-libs and it looks like it still doesn't find it. Also it seems to want an older version of ia32-libs.

/dell/openmanage/networkmanager/oware3rd/mysql/5.0.51-pc-linux-i686-64/bin/mysqld: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

I first tried this blog.lroguet.com/install-libstdc-so-5-on-ubuntu-10-04-64-bit

but it did not work

I then tried apt-get install ia32-libs and still the same problem.

I then did a  dpkg -i ia32-libs_2.7ubuntu6.1_amd64.deb

I followed the instructions in the above link and still get

ldd -d /dell/openmanage/networkmanager/oware3rd/mysql/5.0.51-pc-linux-i686-64/bin/mysqladmin

linux-vdso.so.1 =>  (0x00007fffb5791000)

libcrypt.so.1 => /lib/libcrypt.so.1 (0x00007f049d685000)

libnsl.so.1 => /lib/libnsl.so.1 (0x00007f049d46b000)

libm.so.6 => /lib/libm.so.6 (0x00007f049d1e7000)

libstdc++.so.5 => not found

libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007f049cfd0000)

libc.so.6 => /lib/libc.so.6 (0x00007f049cc49000)

libdl.so.2 => /lib/libdl.so.2 (0x00007f049ca45000)

/lib64/ld-linux-x86-64.so.2 (0x00007f049d8cd000)

ldconfig -v | grep libstdc++

/sbin/ldconfig.real: Can't stat /lib/x86_64-linux-gnu: No such file or directory

/sbin/ldconfig.real: Can't stat /usr/lib/x86_64-linux-gnu: No such file or directory

libstdc++.so.6 -> libstdc++.so.6.0.13

libstdc++.so.5 -> libstdc++.so.5.0.7

libstdc++.so.6 -> libstdc++.so.6.0.13

0 Kudos
1 Reply
Anonymous
Not applicable

Re: Installing OMNM 5.2 SP1 on Ubuntu 10.0.4

Unfortunately Ubuntu is not a supported OS for the OMNM software. Making troubleshooting an install a bit more difficult. I found this tutorial that seems pretty detailed and may be worth looking at.

keithscode.com/.../18-installing-dell-openmanage-server-administrator-on-ubuntu.html

Thanks  

0 Kudos