Highlighted
2 Bronze

Issue with VLAN being removed from port-channel on reload

I have 2x Dell S4148s and I am having a weird issue with the running config losing VLANs assigned to port channels.

I am setting devices up in a VLT and I cant seem to resolve this issue. If I run the correct commands against the switch after reload, it works perfectly, but then each reload it is again removed.

Here is how the port channel should look

OS10(conf-if-po-51)# show configuration
!
interface port-channel51
 no shutdown
 switchport access vlan 40
 vlt-port-channel 51

I run the write memory command, reload the switch and then it shows this

OS10(conf-if-po-51)# show configuration
!
interface port-channel51
 no shutdown
 vlt-port-channel 51
OS10(conf-if-po-51)#

Here is the running config from my switches, it is identical apart from the VLAN IP addresses and VLT backup.

OS10# show running-configuration

! Version 10.4.3.3
! Last configuration change at Aug  01 19:12:45 2019
!
ip vrf default
!
interface breakout 1/1/25 map 100g-1x
interface breakout 1/1/26 map 100g-1x
interface breakout 1/1/29 map 100g-1x
interface breakout 1/1/30 map 100g-1x
system-user linuxadmin password $6$5DdOHYg5$JCE1vMSmkQOrbh31U74PIPv7lyOgRmba1IxhkYibppMXs1KM4Y.gbTPcxyMP/PHUkMc5rdk/ZLv9Sfv3ALtB61
iscsi enable
iscsi target port 860
iscsi target port 3260
vrrp version 3
spanning-tree mode rstp
username admin password $6$q9QBeYjZ$jfxzVqGhkxX3smxJSH9DDz7/3OJc6m5wjF8nnLD7/VKx8SloIhp4NoGZs0I/UNwh8WVuxwfd9q4pWIgNs5BKH. role sysadmin priv-lvl 15
aaa authentication login default local
aaa authentication login console local
!
class-map type application class-iscsi
!
policy-map type application policy-iscsi
!
interface vlan1
 no shutdown
!
interface vlan40
 description RoutingVLANtoSophos
 no shutdown
 ip address 10.40.12.12/24
 !
 vrrp-group 40
  virtual-address 10.40.12.10
!
interface vlan100
 description HostVLAN
 no shutdown
 ip address 10.100.100.12/24
 !
 vrrp-group 100
  virtual-address 10.100.100.10
!
interface vlan200
 no shutdown
!
interface port-channel1
 no shutdown
 switchport access vlan 100
 vlt-port-channel 1
!
interface port-channel9
 no shutdown
 switchport access vlan 100
 vlt-port-channel 9
!
interface port-channel17
 no shutdown
 switchport access vlan 100
 vlt-port-channel 17
!
interface port-channel51
 no shutdown
 switchport access vlan 40
 vlt-port-channel 51
!
interface mgmt1/1/1
 no shutdown
 no ip address dhcp
 ip address 192.168.90.221/24
 ipv6 address autoconfig
!
interface ethernet1/1/1
 no shutdown
 channel-group 1
 no switchport
 flowcontrol receive on
!
interface ethernet1/1/2
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/3
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/4
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/5
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/6
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/7
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/8
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/9
 no shutdown
 channel-group 9
 no switchport
 flowcontrol receive on
!
interface ethernet1/1/10
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/11
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/12
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/13
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/14
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/15
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/16
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/17
 no shutdown
 channel-group 17
 no switchport
 flowcontrol receive on
!
interface ethernet1/1/18
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/19
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/20
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/21
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/22
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/23
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/24
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/25
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/26
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/29
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/30
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/31
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/32
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/33
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/34
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/35
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/36
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/37
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/38
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/39
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/40
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/41
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/42
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/43
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/44
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/45
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/46
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/47
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/48
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/49
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/50
 no shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/51
 shutdown
 switchport access vlan 1
 flowcontrol receive on
!
interface ethernet1/1/52
 no shutdown
 channel-group 51 mode active
 no switchport
 flowcontrol receive on
!
interface ethernet1/1/53
 no shutdown
 no switchport
 flowcontrol receive on
!
interface ethernet1/1/54
 no shutdown
 no switchport
 flowcontrol receive on
!
management route 192.168.0.0/16 192.168.90.1
!
ip route 0.0.0.0/0 10.40.12.1
!
support-assist
!
vlt-domain 254
 backup destination 192.168.90.220
 delay-restore 10
 discovery-interface ethernet1/1/53-1/1/54
 peer-routing
 vlt-mac 00:00:00:00:00:02
snmp-server contact "Contact Support"

 

Version info

OS10# show version
Dell EMC Networking OS10-Enterprise
Copyright (c) 1999-2019 by Dell Inc. All Rights Reserved.
OS Version: 10.4.3.3
Build Version: 10.4.3.3.206
Build Time: 2019-05-20T13:03:16-0700
System Type: S4148F-ON
Architecture: x86_64
Up Time: 00:05:35

 

Any help is appreciated!

0 Kudos
2 Replies
Highlighted
2 Bronze

Re: Issue with VLAN being removed from port-channel on reload

I have been informed this is a known issue and I am waiting for a firmware update to resolve.

0 Kudos
Highlighted

Re: Issue with VLAN being removed from port-channel on reload

Thanks for the update.


Thanks,
DELL-Josh Cr
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
#IWork4Dell
0 Kudos