Networking General

Last reply by 07-02-2021 Unsolved
Start a Discussion
2 Bronze
2 Bronze
1792

LACP between N-series and S4128F (VLT) core

Hi, 

I am having issues setting up LACP between my two S4128F, sat up in VLT, and my access switches (N-series 1100/2000). 

I am first wondering if this setup even is possible, with one interface on each of the S4128F configured on the same portchannel, and then connected to the N-Series. 

Problem is I dont get both links active.  One is always active and other inactive port. With no redundancy or failover. LACP is also configured on the N-Series. 

The interface port-channel is member of the same vlt-port-channel on both VLT members.


Replies (4)
1777

Hello @Plati1337,


Good to see you back in the Dell Community!


Sadly, we cannot help directly in configurations as there are some Dell Professional services that can handle this task on your behalf. In case you need this professional help, please let us know and I will make sure to show you how you can contact them. But, of course, we can try to offer you some help:


I can confirm you that it is possible to configure a LACP between two S4128F (VLT) and access switches (N-series 1100/2000).

What OS are you using? 10 or 9? Spamming tree is active? I ask this, because if you have both sides active you should have loops. So that would be something to consider. 


If you are using OS10. Please, reference the material on page 174: https://dell.to/361Vt8O and this article: https://dell.to/2SFwViJ


And if you are using OS9, check this: https://dell.to/364ONqj


Finally, if your switch is still in warranty you can contact phone or online support and send them the switch logs. They will not perform the configuration but they will be able to tell you if something is incorrect.


Regards.


Diego López
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#Iwork4Dell

Did I answer your query? Please click on ‘Accept as Solution’
‘Kudo’ the posts you like!
1765

Hello @Plati1337 

I have LACP working between a pair of Dell S4128F-ON switches in VLT and 2x Dell N1524 switches. 

Is stacking configured on the N1100 and N2000 switches? I believe this will be required for them to be able see the S4128F VLT switches as a single entity and to avoid any Layer 2 loops. 

Here is my LACP configuration for the S4128F and N1524 switches - the N1524s are configured in a stack. Ports 29 on each of the S4128F are connected to ports te1/0/4 and te2/0/4 on the N1524 switches. 

 

Dell S4128F Switches

interface port-channel3
description "LACP Port Channel to Dell N1524 Stack"
no shutdown
switchport mode trunk
switchport trunk allowed vlan 10,20,80
vlt-port-channel 3

interface ethernet1/1/29
no shutdown
description "LACP Member Link to Dell N1524"
channel-group 3 mode active
no switchport
flowcontrol receive off

 

Dell N1524 Switches

interface port-channel 1
description "LACP Port Channel to Dell S4128F-ON"
no shutdown
switchport mode trunk
switchport trunk allowed vlan 10,20,80

interface te1/0/4
description "LACP Member Link to Dell S4128F-ON Switch 1"
no shutdown
channel-group 1 mode active

interface te2/0/4
description "LACP Member Link to Dell S4128F-ON Switch 2"
no shutdown
channel-group 1 mode active

 

I hope this helps.

1744

Thanks for your replies. 
I have now tried configure N2000 stack for the access switches, but it is still the same. 
I do, however see this entry in the log: 
DOT3AD[dot3ad_core_lac]: dot3ad_lacp.c(2339) 11030 %% WARN Interface Te2/0/1 partner priority 4096 is not same as existing members of LAG interface Po1 (4096). Not adding interface Te2/0/1 as active member of LAG interface Po1.

But I have configures the same priority on each of the interfaces, on both sides. I will attach the configuration here, I hope you will locate what I am doing wrong. 

Core S4128F running OS10, configured in VLT: 

Core-1:
# show vlt 1
Domain ID : 1
Unit ID : 2
Role : primary
Version : 2.3
Local System MAC address : cc:48:3a:fa:32:76
Role priority : 4096
VLT MAC address : 00:00:00:00:00:02
IP address : fda5:74c8:b79e:1::2
Delay-Restore timer : 90 seconds
Peer-Routing : Disabled
Peer-Routing-Timeout timer : 0 seconds
VLTi Link Status
port-channel1000 : up

VLT Peer Unit ID System MAC Address Status IP Address Version
----------------------------------------------------------------------------------
1 cc:48:3a:fa:36:f6 up fda5:74c8:b79e:1::1 2.3

interface port-channel2
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 10-11,20
vlt-port-channel 2

interface ethernet1/1/12
no shutdown
channel-group 2 mode active
no switchport
flowcontrol receive on
lacp port-priority 4096
lacp rate fast

Core-2:
# show vlt 1
Domain ID : 1
Unit ID : 1
Role : secondary
Version : 2.3
Local System MAC address : cc:48:3a:fa:36:f6
Role priority : 8192
VLT MAC address : cc:48:3a:fa:32:76
IP address : fda5:74c8:b79e:1::1
Delay-Restore timer : 90 seconds
Peer-Routing : Disabled
Peer-Routing-Timeout timer : 0 seconds
VLTi Link Status
port-channel1000 : up

VLT Peer Unit ID System MAC Address Status IP Address Version
----------------------------------------------------------------------------------
2 cc:48:3a:fa:32:76 up fda5:74c8:b79e:1::2 2.3

interface port-channel2
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 10-11,20
vlt-port-channel 2

interface ethernet1/1/12
no shutdown
channel-group 2 mode active
no switchport
flowcontrol receive on
lacp port-priority 4096
lacp rate fast



N2000 stack: 

interface port-channel 1
switchport mode trunk
switchport trunk allowed vlan 10-11,20

interface Te1/0/1
channel-group 1 mode active
lacp port-priority 4096
switchport mode trunk
switchport trunk allowed vlan 10-11,20

interface Te2/0/1
channel-group 1 mode active
lacp port-priority 4096
switchport mode trunk
switchport trunk allowed vlan 10-11,20

#show interfaces port-channel 1

Channel Ports Ch-Type Hash Type Min-links Local Prf Rx Util Tx Util
------- ----------------------------- -------- --------- --------- --------- --------- ---------
Po1 Active: Te1/0/1 Dynamic 7 1 Disabled 0 0
Inactive: Te2/0/1



1737

I would try removing lacp port-priority and lacp rate on the physical interfaces unless there is a particular need. 

Generally port priority is used to decide which ports should be put into standby mode when there is a hardware limitation that prevents all compatible ports from aggregating. 

I can also see that flow control is enabled on the S4128F physical interfaces participating in the port-channel but not on the N2000 stack interfaces. I would also try turning this off and testing. 

After making these changes I would perform a shutdown then no shutdown of of the port-channel interface. 

 

Latest Solutions
Top Contributor