Highlighted
Edisto Kid
1 Copper

Newbie here, setting up a LAG between two Powerconnect 6248's

New to the world of networking.... but I have a CLI guide and Google so watch out!

I have two 6248's about 100' apart that I need to connect. They were purchased without any modules so I was thinking of using a LAG. Our exchange servers are currently on the ".253" switch with all of our office workstations. The plan is to locate the exchange and NAS server with the new ".248" switch. Office workstations (approx 30) will remain on the 253 switch.

I am new to this office also. The switch was configed by a kid just out of school a few years ago. I have inherited all this as I was networking our DVR's and was proficient with the firewall device. I have attached both configs here- any input is appreciated.

I am researching spanning tree options. Seems to be a lot there I need to know.

Ports 1-4 on the 248 switch and ports 25 and 26 on the 253 switch are my test subjects. I have them connected now and can browse out and ping any device on any VLAN. All ports are on VLAN 2, this is our LAN really. The other VLANs are fiber connections to remote sites.

I am about to view statistics for the port-channel interface. I will will be reading about Trunk mode vs. General mode and making changes from there.

I am honestly unsure about the IP convention for the two switches- I know I must use another VLAN besides 1, The 10.0.0... was in place and will not likely change. Did I guess correctly that both switches need to have IP's in the same range and VLAN id? And, would 248 need any routing statements?

Thanks in advance- again, any input or suggestions appreciated.

248 switch:

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2013.01.15 15:50:12 =~=~=~=~=~=~=~=~=~=~=~=

User:xxxxxx
Password:********
console>enable

console#show run
!Current Configuration:
!System Description "Powerconnect 6248P, 3.2.0.7, VxWorks 6.5"
!System Software Version 3.2.0.7
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 2
vlan routing 2 1
exit
stack
member 1 5
exit
ip address 192.168.99.252 255.255.255.0
ip routing
ip route 0.0.0.0 0.0.0.0 10.0.0.253
interface vlan 2
routing
ip address 10.0.0.248 255.255.255.0
exit
username "xxxxxx" password xxxxxxxxxxxxxxxxxxxxxxxx level 15 encrypted

--More-- or (q)uit
spanning-tree bpdu flooding
spanning-tree bpdu-protection
!
interface ethernet 1/g1
channel-group 1 mode auto
spanning-tree auto-portfast
switchport mode trunk
switchport trunk allowed vlan add 2
exit
!
interface ethernet 1/g2
channel-group 1 mode auto
spanning-tree auto-portfast
switchport mode trunk
switchport trunk allowed vlan add 2
exit
!
interface ethernet 1/g3
channel-group 2 mode auto
spanning-tree auto-portfast
switchport mode trunk

--More-- or (q)uit
switchport trunk allowed vlan add 2
exit
!
interface ethernet 1/g4
channel-group 2 mode auto
spanning-tree auto-portfast
switchport mode trunk
switchport trunk allowed vlan add 2
exit
!
interface ethernet 1/g5
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g6
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g7

--More-- or (q)uit
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g8
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g9
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g10
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g11
spanning-tree auto-portfast

--More-- or (q)uit
switchport access vlan 2
exit
!
interface ethernet 1/g12
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g13
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g14
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g15
spanning-tree auto-portfast
switchport access vlan 2

--More-- or (q)uit
exit
!
interface ethernet 1/g16
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g17
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g18
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g19
spanning-tree auto-portfast
switchport access vlan 2
exit

--More-- or (q)uit
!
interface ethernet 1/g20
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g21
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g22
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g23
spanning-tree auto-portfast
switchport access vlan 2
exit
!

--More-- or (q)uit
interface ethernet 1/g24
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g25
channel-group 1 mode auto
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g26
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g27
spanning-tree auto-portfast
switchport access vlan 2
exit
!

--More-- or (q)uit
interface ethernet 1/g28
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g29
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g30
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g31
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g32

--More-- or (q)uit
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g33
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g34
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g35
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g36
spanning-tree auto-portfast

--More-- or (q)uit
switchport access vlan 2
exit
!
interface ethernet 1/g37
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g38
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g39
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g40
spanning-tree auto-portfast
switchport access vlan 2

--More-- or (q)uit
exit
!
interface ethernet 1/g41
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g42
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g43
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g44
spanning-tree auto-portfast
switchport access vlan 2
exit

--More-- or (q)uit
!
interface ethernet 1/g45
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g46
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g47
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g48
spanning-tree auto-portfast
switchport access vlan 2
exit
!

--More-- or (q)uit
interface port-channel 1
description 'LAG1'
spanning-tree auto-portfast
switchport mode trunk
switchport trunk allowed vlan add 2
exit
!
interface port-channel 2
description 'LAG2'
hashing-mode 6
switchport mode trunk
switchport trunk allowed vlan add 2
exit

253 Switch:

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2013.01.15 16:17:55 =~=~=~=~=~=~=~=~=~=~=~=

User:xxxxxx
Password:********
console>enable

console#show running-config
!Current Configuration:
!System Description "PowerConnect 6248, 3.3.1.10, VxWorks 6.5"
!System Software Version 3.3.1.10
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 2,680-700
vlan routing 2 1
vlan routing 680 2
vlan routing 681 3
vlan routing 682 4
vlan routing 683 5
vlan routing 684 6
vlan routing 685 7
vlan routing 686 8
vlan routing 687 9
vlan routing 688 10
vlan routing 689 11
vlan routing 690 12
vlan routing 691 13

--More-- or (q)uit
vlan routing 692 14
vlan routing 693 15
vlan routing 694 16
vlan routing 695 17
vlan routing 696 18
vlan routing 697 19
vlan routing 698 20
vlan routing 699 21
vlan routing 700 22
exit
stack
member 1 2
exit
ip address 192.168.99.253 255.255.255.0
ip routing
ip route 0.0.0.0 0.0.0.0 10.0.0.254
ip route 10.100.8.0 255.255.255.0 10.100.8.253
ip route 10.100.10.0 255.255.255.0 10.100.10.253
ip route 10.100.7.0 255.255.255.0 10.100.7.253
ip route 10.100.18.0 255.255.255.0 10.100.18.253
ip route 10.100.15.0 255.255.255.0 10.100.15.253

--More-- or (q)uit
ip route 172.19.182.0 255.255.255.224 10.0.0.99
ip route 172.19.124.0 255.255.255.224 10.0.0.199
ip helper-address 10.0.0.251
ip helper-address 10.0.0.252
interface vlan 2
name
routing
ip address 10.0.0.253 255.255.255.0
exit
interface vlan 680
name
routing
ip address 10.100.10.254 255.255.255.0
exit
interface vlan 681
name
routing
ip address 10.100.8.254 255.255.255.0
exit
interface vlan 682
name

--More-- or (q)uit
routing
ip address 10.100.7.254 255.255.255.0
exit
interface vlan 683
name
routing
ip address 10.100.18.254 255.255.255.0
exit
interface vlan 684
name
routing
ip address 10.100.15.254 255.255.255.0
exit
interface vlan 685
routing
exit
interface vlan 686
routing
exit
interface vlan 687
routing

--More-- or (q)uit
exit
interface vlan 688
routing
exit
interface vlan 689
routing
exit
interface vlan 690
routing
exit
interface vlan 691
routing
exit
interface vlan 692
routing
exit
interface vlan 693
routing
exit
interface vlan 694
routing

--More-- or (q)uit
exit
interface vlan 695
routing
exit
interface vlan 696
routing
exit
interface vlan 697
routing
exit
interface vlan 698
routing
exit
interface vlan 699
routing
exit
interface vlan 700
routing
exit
username "xxxxxx" password xxxxxxxxxxxxxxxxxxxxxxxxx level 15 encrypted
snmp-server enable traps dvmrp

--More-- or (q)uit
snmp-server enable traps pim
snmp-server enable traps captive-portal client-auth-failure
snmp-server enable traps captive-portal client-connect
snmp-server enable traps captive-portal client-db-full
snmp-server enable traps captive-portal client-disconnect
snmp-server enable traps ospf all
snmp-server enable traps ospfv3 all
dhcp l2relay
!
interface ethernet 1/g1
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g2
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g3
spanning-tree auto-portfast

--More-- or (q)uit
switchport access vlan 2
exit
!
interface ethernet 1/g4
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g5
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g6
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g7
spanning-tree auto-portfast
switchport access vlan 2

--More-- or (q)uit
exit
!
interface ethernet 1/g8
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g9
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g10
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g11
spanning-tree auto-portfast
switchport access vlan 2
exit

--More-- or (q)uit
!
interface ethernet 1/g12
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g13
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g14
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g15
spanning-tree auto-portfast
switchport access vlan 2
exit
!

--More-- or (q)uit
interface ethernet 1/g16
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g17
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g18
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g19
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g20

--More-- or (q)uit
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g21
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g22
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g23
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g24
spanning-tree auto-portfast

--More-- or (q)uit
switchport access vlan 2
exit
!
interface ethernet 1/g25
channel-group 1 mode auto
description 'LAG_1'
spanning-tree disable
spanning-tree auto-portfast
switchport mode trunk
switchport trunk allowed vlan add 2
exit
!
interface ethernet 1/g26
channel-group 2 mode auto
description 'LAG_2'
spanning-tree disable
spanning-tree auto-portfast
switchport mode trunk
switchport trunk allowed vlan add 2
exit
!

--More-- or (q)uit
interface ethernet 1/g27
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g28
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g29
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g30
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g31

--More-- or (q)uit
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g32
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g33
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g34
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g35
spanning-tree auto-portfast

--More-- or (q)uit
switchport access vlan 2
exit
!
interface ethernet 1/g36
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g37
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g38
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g39
spanning-tree auto-portfast
switchport access vlan 2

--More-- or (q)uit
exit
!
interface ethernet 1/g40
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g41
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g42
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g43
spanning-tree auto-portfast
switchport access vlan 2
exit

--More-- or (q)uit
!
interface ethernet 1/g44
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g45
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g46
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/g47
no negotiation
description 'ME3400_gig02_VLANs'
spanning-tree auto-portfast
switchport mode trunk

--More-- or (q)uit
switchport trunk allowed vlan add 680-700
exit
!
interface ethernet 1/g48
description 'Firewall'
spanning-tree auto-portfast
switchport access vlan 2
exit
!
interface ethernet 1/xg1
switchport mode trunk
exit
!
interface ethernet 1/xg2
switchport mode trunk
exit
!
interface port-channel 1
description 'LAG_1'
switchport mode trunk
switchport trunk allowed vlan add 2

--More-- or (q)uit
exit
!
interface port-channel 2
description 'LAG_2'
switchport mode trunk
switchport trunk allowed vlan add 2
exit
0 Kudos
4 Replies

Re: Newbie here, setting up a LAG between two Powerconnect 6248's

You do not want to have portfast set on a LAG between switches or routers.  Portfast is intended for use on ports connecting to end devices: laptop, desktop or server.  If you set portfast on a connection between switches you are enabling the network to create loops which can degrade performance or shutdown the network.

When setting up a LAG between devices you will want the same amount of ports and cable connected on both ends of the connection.  I see ports 1 & 2 are port-channel 1 on the 248 switch and only port 25 is port-channel 1 on the 253 switch.

The purpose of a LAG is to group multiple physical ports together to act as one virtual port.  

Here is a definition of Link Aggregation:

Link Aggregation Groups or IEEE 802.1AX-2008 is a computer networking term which describes using multiple network cables/ports in parallel to increase the link speed beyond the limits of any one single cable or port, and to increase the redundancy for higher availability.

The benefits of Link Aggregation include:

  Increased Availability — If a link within a LAG fails or is replaced, the traffic is not disrupted and communication is maintained (even though the available capacity is reduced).

  Load Sharing — Traffic is distributed across multiple links, minimizing the probability that a single link be overwhelmed.

  Use of Existing Hardware — Firmware replaces the need to upgrade the hardware to higher bandwidth capacity.

Also when a physical port is associated with a port-channel you do not have any configuration on the individual physical port.  Just the commands to set up the channel-group.  Then you move the port-channel to set up any switchport commands that are needed.

Get Support on Twitter @DellCaresPro

Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

Edisto Kid
1 Copper

Re: Newbie here, setting up a LAG between two Powerconnect 6248's

Thanks. I have been reading a bit on port settings and was headed that way. Good to hear from someone who has been there.

I have configed two ports on one switch and four on the other for testing different settings (moving cable). I am currently testing the new switch with two workstations. There are no errors in statistics for the port-cahnnel- is there a better way to test? maybe monitoring speed?

I can ping and browse out all across our network. Looks like the original 253 switch is taking care of all the routing.

0 Kudos

Re: Newbie here, setting up a LAG between two Powerconnect 6248's

Ping is a good indication that everything is communicating properly.  You can use something like Wire Shark to monitor the traffic that is going through also.

Get Support on Twitter @DellCaresPro

Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

Edisto Kid
1 Copper

Re: Newbie here, setting up a LAG between two Powerconnect 6248's

Thanks again. I have used Wire Shark to monitor a device- but have not looked at it in awhile. Obviously not to its capacity. I had expected more forum member input, so I do appreciate your time. Maybe the word newbie turned them off.

I have had my workstation and laptop on the switch for two days- will cut the office over tomorrow.

0 Kudos