Highlighted
2 Bronze

Non-Default VLAN on Dell PowerConnect 6224 is Blocking All Traffic. Why?

So, I have two Dell PowerConnect 6224 switches (non-stacked). On both of the switches I've taken ports 8 and 9 and assigned them to VLAN 2. The other ends of those ports go to two Windows 2008 R2 Hyper-V host servers (Dell PowerEdge R710). Each server connects to the two switches via a teamed connection for redundancy and speed.

The servers have their IPs as 10.0.2.5 and 10.0.2.6 with a subnet mask of 255.255.255.0.

The VLAN interfaces on both switches have the IPs of 10.0.2.13 and 10.0.2.14 with a subnet mask of 255.255.255.0 as well.

Subnet 10.0.2.0/24 is bound to the VLAN. The MAC addresses of the teamed connections as well as the VLAN interfaces (from the two switches) are also bound to the VLAN.

My problem is that the two servers are unable to ping each other, or the VLAN interface IPs. The switches are also unable to ping the VLAN interface IP of their companion switch and are also unable to ping the IPs of the servers.

I'd really appreciate it if someone could tell me what I'm missing. I'm starting to get really angry with these switches...

0 Kudos
Reply
12 Replies
Highlighted
4 Tellurium

Can you provide your config lines for the interfaces?

You will need routing turned on to reach other vlans and subnets.

sample:

console# configure

console(config)# interface ethernet eXX

console(config-if)# switchport mode access

console(config-if)# switchport access vlan XXX

console(config-if)# end

page 360 has the vlan configuration options in this User Guide for the 62xx switch.

support.dell.com/.../ucg_en.pdf

Get Support on Twitter @DellCaresPro

Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

Reply
Highlighted
2 Bronze

Hi Willy, I'm pretty sure I've done everything that the guide has listed. How do I list out the config lines so I can copy/paste them here? What's the command?

0 Kudos
Reply
Highlighted
4 Tellurium

console# show run

and or

console# show interfaces detail ethernet XX

Also for routing you can enable routing using this command.

console> enable

console# config

console(config)# ip routing

To enable routing for the VLAN, run this command

console(config)#interface vlan 2

console(config-if-vlan2)#routing

console(config-if-vlan2)#exit

Here is a good document that goes over VLAN routing.

www.dell.com/.../app_note_38.pdf

Get Support on Twitter @DellCaresPro

Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

Reply
Highlighted
1 Copper

Hello,

Can you help out to solve the problem that why I could not able to ping any of my server IP from Dell S3048-ON switch? Below are the config of my switch. Kindly check it and please help me to resolve my problem.

5GNSASW01#sh run
Current Configuration ...
! Version 9.13(0.0P1)
! Last configuration change at Wed Jul 1 13:07:14 2020 by default
! Startup-config last updated at Thu Jun 25 10:49:38 2020 by default
!
boot system stack-unit 1 primary system://A
boot system stack-unit 1 secondary system://B
!
hostname 5GNSASW01
!
protocol lldp
!
redundancy auto-synchronize full
!
enable password 7 b125455cf679b2083040aa2e0fb58a7c
!
username admin password 7 1d28e9f33f99cf5c
!
stack-unit 1 provision S3048-ON
!
interface GigabitEthernet 1/1
no ip address
shutdown
!
interface GigabitEthernet 1/2
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/3
no ip address
shutdown
!
interface GigabitEthernet 1/4
no ip address
shutdown
!
interface GigabitEthernet 1/5
no ip address
shutdown
!
interface GigabitEthernet 1/6
no ip address
shutdown
!
interface GigabitEthernet 1/7
no ip address
shutdown
!
interface GigabitEthernet 1/8
no ip address
shutdown
!
interface GigabitEthernet 1/9
no ip address
shutdown
!
interface GigabitEthernet 1/10
no ip address
shutdown
!
interface GigabitEthernet 1/11
no ip address
shutdown
!
interface GigabitEthernet 1/12
no ip address
shutdown
!
interface GigabitEthernet 1/13
no ip address
shutdown
!
interface GigabitEthernet 1/14
no ip address
shutdown
!
interface GigabitEthernet 1/15
no ip address
shutdown
!
interface GigabitEthernet 1/16
no ip address
shutdown
!
interface GigabitEthernet 1/17
no ip address
shutdown
!
interface GigabitEthernet 1/18
no ip address
shutdown
!
interface GigabitEthernet 1/19
no ip address
shutdown
!
interface GigabitEthernet 1/20
no ip address
shutdown
!
interface GigabitEthernet 1/21
no ip address
shutdown
!
interface GigabitEthernet 1/22
no ip address
shutdown
!
interface GigabitEthernet 1/23
no ip address
shutdown
!
interface GigabitEthernet 1/24
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/25
no ip address
shutdown
!
interface GigabitEthernet 1/26
no ip address
shutdown
!
interface GigabitEthernet 1/27
no ip address
shutdown
!
interface GigabitEthernet 1/28
no ip address
shutdown
!
interface GigabitEthernet 1/29
no ip address
shutdown
!
interface GigabitEthernet 1/30
no ip address
shutdown
!
interface GigabitEthernet 1/31
no ip address
shutdown
!
interface GigabitEthernet 1/32
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/33
no ip address
shutdown
!
interface GigabitEthernet 1/34
no ip address
shutdown
!
interface GigabitEthernet 1/35
no ip address
shutdown
!
interface GigabitEthernet 1/36
no ip address
shutdown
!
interface GigabitEthernet 1/37
no ip address
shutdown
!
interface GigabitEthernet 1/38
no ip address
shutdown
!
interface GigabitEthernet 1/39
no ip address
shutdown
!
interface GigabitEthernet 1/40
no ip address
shutdown
!
interface GigabitEthernet 1/41
no ip address
shutdown
!
interface GigabitEthernet 1/42
no ip address
shutdown
!
interface GigabitEthernet 1/43
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/44
no ip address
shutdown
!
interface GigabitEthernet 1/45
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/46
no ip address
shutdown
!
interface GigabitEthernet 1/47
no ip address
shutdown
!
interface GigabitEthernet 1/48
no ip address
shutdown
!
interface TenGigabitEthernet 1/49
no ip address
switchport
no shutdown
!
interface TenGigabitEthernet 1/50
no ip address
shutdown
!
interface TenGigabitEthernet 1/51
no ip address
switchport
no shutdown
!
interface TenGigabitEthernet 1/52
no ip address
shutdown
!
interface ManagementEthernet 1/1
ip address 192.168.1.1/24
no shutdown
!
interface ManagementEthernet 2/1
shutdown
!
interface ManagementEthernet 3/1
shutdown
!
interface ManagementEthernet 4/1
shutdown
!
interface ManagementEthernet 5/1
shutdown
!
interface ManagementEthernet 6/1
shutdown
!
interface Vlan 1
!
interface Vlan 1001
description "EPC&MEC Backend Vlan and eNB"
ip address 10.200.1.1/24
tagged GigabitEthernet 1/24
untagged TenGigabitEthernet 1/49
no shutdown
!
interface Vlan 2001
description "EPC SGi Frontend VLAN"
ip address 10.200.2.111/24
untagged GigabitEthernet 1/32
untagged TenGigabitEthernet 1/51
no shutdown
!
interface Vlan 3001
description "EPC&MEC OAM VLAN"
ip address 10.200.3.1/24
untagged GigabitEthernet 1/2,1/43,1/45
no shutdown
!
ip route 10.200.1.0/24 10.200.1.1
ip route 10.200.2.0/24 10.200.2.111
ip route 10.200.3.0/24 10.200.3.1
!
line console 0
line vty 0
line vty 1
line vty 2
line vty 3
line vty 4
line vty 5
line vty 6
line vty 7
line vty 8
line vty 9
!
reload-type
boot-type normal-reload
config-scr-download enable
!
end

 

Thanking in advance. Waiting for the solution.

0 Kudos
Reply
Highlighted
Moderator
Moderator

Hi sid-tokyo,

How are you testing it? Are you testing from the switch to the servers or from server to server? Are they on the same VLAN?


Thanks,
DELL-Josh Cr
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
#IWork4Dell
0 Kudos
Reply
Highlighted
1 Copper

DELL-Josh Cr,

Thanks for your reply.

Yes, I'm testing it from Switch to Server. I can able to ping switch and my wireless device which is attached to the switch from server, but I could not able to ping server from switch. Is there any other setting which I have to set in Dell switch?

 

Thanks & Regards,

Sid

0 Kudos
Reply
Highlighted
1 Copper

DELL-Josh Cr,

Thanks for your reply.

Also I want to ask you one more thing that. Can you please tell me how to use Wireshark app on Dell S3048-ON Switch? If you tell me the setting for the switch I can able to see the issue from Wireshark app. 

 

 

Thanks & Regards,

Sid

0 Kudos
Reply
Highlighted
Moderator
Moderator

Thanks Sid,

Page 565 covers port monitoring https://dell.to/2ZrrraK


Thanks,
DELL-Josh Cr
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
#IWork4Dell
0 Kudos
Reply
Highlighted
2 Bronze

!Current Configuration:

!System Description "Powerconnect 6224, 3.2.0.7, VxWorks 6.5"

!System Software Version 3.2.0.7

!Cut-through mode is configured as disabled

!

configure

gvrp enable

vlan database

vlan 2

vlan routing 2 1

vlan association subnet 10.0.2.0 255.255.255.0 2

vlan association mac 5C26.0AC7.F7D9 2

vlan association mac 5C26.0AC7.F824 2

vlan association mac 782B.CB3A.0F08 2

vlan association mac 782B.CB3A.0F0A 2

vlan association mac 782B.CB3B.763D 2

vlan association mac 782B.CB3B.763F 2

exit

sntp unicast client enable

sntp server ntp1.phoenixpubliclibrary.org

sntp server ntp2.phoenixpubliclibrary.org

clock timezone -7 minutes 0 zone "MST"

stack

member 1 1

exit

ip address 10.0.0.3 255.255.255.0

ip default-gateway 10.0.0.1

ip domain-name ???

ip name-server 10.0.1.1

ip name-server 10.0.1.2

ip host win2k8r2-dc-01 10.0.1.1

ip host win2k8r2-dc-02 10.0.1.2

ip host win2k8r2-h-01 10.0.1.5

ip host win2k8r2-h-02 10.0.1.6

ip host win2k8r2-hc-01 10.0.1.4

no ipv6 enable

interface vlan 2

name "Failover Cluster"

routing

ip address 10.0.2.13 255.255.255.0

bandwidth 10000

ip local-proxy-arp

ip mtu 1500

exit

username ??? password ??? level 15 encrypted

!

interface ethernet 1/g8

switchport access vlan 2

exit

!

interface ethernet 1/g9

switchport access vlan 2

exit

!

interface ethernet 1/g24

switchport mode trunk

switchport trunk allowed vlan add 2

exit

exit

0 Kudos
Reply