Highlighted
lmahaffy
1 Nickel

On 6224; variation in Ping response times between vlan IP, Monitor IP, and hosts

I am wondering if anyone has observed that when you ping against the management interface or hosts (attached to access ports) you get consistent ping responses (<1ms) but when you ping against IPs assigned to vlans (on the switch) you get variable responses (see example).  If so to what might this be attributed?

(Ping against attached host = XXX.XXX.102.0)  

Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128
Reply from XXX.XXX.102.0: bytes=32 time<1ms TTL=128

(Ping against vlan IP)

Reply from 10.10.10.95: bytes=32 time=1ms TTL=64

Reply from 10.10.10.95: bytes=32 time=96ms TTL=64
Reply from 10.10.10.95: bytes=32 time=36ms TTL=64
Reply from 10.10.10.95: bytes=32 time=32ms TTL=64
Reply from 10.10.10.95: bytes=32 time=83ms TTL=64
Request timed out.
Reply from 10.10.10.95: bytes=32 time=1ms TTL=64
Reply from 10.10.10.95: bytes=32 time=59ms TTL=64
Request timed out.
Reply from 10.10.10.95: bytes=32 time=1ms TTL=64
Reply from 10.10.10.95: bytes=32 time=9ms TTL=64
Reply from 10.10.10.95: bytes=32 time=89ms TTL=64
Reply from 10.10.10.95: bytes=32 time=68ms TTL=64
Reply from 10.10.10.95: bytes=32 time=1ms TTL=64
Reply from 10.10.10.95: bytes=32 time=97ms TTL=64
Reply from 10.10.10.95: bytes=32 time=46ms TTL=64
Reply from 10.10.10.95: bytes=32 time=125ms TTL=64
Reply from 10.10.10.95: bytes=32 time=1ms TTL=64
Reply from 10.10.10.95: bytes=32 time=1ms TTL=64
Reply from 10.10.10.95: bytes=32 time=1ms TTL=64
Reply from 10.10.10.95: bytes=32 time=1ms TTL=64
Reply from 10.10.10.95: bytes=32 time=69ms TTL=64

Thanks for any responses.

Tags (3)
0 Kudos
13 Replies
Moderator
Moderator

RE: On 6224; variation in Ping response times between vlan IP, Monitor IP, and hosts

So 10.10.10.95 is assigned to a specific VLAN on the 6224?

What firmware is the switch on right now?

It is not usually recommended to ping from the switch to the switch, but rather setup clients and ping from client to client.

What does your running config look like?

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
lmahaffy
1 Nickel

RE: On 6224; variation in Ping response times between vlan IP, Monitor IP, and hosts

This is the first time I have configured a Dell switch.

10.10.10.95 is assigned to a specific vlan.

3.3.8.2,  but the same was observed on 3.3.3.3.

I am ping the vlan IP interface on the switch from a host within the network.  This is how I normally manage other switch vendor's equipment and the reason why this is of interest to me.  It also causes drops in tftp file transfers i.e. firmware.

Port 1/g24 is the trunk port, and a host is connected to port 1/g22 for testing.

On port 1/g24, I'm not sure that 'negotiation 1000f' is the issue or not, but all traffic has to go through 1/g24 and the host on 1/g22 pings fine.

Config>>>

NetSW095#show running-config
!Current Configuration:
!System Description "PowerConnect 6224, 3.3.8.2, VxWorks 6.5"
!System Software Version 3.3.8.2
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 9,100,810
vlan routing 100 1
vlan routing 9 2
vlan routing 810 3
vlan association subnet 10.10.9.0 255.255.255.0 9
vlan association subnet 10.10.10.0 255.255.255.0 810
vlan association subnet XXX.XXX.100.0 255.255.252.0 100
exit
ip telnet server disable

hostname "NetSW095"
sntp unicast client enable
sntp server XXX.XXX.XX.X priority 2

clock summer-time recurring USA zone "MDT"
clock timezone -7 minutes 0 zone "MST"
stack
member 1 1
exit
ip address none
ip https server
no ip http server
ip routing
ip route 0.0.0.0 0.0.0.0 XXX.XXX.100.1
interface vlan 9
name "SSJumbo"
routing
ip address 10.10.9.95 255.255.255.0
bandwidth 10000
ip mtu 1526
exit
interface vlan 100
name "vlan100"
routing
ip address XXX.XXX.100.95 255.255.252.0

bandwidth 10000
no ip proxy-arp
ip mtu 1500
exit
interface vlan 810
name "Datacenter"
routing
ip address 10.10.10.95 255.255.255.0
exit
username "admin" password --cut-- level 15 encrypted
aaa authentication login "defaultList" local
monitor session 1 destination interface 1/g10
monitor session 1 source interface 1/g24
monitor session 1 mode
ip ssh server
no spanning-tree
!
interface ethernet 1/g1
spanning-tree portfast
mtu 9216
switchport access vlan 9

exit
!
interface ethernet 1/g2
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g3
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g4
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g5

spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g6
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g7
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g8
spanning-tree portfast
mtu 9216
switchport access vlan 9

exit
!
interface ethernet 1/g9
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g10
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g11
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g12

spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g13
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g14
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g15
spanning-tree portfast
mtu 9216
switchport access vlan 9

exit
!
interface ethernet 1/g16
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g17
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g18
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g19

spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g20
spanning-tree portfast
mtu 9216
switchport access vlan 9
exit
!
interface ethernet 1/g21
mtu 9216
switchport access vlan 100
exit
!
interface ethernet 1/g22
mtu 9216
switchport access vlan 100
exit
!

interface ethernet 1/g23
mtu 1526
switchport mode trunk
switchport trunk allowed vlan add 9,100,810
exit
!
interface ethernet 1/g24
negotiation 1000f
mtu 1526
switchport mode trunk
switchport trunk allowed vlan add 9,100,810
exit
!
interface ethernet 1/xg1
mtu 9216
exit
!
interface ethernet 1/xg2
mtu 9216
exit
!

interface ethernet 1/xg3
mtu 9216
exit
!
interface ethernet 1/xg4
mtu 9216
exit
!
interface port-channel 1
mtu 9216
exit
!
interface port-channel 2
mtu 9216
exit
!
interface port-channel 3
mtu 9216
exit
!
interface port-channel 4

mtu 9216
exit
!
interface port-channel 5
mtu 9216
exit
!
interface port-channel 6
mtu 9216
exit
!
interface port-channel 7
mtu 9216
exit
!
interface port-channel 8
mtu 9216
exit
!
interface port-channel 9
mtu 9216

exit
!
interface port-channel 10
mtu 9216
exit
!
interface port-channel 11
mtu 9216
exit
!
interface port-channel 12
mtu 9216
exit
!
interface port-channel 13
mtu 9216
exit
!
interface port-channel 14
mtu 9216
exit

!
interface port-channel 15
mtu 9216
exit
!
interface port-channel 16
mtu 9216
exit
!
interface port-channel 17
mtu 9216
exit
!
interface port-channel 18
mtu 9216
exit
!
interface port-channel 19
mtu 9216
exit
!

interface port-channel 20
mtu 9216
exit
!
interface port-channel 21
mtu 9216
exit
!
interface port-channel 22
mtu 9216
exit
!
interface port-channel 23
mtu 9216
exit
!
interface port-channel 24
mtu 9216
exit
!
interface port-channel 25

mtu 9216
exit
!
interface port-channel 26
mtu 9216
exit
!
interface port-channel 27
mtu 9216
exit
!
interface port-channel 28
mtu 9216
exit
!
interface port-channel 29
mtu 9216
exit
!
interface port-channel 30
mtu 9216

exit
!
interface port-channel 31
mtu 9216
exit
!
interface port-channel 32
mtu 9216
exit
!
interface port-channel 33
mtu 9216
exit
!
interface port-channel 34
mtu 9216
exit
!
interface port-channel 35
mtu 9216
exit

!
interface port-channel 36
mtu 9216
exit
!
interface port-channel 37
mtu 9216
exit
!
interface port-channel 38
mtu 9216
exit
!
interface port-channel 39
mtu 9216
exit
!
interface port-channel 40
mtu 9216
exit
!

interface port-channel 41
mtu 9216
exit
!
interface port-channel 42
mtu 9216
exit
!
interface port-channel 43
mtu 9216
exit
!
interface port-channel 44
mtu 9216
exit
!
interface port-channel 45
mtu 9216
exit
!
interface port-channel 46

mtu 9216
exit
!
interface port-channel 47
mtu 9216
exit
!
interface port-channel 48
mtu 9216
exit

exit

NetSW095#

0 Kudos
Moderator
Moderator

RE: On 6224; variation in Ping response times between vlan IP, Monitor IP, and hosts

Just to confirm, we are seeing the latecy with traffic that is traversing port 1/g24?

Can we run this command on that port, look over some of the counters.

console>show interfaces counters ethernet 1/g24

Is there a reason that jumbo frames is enabled on all ports except ports 23 and 24?

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
lmahaffy
1 Nickel

RE: On 6224; variation in Ping response times between vlan IP, Monitor IP, and hosts

Yes; latency is on traffic that touches the switch through port 1/g24.
Jumbo frames are enabled because the switch is designated to be used as an iSCSI backbone.

NetSW095#show interfaces counters ethernet 1/g24
      Port        InOctets  InUcastPkts InMcastPkts InBcastPkts
---------------- ---------- ----------- ----------- -----------
1/g24            5867958    97          29485       1770
      Port       OutOctets  OutUcastPkts OutMcastPkts OutBcastPkts
---------------- ---------- ------------ ------------ ------------
1/g24            10609      85           5            16
FCS Errors: ................................... 0
Single Collision Frames: ...................... 0
Late Collisions: .............................. 0
Excessive Collisions: ......................... 0
Multiple Collisions: .......................... 0
Oversize Packets: ............................. 3
Internal MAC Rx Errors: ....................... 0
Received Pause Frames: ........................ 0
Transmitted Pause Frames: ..................... 0
Receive Packets Discarded: .................... 8995
Transmit Packets Discarded: ................... 0

Scott

0 Kudos
Moderator
Moderator

RE: On 6224; variation in Ping response times between vlan IP, Monitor IP, and hosts

Your getting some discarded packets, and all the ports are set to Jumbo frames except ports 23 and 24, they are set to mtu 1526. I would look at getting ports 23 and 24 set to mtu 9216 and see if it makes any difference.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
lmahaffy
1 Nickel

RE: On 6224; variation in Ping response times between vlan IP, Monitor IP, and hosts

interface ethernet 1/g24
mtu 9216
switchport mode trunk
switchport trunk allowed vlan add 9,100,810
exit
!

No Change.  Smiley Sad

0 Kudos
lmahaffy
1 Nickel

RE: On 6224; variation in Ping response times between vlan IP, Monitor IP, and hosts

1/g23 is not currently connected.

0 Kudos
Moderator
Moderator

RE: On 6224; variation in Ping response times between vlan IP, Monitor IP, and hosts

I would setup a monitoring session on port 1/g24.

console(config)#monitor session 1 source interface1/g24
console(config)#monitor session 1 destination interface 1/g10
console(config)#monitor session 1 mode

Then plug a client running monitoring software like wireshark into the destination port and look at what packets are being discarded.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
lmahaffy
1 Nickel

RE: On 6224; variation in Ping response times between vlan IP, Monitor IP, and hosts

Smiley Happy  Good suggestion.  I did this.  This is how I found out that the only traffic that was being dropped was to the Vlan interfaces.  No other traffic seemed to be affected, including traffic through the switch.  In addition, there was no indication as to why the switch is dropping packets, or choosing not to respond to some of the packets, or delay it's response.  The switch is not being heavily utilized as I am just now configuring it for use.

Scott

0 Kudos