Highlighted
MiGe
6 Indium

PC6224, native VLAN on trunk port and more than one DHCP relay

Hello.

(This question has been rewritten becuase I got the first problem solved!)


We're already using PC6024's but now we bought a PC6224 for a new site, and that's a little different from the old models.

1) How do I set the native VLAN on a trunk port? "switchport trunk native vlan x" doesn't work on a PC6224.

2) Isn't it possible to have more than 1 DHCP relay address? If I have 2 lines with bootpdhcprelay serverip <IP> then it's only the last line that is used and I need 2 DHCP relays.

Here's the running config:

!Current Configuration:
!System Description "Dell 24 Port Gigabit Ethernet, 2.0.0.12, VxWorks5.5.1"
!System Software Version 2.0.0.12
!
configure
vlan database
vlan  3-4
exit
snmp-server location "CORE"
hostname "EMDKALBSW004"
sntp unicast client enable
sntp server 10.45.15.7
clock summer-time recurring EU zone "utc"
clock timezone 1 minutes 0 zone "CET"
stack
member 1 1
exit
ip address 10.45.15.248 255.255.255.0
ip default-gateway 10.45.15.1
ip address vlan 3
ip routing
ip route 0.0.0.0 0.0.0.0 10.45.15.1
bootpdhcprelay enable
bootpdhcprelay serverip 10.45.15.7
ip helper-address all 10.45.15.7 37
ip helper-address all 10.45.15.7 42
ip helper-address all 10.45.15.7 49
ip helper-address all 10.45.15.7 53
ip helper-address all 10.45.15.7 137
ip helper-address all 10.45.15.7 138
router rip
distance rip 2
exit
interface vlan 3
name "Data"
exit
interface vlan 4
name "VoIP"
routing
ip address  10.45.14.1  255.255.255.0
exit
username "admin" password cea5d07d48eaf0eac3680275e4deffdf level 15 encrypted
spanning-tree mode stp
!
interface ethernet 1/g1
description 'Downlink to Office xfield'
switchport mode trunk
switchport trunk allowed vlan add 3-4
switchport trunk allowed vlan remove 1
exit
!
interface ethernet 1/g2
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g3
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g4
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g5
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g6
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g7
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g8
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g9
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g10
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g11
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g12
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g13
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g14
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g15
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g16
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g17
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g18
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g19
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g20
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g21
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g22
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g23
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g24
spanning-tree portfast
switchport mode general
switchport general pvid 3
no switchport general acceptable-frame-type tagged-only
switchport general allowed vlan add 3
switchport general allowed vlan add 4 tagged
switchport general allowed vlan remove 1
exit
snmp-server group private v1 read Default write Default
snmp-server group private v2 read Default write Default
snmp-server community-group private private
exit


Any help is much appreciated.

Thanks in advance.

Best regards.
Michael
Message Edited by MiGe on 02-06-2008 12:11 PM
0 Kudos
3 Replies
8 Krypton

Re: PC6224, native VLAN on trunk port and more than one DHCP relay

Well as far as the DHCP relay is concerned, one is the current limit. Not sure why they chose to do this but i am hoping we see the ability to use more than one in a future firmware release.

 

As for the Native vlan, On the 62XX series i have worked on when a port is put into a true Trunk mode(not general or access) then there is no native vlan as it only supports tagged packets. Now if your in general mode then you can have the tagged traffic and untagged traffic which would required that the PVID be set for the port or trunk.

 

hope this helps

 

0 Kudos
MiGe
6 Indium

Re: PC6224, native VLAN on trunk port and more than one DHCP relay

Thank you for your reply.

I've solved the native VLAN problem by tagging all my VLANs.

I also hope that a future firmware release will allow more than 1 DHCP relay, because we will need that in near futurel when working with PXE.
0 Kudos
bentz
6 Indium

Re: PC6224, native VLAN on trunk port and more than one DHCP relay

I'm having trouble getting VLAN trunking to work between a 5448 and a 6224F for the native VLAN, and I want to confirm what I believe you've stated below... that the only way to prevent the 6224F from (stupidly) tagging the native VLAN is to move it from switchport mode trunk to switchport mode general... is that correct?
0 Kudos