alexxxxxx
1 Nickel

Perfect iSCSI Config for PowerConnect 6224 ?!?

Hi there πŸ™‚

i'm setting up two new PowerConnect 6224 for iSCSI network. But i'm not sure if the config is completly perfect. Because our HP ProCurve 2848 give me a better IOPS performance, but without JumboFrames !!!

The switch config on both devices is the same. I've connected the two switches via LAG on port 21-24. But i get the same performance by using one or two switches. Port 1 is configured for management.

Anybody have an idea how to tune up this config? πŸ™‚

Config:

console#show running-config
!Current Configuration:
!System Description "PowerConnect 6224, 3.3.5.5, VxWorks 6.5"
!System Software Version 3.3.5.5
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 10
exit
stack
member 1 1
exit
ip address X.X.X.X

ip address vlan 10
!
interface ethernet 1/g1
storm-control broadcast
storm-control multicast
spanning-tree portfast
switchport access vlan 10


exit
!
interface ethernet 1/g2
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g3
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g4
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


exit
!
interface ethernet 1/g5
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g6
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g7
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


exit
!
interface ethernet 1/g8
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g9
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g10
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


exit
!
interface ethernet 1/g11
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g12
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g13
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


exit
!
interface ethernet 1/g14
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g15
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g16
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


exit
!
interface ethernet 1/g17
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g18
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g19
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


exit
!
interface ethernet 1/g20
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g21
channel-group 1 mode on
mtu 9216
exit
!
interface ethernet 1/g22
channel-group 1 mode on
mtu 9216
exit
!
interface ethernet 1/g23
channel-group 1 mode on


mtu 9216
exit
!
interface ethernet 1/g24
channel-group 1 mode on
mtu 9216
exit
!
interface port-channel 1
mtu 9216
exit
exit

0 Kudos
6 Replies
Moderator
Moderator

Re: Perfect iSCSI Config for PowerConnect 6224 ?!?

One of the first and easiest things that can help with operability is ensuring the firmware on the switch is up to date.

www.dell.com/.../powerconnect-6224

The switch also has a built in global command that will automatically optimize the port configuration. That command is.

#iscsi enable

After firmware update and iscsi enable command I would check performance again.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
8 Krypton

Re: Perfect iSCSI Config for PowerConnect 6224 ?!?

At the risk of being self serving, I will say that my posts on rebuilding the 6200 series switches for EqualLogic has not only been extremely popular, but I've used the same arrangement to deploy in a number of environments beyond just my own.  It's bomb proof.  But aside from that, yes, make sure you are running the latest firmware.

vmpete.com/.../reworking-my-powerconnect-6200-switches-for-my-iscsi-san

0 Kudos
alexxxxxx
1 Nickel

Re: Perfect iSCSI Config for PowerConnect 6224 ?!?

I've installed the FW Version 3.3.5.5 - the config i've posted is identicaly on both switches. I've only changed the ip! But after connecting my ESXi's the communication between Ports on different switches don't work anymore. I think it must be the LAG-Config. 

0 Kudos
Moderator
Moderator

Re: Perfect iSCSI Config for PowerConnect 6224 ?!?

The most current firmware is 3.3.7.3, the link i posted will take you to the download for it. What ports do your servers plug into? Does port channel 1 connect the two switches together? you have VLAN 10 created but then no ports placed in VLAN 10. Is VLAN 10 intended to be for the ISCSI traffic? What storage devices are you using and what ports do they plug into?

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
alexxxxxx
1 Nickel

Re: Perfect iSCSI Config for PowerConnect 6224 ?!?

Yes Port-Channel 1 is the connection between the two switches (g21-g24). I've created VLAN 10 only to seperate the iSCSI Traffic from Mgmt-Network. In my config only Port g1 has access to VLAN 10. I would use the default VLAN for ISCSI-Traffic (g2-g20).

Actually i can't ping between the two switches. I'm using a HP MSA P2000 G3 in this environment. But next week i'll connect a PS4100XS too. If it works πŸ˜„

0 Kudos
Moderator
Moderator

Re: Perfect iSCSI Config for PowerConnect 6224 ?!?

For the connection between the two switches we should set the port channel to general mode, set the PVID and tag any other VLANs we want to traverse that connection.

Before we proceed I would like to clarify the intended VLAN setup vs. how it is currently setup.

When you run the command

#ip address vlan 10

You change the management VLAN to VLAN 10.

Then you place port g1 into access mode for VLAN 10 and connect it to our ISCSI storage device. This has created a scenario where your iSCSI traffic and management are on the same VLAN, which is not ideal.

The other ports g2-g24 are all still in the default access mode for VLAN 1.

In most situation the management, ISCSI, and servers are all on their own VLAN. Then a routing device on the network will perform VLAN routing to enable the VLANs to communicate with each other.

Example:

Create three different VLANs

console(config)#vlan database

console(config-if)#vlan 10 (this one is for management, not required as VLAN 1 can be left as the management)

console(config-if)#Vlan 20 (ISCSI)

console(config-if)#Vlan 30 (Server)

Make VLAN 10 the management VLAN

console(config)#ip address vlan 10

Assign ports with ISCSI storage devices to VLAN 20 for our ISCSI traffic

console(config-if)#switchport access vlan 20

Assign other ports that have servers plugged into  them into our server VLAN

console(config-if)#switchport access vlan 30

Set the connection between the two switches to general mode.

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 20,30 tagged

console(config-if)# switchport general pvid 10

If you want one of the 6224 switches to perform the routing, run these commands.

console#config

console(config)#ip routing

console(config)#interface vlan 10

console(config-if-vlan2)#routing

console(config-if-vlan2)#exit

console(config)#interface vlan 20

console(config-if-vlan3)#routing

console(config-if-vlan3)#exit

console(config)#interface vlan 30

console(config-if-vlan4)#routing

console(config-if-vlan4)#end

So I would look at changing some of the VLAN setup. If anything at least get the management traffic separate from the server/ISCSI traffic.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos