jericsmith
1 Copper

PowerConnect 3524 VLAN help.

I have inherited the administration of a PowerConnect 3524P. We had to reset it to factory as the prior admin left no credentials. I have never used Dell switches before (used to Netgear or Ubiquiti for Layer 2). I am pulling my hair out trying to accomplish what I think is a fairly simple configuration.

1. Use the G3 port to uplink to our router. So far I get nothing unless the router is connected to any of the ports 1-24

2. Setup ports 1-14 to serve up VLAN 20 from my router. I have set the ports up to be members of VLAN 20 and have it set to tag, but I get nothing. Again, I'm used to configuring this on other brands and I'm sure I'm just overlooking something simple.

Any assistance would be much appreciated. 

thanks!

0 Kudos
3 Replies
Anonymous
Not applicable

RE: PowerConnect 3524 VLAN help.

Most of the time the ports that connect to end device, workstation, laptops, server, will send and receive untagged frames. Ports 1-2,4-14 can be placed in access mode for VLAN 20. This means that any untagged frames received will be placed on VLAN 20. Ports 15-24 can be left in the default access mode for VLAN 1. Then port 3 that connects to your router will need to be set to Trunk mode in order to allow traffic from both VLANs to traverse that connection.

Here is an example of what the commands would look like.

Console(config)# interface ethernet 1/e1

Console(config-if)# switchport mode access

Console(config-if)# switchport access VLAN 20

Console(config)# interface ethernet 1/e3

Console(config-if)# switchport mode trunk

Console(config-if)# switchport trunk allowed vlan add 20

Your router will also need to have it's port set to tag VLAN 20. If Trunk mode doesnt seem to be working, you can also try general mode.

Console(config)# interface ethernet 1/e3

Console(config-if)# switchport mode general

Console(config-if)# switchport general allowed vlan add 20 tagged

Page 494 of the CLI guide has some further info on the switchport mode command.

http://dell.to/1M27iYP

Let us know if this helps.

0 Kudos
jericsmith
1 Copper

RE: PowerConnect 3524 VLAN help.

Figured it out. I needed the configure config the trunk to accept the vlans. All working now. Woot

0 Kudos
Highlighted
Anonymous
Not applicable

RE: PowerConnect 3524 VLAN help.

Excellent, glad to hear it.

0 Kudos