Aloron
2 Bronze

PowerConnect 5324 Firmware ?????

Hi Everyone,

I have a 5324 here in my office and I logged into with hyper termial with no trouble and I notice that the firmware on the box is dated back to 2004 .. I checked the website and see that there is a new verison out there ..

So I downloaded it and did the xmodem send a file and everything was going fine .. took 3 hours but no big deal .. it gets done and does it thing and reboots and it still coming up with the firmware from 2004 .. so did it again , same thing ..

what might i be missing ?

 

thanks ..

0 Kudos
8 Replies
Anonymous
Not applicable

Re: PowerConnect 5324 Firmware ?????

There are a few different ways to perform the update. You may want to try another method, like using the Web GUI.

Downloading Files:

1 Open the File Download From Server page.

2 Define the file type to download.

3 Define the fields.

4 Click Apply Changes.

The software is downloaded to the device.

Once applied the running config needs to be copied to the startup config.

Copying Files

1 Open the Copy Files page.

2 Define the Source and Destination fields.

3 Click Apply Changes.

The file is copied, and the device is updated.

Then reset the device.

Resetting the Device

1 Open the Reset page

2 Click reset.

A confirmation message displays.

3 Click OK.

The device is reset. After the device is reset, a prompt for a user name and password displays.

4 Enter a user name and password to reconnect to the Web Interface.

You can also perform the same tasks using the CLI. These methods can all be found in the owners guide.

support.dell.com/.../5324UG.pdf

A big thing is to make sure the running config is saved to the startup config before restarting.

Keep us updated.

Thanks.

0 Kudos
Aloron
2 Bronze

Re: PowerConnect 5324 Firmware ?????

Thanks DELL-Daniel Co , using the GUI sure about be nice but as the switch was some how wiped cleaned there is no running config or anything in it .. its like someone did a facorty reset on it ..

so I havent figure out yet how to get into the gui if there even is one ..

0 Kudos
Anonymous
Not applicable

Re: PowerConnect 5324 Firmware ?????

The 5324 does not have a default IP address, so if it has been cleared, it will not have a IP address you can use to connect to the WEB GUI or Telnet. You will have to use the console port and directly connect to the switch.

When you are connected through the hyper terminal are you able to run any commands?

Once you have a connection to the console you should have a regular config prompt you can then set the IP address for the switch so you can access it.

console(config)#ip address xxx.xxx.xxx.xxx

If you can set the IP address you can telnet or use the web gui.

If that cannot be done then you will be stuck using the boot menu/ xmodem method.

I would also double check to make sure this version is being used.

www.dell.com/.../DriverDetails

These are the notes I have on performing the boot menu update, I would follow through these steps and make sure nothing was skipped.

1.During the switch startup, press [Esc] ONLY ONCE to enter into the startup prom menu.

For this procedure to work, you must be on site, physically at the switch.

2.Once the prom startup Menus appears, type [Ctrl]-[Shift]-6 to activate the Advanced Menu options.

3.A message will appear stating that the Advanced Menu is activated. Press [Enter] to continue.

4.Press 6 to select the new Advanced Menu.

5.Once the Advanced Menu appears, select 2 to go to the Image Menu.

6.On the Image Menu, select 1 to view the current active operating system image.

7.A message will appear stating that Image-1 or Image-2 is the active image. Press [Enter] to continue.

8.Select 2 to set the current image. At the Insert the new image index:[0,40] prompt, the first number represents the start location of the first image in the flash and the second number represents the start location of the second image.

To activate the first image, enter the first number and press [Enter]. To activate the second image, enter the second number and press [Enter].

9.After returning the Image Menu, select 1 to verify that the correct image is selected for bootup. Press [Enter] to continue.

10.Select 3 to back up to the previous menu.

NOTE:

DO NOT press [Esc] at this point. If [Esc] is pressed, the power will need to be cycled again or the reload command issued again after complete bootup to have the opportunity to enter into the prom menu again.

11.Once the Startup Menu appears, select 1 to download a new operating system image.

12.In your VT100 terminal program, choose to transfer a file via Xmodem.

13.Choose the operating system image file to send and click OK. Usually, operating system image files end with a .dos extension.

14.The VT100 terminal program will report the file transfer status.

15.Once the file transfer is complete, the flash sector for the selected image will be deleted and the file will be saved to the flash chip. If the CRC checksum is verified successfully, a Flash programming success message will show.

The switch will now start a warm boot into the new operating system image, if selected previously.

16.During the bootup, the startup banner will show that the switch is using the newly downloaded operating system image.

17.To verify that the correct operating system image file is being used, type show version.

I hope this helps some, Keep us updated on what you find.

Thanks.

0 Kudos
Aloron
2 Bronze

Re: PowerConnect 5324 Firmware ?????

Thanks for the info Dan , but didnt work .. got the same thing , it goes all the way though sending the file via xmodem says everything was fine .. and when it reboots it still using the old SW Ver. 1.0.0.45 ..

Only thing I did find out is that its using software image 2 , there is nothing in the software image 1 .. because when i tried to run software iamge 1 i got "arc file does not exist"

Any other advice ?

0 Kudos
Anonymous
Not applicable

Re: PowerConnect 5324 Firmware ?????

It is sounding more and more like a hardware issue, since image 1 is not accepting the flash. We can try copying image 2 to image 1. See if this can even be done. The command would look something like.

# copy image 2 image 1

If that does not work then try out

# copy startup-config backup-config

Or

# copy startup-config image 1

If that works then we can try booting to that image 1, and apply the firmware again.

Let us know if that works.

0 Kudos
Aloron
2 Bronze

Re: PowerConnect 5324 Firmware ?????

Thanks Dan for all the help ..

I tried " copy image 2 image 1 " and got % Invalid input detected

then tried " copy startup-config backup-config " and got Copy: The source file is empty

then tried " copy startup-config image 1 " and got % Invalid input detected ..

any thoughts now ?? or can i shoot it ..

0 Kudos
Anonymous
Not applicable

Re: PowerConnect 5324 Firmware ?????

Sorry to hear that none of this has worked. I will continue doing some research, and if I find anything else, I will post it here. But it seems more and more that this is a hardware issue.

0 Kudos
markfen88
2 Bronze

Re: PowerConnect 5324 Firmware ?????

Aloron,

I ran into the same issue but finally got it working. You need to first update your boot rom.

0 Kudos