Highlighted
Moderator
Moderator

PowerConnect Common Questions Between Access, General and Trunk mode

ACCESS MODE:

 

Access Links connect VLAN unaware devices to the port of a VLAN-aware switch. All frames on access links are untagged.

The VLAN switch adds tags to received frames, and removes tags when transmitting frames.

End users and VLAN-unaware workstations commonly reside on access links.

By Default all ports are in ACCESS mode assigned to the default VLAN (VLAN 1).

Ports set to Access mode belong to one VLAN only.

 

Configuring Access Ports

console> enable

console# config

console(config)# interface ethernet 1/e1

console(config-if)# switchport mode access

console(config-if)# switchport access vlan 2

console(config-if)# end

 

GENERAL MODE:

 

General Links consist of a combination of VLAN Trunk and Access Links.

General Links can have both tagged and untagged frames, However, all frames sent to a specific VLAN must be tagged.  All untagged  frames are sent to the native VLAN.

The native VLAN still applies to the General LINK.  While it is possible to have multiple untagged vlans on a General link, you can only have ONE (1) PVID.  The PVID represents the native VLAN. 

While untagged traffic may be sent via several untagged VLANs, returning untagged traffic will only be received by the PVID and therefore will NOT be forwarded to a specific VLAN.

 

Configuring General Ports

 console> enable

console# config

console(config)# interface ethernet 1/e7

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 2 tagged

console(config-if)# end

 

 

 

Remove VLANs From General Ports

console# config

console(config)# int eth 1/e7

console(config-if)# switchport general allowed vlan remove 2

console(config-if)#

  

TRUNK MODE:

 

Trunk Links attach two VLAN aware switches (or other VLAN aware devices) together and allows for multiple VLAN frames to cross one link.

On VLAN trunk links, all frames must be tagged with the respective VLAN ID’s

The native VLAN must match on all switches in the segment. (VLAN 1 is default Native VLAN).  The native VLAN is NOT tagged.

 

Configuring Trunk Ports

 console> enable

console# config

console(config)# interface ethernet 1/e5

console(config-if)# switchport mode trunk

console(config-if)# switchport trunk allowed vlan add 2

console(config-if)# end

 

Remove VLAN From Trunk Port

 console> enable

console# config

console(config)# interface ethernet 1/e5

console(config-if)# switchport trunk allowed vlan remove 2

#iwork4Dell
Get Support on Twitter: @DellCaresPRO