wolfsden3
1 Nickel

PowerConnect N20xx vlan routing

Hi,

I haven't found a good enough answer in any of the forum posts about vlan routing with the N2000 series switches.  Can someone help?

I did this with the 6224's and 6248's but that PDF document tutorial and how to is pretty straight forward.  I don't think the N2000's are the same on the CLI though.

Here's part of my config, the "#" are my comments about what I'm doing:

!Current Configuration:
!System Description "Dell Networking N2024P, 6.3.2.6, Linux 3.6.5-e788596a"
!System Software Version 6.3.2.6

# Configure frame size
# access
hostname "Switch Stack 1"
ip telnet server disable
system jumbo mtu 9216
no ip http server
ip http secure-server
ip http secure-certificate 1
ip http secure-protocol TLS1 SSL3
ip ssh server
no spanning-tree

# Enable IP Routing?
ip routing

# Configure the switch ports
configure
vlan 100
vlan 100
name "New 10 Network"
interface vlan 100
ip address 10.0.3.240 255.255.252.0
interface vlan 1
name "Old 200 Network"
ip address 200.111.111.26 255.255.255.0

# It used to be you couldn't route vlan 1...has this changed BTW?

# Configure the interfaces
interface Gi1/0/22
switchport access vlan 100

That's basically all I've got.  I can assigned more switch ports to vlan 100, etc BUT if I had a non-vlan 100 member (vlan 1 for example) can that even route?  It used to be on the 62xx series (and with Cisco I believe) that you couldn't route the default vlan (vlan 1).  Can you do that now?

What is the setup to route between my 10.x.x.x network and the 200.x.x.x network?  By the way, the 200.x.x.x/24 is an INTERNAL network someone setup it's NOT an external facing interface.  That's why we're changing it to the 10.x.x.x/22 :-)

I assume to get things to route I'd need a gateway.  I've seen some people posting commands BUT they don't explain them for example:

ip route 0.0.0.0 0.0.0.0 192.168.0.1

I assume that routes all 192.x.x.x traffic somewhere...but where?

This particular setup was from a PDF someone uploaded (or a text file or something) with their config asking similar vlan routing questions.  Here is a snippet of their code:

ip routing
interface vlan 1 1
ip address 192.168.13.1 255.255.255.0
exit
interface vlan 1681 2
ip address 192.168.1.1 255.255.255.0

interface vlan 1682 6

ip address 192.168.2.1 255.255.255.0
bandwidth 10000
exit
interface vlan 1683 4
ip address 192.168.3.1 255.255.255.0
exit
interface vlan 1684 5
ip address 192.168.4.1 255.255.255.0
bandwidth 10000
exit
interface vlan 1685 7
ip address 192.168.5.1 255.255.255.0
bandwidth 10000
exit
interface vlan 1686 8
ip address 192.168.6.1 255.255.255.0
bandwidth 10000
exit
interface vlan 1687 3
ip address 192.168.11.1 255.255.255.0
bandwidth 10000
exit
ip route 0.0.0.0 0.0.0.0 192.168.0.1

Why would they put in a command like:  "interface vlan 1 1"...what's with the "1 1" exactly...is that a hop or preference?

The 6200 series never had anything like that from what I remember.  It was here's your gateway, there's your route and you could route anything you wanted to and fro!

If anyone could help me out and help me to understand what's going on it would be much appreciated.  I downloaded the cli manual for the N2000 but the ip routing section is filled with just a bunch of protocol stuff and it doesn't really tell me much, has some "virtual router" stuff in there with a command like "vre red" in it which again...is more confusing because different models of L3 switches didn't ever call it a virtual router they just called it routes!

Thanks for any help on this!

0 Kudos
3 Replies
Moderator
Moderator

RE: PowerConnect N20xx vlan routing

Hi,

Here is some documentation on vlan routing Page 790 http://downloads.dell.com/manuals/common/networking_nxxcli_en-us.pdf

VLAN 1 can be routed, but it still is best practice to not do it. Are both of the VLANs going to be connected to this switch? Is it just the two VLANs that you are using? Assigning an IP address to each of the VLANs and then creating a static route should work.  Page 1469. 

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos
Highlighted
wolfsden3
1 Nickel

RE: PowerConnect N20xx vlan routing

Awesome man I will check it out!

I have a switch stack but if I needed to connect via ethernet to anther L2 or L3 switch I have to use a trunk port on the ethernet connected ports right?

Thanks for your help!

0 Kudos
Moderator
Moderator

RE: PowerConnect N20xx vlan routing

Either a trunk port or general port. 

Thanks,
Josh Craig
Dell EMC Enterprise Support Services
Get support on Twitter @DellCaresPRO
0 Kudos