Highlighted
uwlmjeff
1 Copper

Powerconnect 2724 - Segmenting switch for iSCSI VLAN

Hello,

I have a Powerconnect 2724, an ESXi host, and a Drobo Elite storage array.


As I currently don't have a spare gigabit switch that can support jumbo frames, I thought that I'd try to segment off ports 17-24 (total of 😎 for use as a private VLAN for the iSCSI backend but have been having trouble getting it configured correctly.

The instructions as I understand them are:

  1. Under 'VLAN Membership', create a new VLAN (for example, VLAN ID 2)
  2. Select VLAN ID 2, then toggle ports 17-24 to 'U' and apply changes
  3. Under 'VLAN Port Settings', set the PVID on ports 17-24 to '2', Frame Type 'Admit All', Ingress 'Enable' and apply changes
  4. All devices plugged into ports 17-24 are all on the same IP subnet (different IP subnet from ports 1-16 though)

However, when this setup is completed, devices plugged into ports 17-24 no longer seem to be able to talk to each other...

Any help in sorting this out is greatly appreciated.

Tags (1)
0 Kudos
4 Replies
BrandonSchultz
1 Copper

Re: Powerconnect 2724 - Segmenting switch for iSCSI VLAN

I'm trying to do the exact same thing and having problems. I have created a new VLAN and added a route on the machine that has Drobo Dashboard. I can ping and get a reply from the IP assigned to the new VLAN I created, but the DroboElite's iSCSI ports do not reply to a ping from that subnet. I've double checked and triple checked my switch settings -- PVID's are correct, routing enabled on the new VLAN, U's are ticked on the two ports going to the iSCSI ports -- but no reply from ping. Really frustrating. Anyway, if you come up with a solution kindly let me know what you did to fix. I'll do the same for you if I find a solution.

0 Kudos
bh1633
3 Cadmium

Re: Powerconnect 2724 - Segmenting switch for iSCSI VLAN

I just tried this and it works.

Are any of your hosts or Drobo thing configured for tagged traffic?  If so, the switch will not switch tragged traffic with the configuration described here.

0 Kudos
BrandonSchultz
1 Copper

Re: Powerconnect 2724 - Segmenting switch for iSCSI VLAN

I don't the Drobo or the Windows machine is processing tagged packets. It's a pretty simple setup, really. The VLAN has been assigned an IP and routing enabled. I added a persistent route to that subnet on my Windows 7 machine and I can get a reply from the VLAN's IP. But I get no reply from a ping from the Drobo ports. The two iSCSI ports on the Drobo only have three configuration options: 1. IP address, 2. Subnet mask, 3. Gateway IP. I've assigned each port with an IP on the VLAN's subnet inside an appropriate net mask, and set the gateway to the IP of the VLAN. No dice.

0 Kudos
bh1633
3 Cadmium

Re: Powerconnect 2724 - Segmenting switch for iSCSI VLAN

"I don't the Drobo or the Windows machine is processing tagged packets. "

BH: This sentence is missing a key word.  Please correct

It's a pretty simple setup, really. The VLAN has been assigned an IP and routing enabled.

BH: what IP and where was routing enabled?  What is the IP, mask, default gateway and/or routes on this box?  Post output of "route print" or equivalent.

I added a persistent route to that subnet on my Windows 7 machine and I can get a reply from the VLAN's IP. But I get no reply from a ping from the Drobo ports.

BH: What vlan IP?  On the W7 box? Do you have the W7 firewall set to allow ping?  If you connect the W7 box directly to the Drobo, does it work?

 The two iSCSI ports on the Drobo only have three configuration options: 1. IP address, 2. Subnet mask, 3. Gateway IP. I've assigned each port with an IP on the VLAN's subnet inside an appropriate net mask, and set the gateway to the IP of the VLAN. No dice.

BH: What is the IP, mask and gateway of the Drobo.

0 Kudos