switch-newbie
1 Copper

Powerconnect 51112 / Problem with IP-Adress

Dear all,

need your help - can not assign my 5112 a IP-Adress, and by DHCP the switch is not receiving a IP-Adress (DHCP-Server is working to many other clients well - only the switch has a problem. The same to assing a IP-adress to the switch - Invalid input detected at '^' marker.

Do I need to connect to a special RJ45 to receive via DHCP a IP-Adress?

I´m not a IT-proffesional and only have a limited know-how - and this is my first switch!

Console#show running-config
building running-config, please wait.....
!
snmp-server community private rw
snmp-server community public ro
!
username admin access-level 15
username admin password 7 xyz
username guest access-level 0
username guest password 7 xyz
enable password level 15 7 xyz
!
vlan database
 vlan 1 name DefaultVlan media ethernet state active
!
interface ethernet 1/1
 switchport allowed vlan add 1 untagged
 switchport native vlan 1
!
interface ethernet 1/2
 switchport allowed vlan add 1 untagged
 switchport native vlan 1
!
interface ethernet 1/3
 switchport allowed vlan add 1 untagged
 switchport native vlan 1
!
interface ethernet 1/4
 switchport allowed vlan add 1 untagged
 switchport native vlan 1
!
interface ethernet 1/5
 switchport allowed vlan add 1 untagged
 switchport native vlan 1
!
interface ethernet 1/6
 switchport allowed vlan add 1 untagged
 switchport native vlan 1
!
interface ethernet 1/7
 switchport allowed vlan add 1 untagged
 switchport native vlan 1
!
interface ethernet 1/8
 switchport allowed vlan add 1 untagged
 switchport native vlan 1
!
interface ethernet 1/9
 switchport allowed vlan add 1 untagged
 switchport native vlan 1
!
interface ethernet 1/10
 switchport allowed vlan add 1 untagged
 switchport native vlan 1
!
interface ethernet 1/11
 switchport allowed vlan add 1 untagged
!
interface ethernet 1/12
 switchport allowed vlan add 1 untagged
 switchport native vlan 1
!
interface vlan 1
 ip address 0.0.0.0 255.0.0.0
 ip address dhcp
!

Console(config)#interface vlan 1
Console(config-if)#ip adress 192.168.xyz .xyz 255.255.255.0
                        ^
% Invalid input detected at '^' marker.
Console(config-if)#

Console(config-if)#ip default gateway 192.168.xyz .xyz
                      ^
% Invalid input detected at '^' marker.
Console(config-if)#

 

What should I do now to assign a IP to this switch?

Many thanks to your help !!!

Peter

0 Kudos
3 Replies
bdearlove
2 Iron

Re: Powerconnect 51112 / Problem with IP-Adress

Configuring the IP address looks correct except you mis-spelt the word address. 

Configuring the Default gateway you do not do in the VLAN section, exit out one to (Config)

There is also a spot on the Powerconnect 5XXX which disables DHCP broadcasts and is enabled by default, that is probably what is stopping you. Sorry, I do not know where it is located on the CLI though.

 

0 Kudos
switch-newbie
1 Copper

Re: Powerconnect 51112 / Problem with IP-Adress

Dear bdearlove,

Invalid input detected at '^' marker. - if I will not receive this message after sending a command by CLI, I would be able to change some settings. What could be the Prob.?

As example show running-config will do, what I want, show ip is result Invalid input detected at '^' marker - whats wrong with my input (anyway if in config or not - in all areas of CLI I will get this crazy result...

kind regards

/Peter

 

Configuring the IP address looks correct except you mis-spelt the word address. 

Configuring the Default gateway you do not do in the VLAN section, exit out one to (Config)

There is also a spot on the Powerconnect 5XXX which disables DHCP broadcasts and is enabled by default, that is probably what is stopping you. Sorry, I do not know where it is located on the CLI though.

 

 

0 Kudos
switch-newbie
1 Copper

Re: Powerconnect 51112 / Problem with IP-Adress

Dear bdearlove,

 

thanks to your first answer - now I understood your words - all working fine now - once again thanks!

 

cu

/Peter

0 Kudos