Highlighted
Patbl
Bronze

Powerconnect 5424 transceiver in 5524P

My fibre internet provider requires that I use their transceiver (a Huawei SmartAX MA5671A SC transceiver) which works seamlessly in my Powerconnect 5424. I use one SFP port essentially as a media converter to my router (vlan 35) and then back to the switch (vlan 1). This has worked without any issue for months.

I wanted to move to a POE capable switch and picked up a 5524P. I have been able to get the 5524P to recognize the transceiver by setting the port speed to 1000. The switch reports that the link is up (show fiber-ports optical-transceiver) but I can't seem to establish a connection. The LEDs also seem to show activity.

is there something else I can do to try to identify the problem?

here is my configuration on the 5524P:

interface vlan 1
ip address 192.168.2.4 255.255.255.0
!
interface vlan 35
name "Bell Internet"
!
interface gigabitethernet1/0/1
switchport access vlan 35
!
interface gigabitethernet1/0/17
channel-group 1 mode on
!
interface gigabitethernet1/0/18
channel-group 1 mode on
!
interface gigabitethernet1/0/19
channel-group 2 mode on
!
interface gigabitethernet1/0/20
channel-group 2 mode on
!
interface tengigabitethernet1/0/1
speed 1000
switchport mode trunk
switchport trunk allowed vlan remove 1-34,36-4094
!

 

and on the 5424

interface ethernet g24
switchport mode trunk
exit
vlan database
vlan 35
exit
interface ethernet g2
switchport access vlan 35
exit
interface ethernet g24
switchport trunk allowed vlan add 35
exit
interface vlan 35
name "Bell Internet"
exit

 

Any help would be appreciated

0 Kudos
12 Replies
Moderator
Moderator

Re: Powerconnect 5424 transceiver in 5524P

It sounds like the transceiver is going to work, perhaps the config needs some tweaking. Can you provide some additional information on which ports plug into the firewall?

The ports that plug into the firewall should probably be set to Access mode for VLAN 35.

Port channel is used to combine multiple interfaces into one logical interface. Do ports 17 and 18 plug into the same device? ports 19 and 20?

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
Patbl
Bronze

Re: Powerconnect 5424 transceiver in 5524P

Port g2 goes to the firewall on the 5424. This will be done by port 1 (gigabitethernet1/0/1) for the 5524P.

ports 17,18 and 19,20 will be connected in NASs once I get this issue resolved.

 

Thanks

0 Kudos
Moderator
Moderator

Re: Powerconnect 5424 transceiver in 5524P

If I am understanding correctly, I believe the config will need to have the ISP and one of the router connections set to untagged for VLAN 35, then the second connection from the router set to untagged for VLAN 1(which should be the default).

Switchport mode access
Switchport access vlan 35

I have put together a little diagram, let me know if this is not the correct topology.

5524 isp connection.png

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
Patbl
Bronze

Re: Powerconnect 5424 transceiver in 5524P

The topology looks essentially right but I have the ISP connected to the SFP port (tengigabitethernet1/0/1).

I have that port as a trunk, I will try to set it to access tonight.

I'll let you know. 

Patbl
Bronze

Re: Powerconnect 5424 transceiver in 5524P

So it tried setting the trunk port to access and still no luck.
here are some of the diagnostics I recorded in an effort to provide all the information you might need.

The one thing I noticed is that the diagnostic of the transceiver is not providing as much information on the 5524P as the 5424.

Thanks again

5524P Ottawa# $tical-transceiver interface tengigabitethernet 1/0/1 detailed

Port Temp Voltage Current Output Input LOS
[C] [Volt] [mA] Power Power
[mWatt] [mWatt]
----------- ------ ------- ------- ------- ------- ---
te1/0/1 0 0.0 0.0 1.00 1.00 No

Temp - Internally measured transceiver temperature
Voltage - Internally measured supply voltage
Current - Measured TX bias current
Output Power - Measured TX output power in milliWatts
Input Power - Measured RX received power in milliWatts
LOS - Loss of signal
N/A - Not Available, N/S - Not Supported, W - Warning, E - Error

 

from the 5424:

Optical Transceiver Diagnostics




Port g24


**bleep** Status

Temperature 36 (C)
Voltage 3.2955 (V)
Current 3.783 (mA)
Output Power 16.14 (mWatt)
Input Power 0.34 (mWatt)
Transmitter Fault False Not Relevant
Loss of Signal N/S Not Relevant
Data Ready False Not Relevant

0 Kudos
Patbl
Bronze

Re: Powerconnect 5424 transceiver in 5524P

additional information from the 5524P

Other information from the 5524P

5524P Ottawa# show interfaces switchport tengigabitethernet 1/0/1
Gathering information...

Name: te1/0/1
Switchport: enable
Administrative Mode: access
Operational Mode: up
Access Mode VLAN: 35
Access Multicast TV VLAN: none
Trunking Native Mode VLAN: 1
Trunking VLANs Enabled: 1,35
2-34,36-4094 (Inactive)
General PVID: 1
General VLANs Enabled: none
General Egress Tagged VLANs Enabled: none
General Forbidden VLANs: none
General Ingress Filtering: enabled
General Acceptable Frame Type: all
General GVRP status: disabled
Customer Mode VLAN: none
Private-vlan promiscuous-association primary VLAN: none
Private-vlan promiscuous-association Secondary VLANs Enabled: none
Private-vlan host-association primary VLAN: none
Private-vlan host-association Secondary VLAN Enabled: none
DVA: disable

Classification rules:

Classification type Group ID VLAN ID
------------------- -------- -------


5524P Ottawa# show interfaces switchport gigabitethernet 1/0/1
Gathering information...

Name: gi1/0/1
Switchport: enable
Administrative Mode: access
Operational Mode: up
Access Mode VLAN: 35
Access Multicast TV VLAN: none
Trunking Native Mode VLAN: 1
Trunking VLANs Enabled: 1,35
2-34,36-4094 (Inactive)
General PVID: 1
General VLANs Enabled: none
General Egress Tagged VLANs Enabled: none
General Forbidden VLANs: none
General Ingress Filtering: enabled
General Acceptable Frame Type: all
General GVRP status: disabled
Customer Mode VLAN: none
Private-vlan promiscuous-association primary VLAN: none
Private-vlan promiscuous-association Secondary VLANs Enabled: none
Private-vlan host-association primary VLAN: none
Private-vlan host-association Secondary VLAN Enabled: none
DVA: disable

Classification rules:

Classification type Group ID VLAN ID
------------------- -------- -------

5524P Ottawa# show vlan

Vlan Name Tagged Ports UnTagged Ports Type Authorization
---- ------------ ------------------ ------------------ --------- -------------
1 1 gi1/0/2-16, Default Required
gi1/0/21-48,
te1/0/2,
gi2/0/1-48,
te2/0/1-2,
gi3/0/1-48,
te3/0/1-2,
gi4/0/1-48,
te4/0/1-2,
gi5/0/1-48,
te5/0/1-2,
gi6/0/1-48,
te6/0/1-2,
gi7/0/1-48,
te7/0/1-2,
gi8/0/1-48,
te8/0/1-2,Po1-32
35 Bell gi1/0/1,te1/0/1 permanent Required
Internet

 

0 Kudos
moxom
Bronze

Re: Powerconnect 5424 transceiver in 5524P

You could try to assign vlan 35 to the PC access port and assign the appropriate IP address. (or assign an IP address to interface VLAN 35 - same same). To check if you at least have a connection before the router.

0 Kudos
Patbl
Bronze

Re: Powerconnect 5424 transceiver in 5524P

I'm not sure I understand the proposal. My router is not only acting as a firewall but is also establishing a pppoe connection, which is why my router is necessary. I can try to have a computer establish the pppoe connection instead of the router.

I'll give it a try and see if there is a different result but I don't really understand why this would make a difference. 

I may not be able to get back to this for a week as I will be traveling but any ideas continue to be welcome. 

Thanks

0 Kudos
moxom
Bronze

Re: Powerconnect 5424 transceiver in 5524P

If you're absolutely sure the router/firewall and cables is working as it should, It shouldn't make a difference, but in my experience it's easier to test if you simplify the setup as much as possible.

Sometimes you get surprised where the issues lie.. I have never experienced any SFP errors when the link is up.. usually, if the transceiver is faulty, you wont get a link at all.. which is what leads me to think there's something else going on. I could be wrong though.

If the ports from ISP -> Router is set to switchport mode access and VLAN 35 (depending on how the ISP port is configured) and the port from router -> PC is vlan 1, the switch configuration should be good.

Which is why I would try to take out the router of the equation - that is my thought process, if you don't agree feel free to wait for other suggestions Smiley Happy

 

 

0 Kudos