Highlighted
Andy Gough
1 Copper

Powerconnect 6248 VLAN's

Hi all,

We have had two dell Power connects running our iSCSI network for some time now, we recently upgraded to a newer firmware (3.3.1.10 from 3.2.1.3), and stacked them together.

We now want to create a new VLAN for vMotion traffic, but are having issues.  I created VLAN50 with IP 10.0.0.253/24, our existing iSCSI network is on VLAN1 with range 192.168.0.0/16.  I plugged a single machine into a port setup as an access port, configured it with a 10.0.0.111 address, and untagged the 50 VLAN in it.

However, when i run 'show ip interfaces', it shows vlan 50 as 'down'.  There are no network devices between the switch and the machine, the port itself shows up, but when i run wireshark, i can only see ARP traffic going out from my machine, nothing coming back from the 10.0.0.0 network.

This is the config:


!Current Configuration:
!System Description "PowerConnect 6248, 3.3.1.10, VxWorks 6.5"
!System Software Version 3.3.1.10
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 50
vlan routing 50 1
vlan association subnet 10.0.0.0 255.255.255.0 10
exit
stack
member 1 2
member 2 2
exit
ip address 192.168.90.201 255.255.255.0
ip default-gateway 192.168.90.199
interface vlan 50
name "vMotion"
routing
ip address 10.0.0.253 255.255.255.0
ip mtu 9000
exit
username "administrator" password 8072972100438434899a51fd3e255844 level 15 encrypted
!
interface ethernet 1/g1
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g2
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g3
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g4
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g5
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g6
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g7
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g8
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g9
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g10
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g11
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g12
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g13
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g14
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g15
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g16
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g17
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g18
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g19
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g20
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g21
spanning-tree portfast
mtu 9216
switchport access vlan 50
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g22
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g23
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g24
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g25
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g26
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g27
description 'Link-To-Attenda'
spanning-tree portfast
mtu 9216
switchport mode trunk
switchport trunk allowed vlan add 1
exit
!
interface ethernet 1/g28
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g29
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g30
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g31
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g32
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g33
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g34
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g35
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g36
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g37
spanning-tree portfast
mtu 9216
switchport mode trunk
switchport trunk allowed vlan add 1
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g38
spanning-tree portfast
mtu 9216
switchport mode trunk
switchport trunk allowed vlan add 1
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g39
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g40
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g41
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g42
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g43
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g44
spanning-tree portfast
mtu 9216
no lldp transmit
no lldp receive
exit
!
interface ethernet 1/g45
traffic-shape 1024000 kbps
spanning-tree portfast
mtu 9216
switchport mode trunk
switchport trunk allowed vlan add 1
exit
!
interface ethernet 1/g46
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g47
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g48
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/xg1
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/xg2
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/xg3
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/xg4
spanning-tree portfast
mtu 9216
exit
snmp-server community rw
exit

Can anyone see why my VLAN isn't coming up?

Thanks
0 Kudos
4 Replies
jp1110
1 Nickel

Re: Powerconnect 6248 VLAN's

Your trunk is not passing VLAN50.

interface ethernet 1/g37

spanning-tree portfast

mtu 9216

switchport mode trunk

switchport trunk allowed vlan add 1  <--- !

no lldp transmit

no lldp receive

exit

!

interface ethernet 1/g38

spanning-tree portfast

mtu 9216

switchport mode trunk

switchport trunk allowed vlan add 1  <--- !

no lldp transmit

no lldp receive

exit

!

0 Kudos
Andy Gough
1 Copper

Re: Powerconnect 6248 VLAN's

Apologies, looks like I uploaded an incomplete config from earlier.  I do have the VLAN 50 allowed on the trunk.  Can anyone see any other issues with the config?  I plan to take the iSCSI network down in a week or two, flatten the switch, and reconfigure.  Believe it's an issue in how we stacked the switches, so hopefully that will resolve it, unless anyone can see another problem

0 Kudos
jp1110
1 Nickel

Re: Powerconnect 6248 VLAN's

Can you get on and show us the current running config.  It should include both switches - from this we should be able to see what stands out.  As always strip out any private stuff you don't want advertised...

0 Kudos
Andy Gough
1 Copper

Re: Powerconnect 6248 VLAN's

This will have to wait until the weekend now unfortunately.  I'm going to blat the two switches on our DEV iSCSI network and reconfigure from scratch.  Hopefully that will resolve the issue, but if not i'll repost next week to see what's up.  Thanks for the response

0 Kudos