F1_Champ
1 Copper

QOS with Powerconnect 5448 for VOIP and video conferencing

Hi,

we have a 5448 configured for VOIP on Voice VLAN 201 and COS set to 6. however, we also enabled the QOS to COS mode and trust mode to DSCP. On the phones themselves (Nortel 1120E), we set the Ctrl Priority Bit to Auto.

Now do we need to set the setting on the phones to 6 according to the vlice vlan setting? or the default setting on the COS to Queue setting which I believe is 5?

How can we check if the QOS is working accordingly?

thanks in advance

0 Kudos
6 Replies
bh1633
3 Cadmium

Re: QOS with Powerconnect 5448 for VOIP and video conferencing

Please post your config file and some more description of your setup.

You can check QOS with specialized networking equipment such as IXIA.  Or you can use Wireshark to see if the COS or QOS value is set to what you expected.

0 Kudos
Highlighted
F1_Champ
1 Copper

Re: QOS with Powerconnect 5448 for VOIP and video conferencing

We have 2 office linked by a fibre connection.

There are 3 vlans, 192.168.1.0/24 - data, 101.0/24 - video, 201.0/24 - VOIP.

At office2, all ip phones, video systems and pc are connected to 2 Nortel BES1020-48T

At office1, the dell 5448 has 2 ports configured for trunking, a few ports dedicated to VOIP and others for data vlan.

All IP phones are Nortel 1120E, Ctrl Priority Bit on the phones is set at AUTO.

I want to know if we need to set the priority bit on the phones to a specific value, same goes to video system I suppose. Also want to make sure the QOS setting in the Dell 5448 is correct. On the Nortel BES1020-48T switches however, I'm not sure if the configuration for QOS is correct neither because it's lacking documentation and the interface is very confusing. It would be great if you can help. Below is the config on the Dell 5448.

 

interface port-channel 1

spanning-tree disable

spanning-tree cost 4

exit

interface port-channel 2

spanning-tree disable

spanning-tree cost 4

exit

interface port-channel 3

spanning-tree disable

spanning-tree cost 4

exit

interface port-channel 4

spanning-tree disable

spanning-tree cost 4

exit

interface port-channel 5

spanning-tree disable

spanning-tree cost 4

exit

interface port-channel 6

spanning-tree disable

spanning-tree cost 4

exit

interface port-channel 7

spanning-tree disable

spanning-tree cost 4

exit

interface port-channel 8

spanning-tree disable

spanning-tree cost 4

exit

interface range ethernet g(38,40,42)

spanning-tree disable

exit

interface range ethernet g(38,40,42)

spanning-tree cost 4

exit

interface port-channel 1

description SYS1

flowcontrol auto

exit

interface port-channel 2

description SYS2

flowcontrol auto

exit

interface port-channel 3

description EX1

flowcontrol auto

exit

interface port-channel 4

description SP2

flowcontrol auto

exit

interface port-channel 5

flowcontrol auto

exit

interface port-channel 6

flowcontrol auto

exit

interface port-channel 7

flowcontrol auto

exit

interface port-channel 8

flowcontrol auto

exit

interface range ethernet g(1-2)

switchport mode trunk

exit

interface range ethernet g(26,28,30,32,36)

switchport mode general

exit

vlan database

vlan 101,201

exit

interface range ethernet g(1-2)

switchport trunk allowed vlan add 101

exit

interface range ethernet g(24,34)

switchport access vlan 201

exit

interface range ethernet g(1-2)

switchport trunk allowed vlan add 201

exit

interface vlan 101

name video

exit

interface vlan 201

name voice

exit

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

voice vlan id 201

interface ethernet g26

voice vlan enable

exit

interface ethernet g28

voice vlan enable

exit

interface ethernet g30

voice vlan enable

exit

interface ethernet g32

voice vlan enable

exit

interface ethernet g36

voice vlan enable

exit

interface range ethernet g(4,6)

channel-group 2 mode on

exit

interface range ethernet g(11,13)

channel-group 4 mode on

exit

interface range ethernet g(14,16)

channel-group 3 mode on

exit

interface range ethernet g(15,17)

channel-group 1 mode on

exit

iscsi target port 860 address 0.0.0.0

iscsi target port 3260 address 0.0.0.0

interface vlan 1

ip address 192.168.1.66 255.255.255.0

exit

ip default-gateway 192.168.1.1

qos trust dscp

 

 

0 Kudos
bh1633
3 Cadmium

Re: QOS with Powerconnect 5448 for VOIP and video conferencing

I cannot find much documentation on this phone, can you post  a pointer to a manual or an excerpt from the manual that explains the "Ctrl Priority bit"?

From what I could find out about these phones,  they set the DSCP by default, so setting the 5448 to trust DSCP is correct. 

0 Kudos
F1_Champ
1 Copper

Re: QOS with Powerconnect 5448 for VOIP and video conferencing

I'm trying to find out the manual that explains about it as well. I will post it once I find more details.

So the configuration on the 5448 seems ok right? It works with either DSCP or COS?

Thanks

0 Kudos
bh1633
3 Cadmium

Re: QOS with Powerconnect 5448 for VOIP and video conferencing

When you set "qos trust DSCP" you are saying that the switch should classify ingress (received) traffic based on DSCP.  This defines the priority of packets when they egress (are transmitted from) the switch.

So, given that the phone appears to set the DSCP value, the phone expects that the switches in your network honor this DSCP value and that the 5448 is set to honor the DSCP value, then I believe the switch is configured correctly.

The other choice, "qos trust vpt", would set the switch to classify base on VPT (VLAN priority tag).  VPT is also called COS (class of service).   I would pick one or the other and not have both priority schemes in your network.

0 Kudos
F1_Champ
1 Copper

Re: QOS with Powerconnect 5448 for VOIP and video conferencing

thank you for your suggestion. I really appreciate it:emotion-2:

0 Kudos