rtumaykin
Not applicable

VLAN across 2 5448 switches

Hi all,

I have 2 5448 switches, each one has VLAN with the same tag - 100. Each VLAN spans across ports 1-16, ports 1 and 2 are also trunk ports. Port 1 on switch A is an uplink to my firewall. port 2 on both switches is used to bridge 2 switches with the ethernet cable. 

I can access all servers plugged into the VLAN ports on swtich A but not on switch B. Is there anything I am missing in my configuration?

Thank you

Roman

0 Kudos
6 Replies
8 Krypton

Re: VLAN across 2 5448 switches

post both configuration files please.

0 Kudos
rtumaykin
Not applicable

Re: VLAN across 2 5448 switches

Hi, here are both configs - they are the same except for the management IPs:

Switch A:

interface range ethernet g(1-2)
switchport mode trunk
exit
vlan database
vlan 102
exit
interface range ethernet g(3-16)
switchport access vlan 102
exit
interface range ethernet g(1-2)
switchport trunk allowed vlan add 102
exit
interface vlan 102
name DMZ
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0
iscsi target port 3260 address 0.0.0.0
interface vlan 1
ip address 192.168.100.228 255.255.255.0
exit
ip default-gateway 192.168.100.1
username admin password *** level 15 encrypted
snmp-server community Dell_Network_Manager rw view DefaultSuper 

Switch B:

interface range ethernet g(1-2)
switchport mode trunk
exit
vlan database
vlan 102
exit
interface range ethernet g(3-16)
switchport access vlan 102
exit
interface range ethernet g(1-2)
switchport trunk allowed vlan add 102
exit
interface vlan 102
name DMZ
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0
iscsi target port 3260 address 0.0.0.0
interface vlan 1
ip address 192.168.100.227 255.255.255.0
exit
ip default-gateway 192.168.100.1
username admin password *** level 15 encrypted
snmp-server community Dell_Network_Manager rw view DefaultSuper
 

Thank you very much!

Roman

0 Kudos
8 Krypton

Re: VLAN across 2 5448 switches

Please post the output of "show spanning-tree" and "show interface status" from each switch.

0 Kudos
rtumaykin
Not applicable

Re: VLAN across 2 5448 switches

Hi,

Did I need to define the spanning tree for vlan 102? 

Here is an output for switch A.

console# show spanning-tree


Spanning tree enabled mode STP
Default port cost method:  short

 

  Root ID    Priority    32768
             Address     00:21:9b:a7:e3:84
             Cost        4
             Port        g17
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    32768
             Address     00:25:64:33:94:97
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Number of topology changes 1 last change occurred 82:35:55 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15

Interfaces
 Name   State   Prio.Nbr   Cost     Sts   Role PortFast       Type
------ -------- -------- --------- ------ ---- -------- -----------------
  g1   enabled   128.1       4      Frw   Desg    No        P2P (STP)
  g2   enabled   128.2       4      Dscr  Altn    No        P2P (STP)
  g3   enabled   128.3       4      Dscr  Altn    No        P2P (STP)
  g4   enabled   128.4      100     Dsbl  Dsbl    No            -
  g5   enabled   128.5      100     Dsbl  Dsbl    No            -
  g6   enabled   128.6      100     Dsbl  Dsbl    No            -
  g7   enabled   128.7       4      Frw   Desg    No        P2P (STP)
  g8   enabled   128.8      100     Dsbl  Dsbl    No            -
  g9   enabled   128.9       4      Frw   Desg    No        P2P (STP)
 g10   enabled   128.10      4      Frw   Desg    No        P2P (STP)
 g11   enabled   128.11      4      Frw   Desg    No        P2P (STP)
 g12   enabled   128.12      4      Frw   Desg    No        P2P (STP)
 g13   enabled   128.13      4      Frw   Desg    No        P2P (STP)
 g14   enabled   128.14      4      Frw   Desg    No        P2P (STP)
 g15   enabled   128.15     100     Dsbl  Dsbl    No            -
 g16   enabled   128.16     100     Dsbl  Dsbl    No            -
 g17   enabled   128.17      4      Frw   Root    No        P2P (STP)
 g18   enabled   128.18      4      Frw   Desg    No        P2P (STP)
 g19   enabled   128.19      4      Frw   Desg    No        P2P (STP)
 g20   enabled   128.20     19      Frw   Desg    No        P2P (STP)
 g21   enabled   128.21      4      Frw   Desg    No        P2P (STP)
 g22   enabled   128.22     100     Dsbl  Dsbl    No            -
 g23   enabled   128.23     100     Dsbl  Dsbl    No            -
 g24   enabled   128.24     100     Dsbl  Dsbl    No            -
 g25   enabled   128.25     19      Frw   Desg    No        P2P (STP)
 g26   enabled   128.26     100     Dsbl  Dsbl    No            -
 g27   enabled   128.27      4      Frw   Desg    No        P2P (STP)
 g28   enabled   128.28      4      Frw   Desg    No        P2P (STP)
 g29   enabled   128.29      4      Frw   Desg    No        P2P (STP)
 g30   enabled   128.30      4      Frw   Desg    No        P2P (STP)
 g31   enabled   128.31      4      Frw   Desg    No        P2P (STP)
 g32   enabled   128.32      4      Frw   Desg    No        P2P (STP)
 g33   enabled   128.33      4      Frw   Desg    No        P2P (STP)
 g34   enabled   128.34      4      Frw   Desg    No        P2P (STP)
 g35   enabled   128.35      4      Frw   Desg    No        P2P (STP)
 g36   enabled   128.36      4      Frw   Desg    No        P2P (STP)
 g37   enabled   128.37      4      Frw   Desg    No        P2P (STP)
 g38   enabled   128.38      4      Frw   Desg    No        P2P (STP)
 g39   enabled   128.39      4      Frw   Desg    No        P2P (STP)
 g40   enabled   128.40      4      Frw   Desg    No        P2P (STP)
 g41   enabled   128.41     100     Dsbl  Dsbl    No            -
 g42   enabled   128.42     100     Dsbl  Dsbl    No            -
 g43   enabled   128.43     100     Dsbl  Dsbl    No            -
 g44   enabled   128.44     100     Dsbl  Dsbl    No            -
 g45   enabled   128.45      4      Dscr  Altn    No        P2P (STP)
 g46   enabled   128.46      4      Frw   Desg    No        P2P (STP)
 g47   enabled   128.47      4      Frw   Desg    No        P2P (STP)
 g48   enabled   128.48      4      Frw   Desg    No        P2P (STP)
 ch1   enabled   128.49      4      Dsbl  Dsbl    No            -
 ch2   enabled   128.50      4      Dsbl  Dsbl    No            -
 ch3   enabled   128.51      4      Dsbl  Dsbl    No            -
 ch4   enabled   128.52      4      Dsbl  Dsbl    No            -
 ch5   enabled   128.53      4      Dsbl  Dsbl    No            -
 ch6   enabled   128.54      4      Dsbl  Dsbl    No            -
 ch7   enabled   128.55      4      Dsbl  Dsbl    No            -
 ch8   enabled   128.56      4      Dsbl  Dsbl    No            -


console# show interface status
                                             Flow Link          Back   Mdix
Port     Type         Duplex  Speed Neg      ctrl State       Pressure Mode
-------- ------------ ------  ----- -------- ---- ----------- -------- -------
g1       1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g2       1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g3       1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g4       1G-Copper      --      --     --     --  Down           --     --
g5       1G-Copper      --      --     --     --  Down           --     --
g6       1G-Copper      --      --     --     --  Down           --     --
g7       1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g8       1G-Copper      --      --     --     --  Down           --     --
g9       1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g10      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g11      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g12      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g13      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g14      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g15      1G-Copper      --      --     --     --  Down           --     --
g16      1G-Copper      --      --     --     --  Down           --     --
g17      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g18      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g19      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g20      1G-Copper    Full    100   Enabled  Off  Up          Disabled On
g21      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g22      1G-Copper      --      --     --     --  Down           --     --
g23      1G-Copper      --      --     --     --  Down           --     --
g24      1G-Copper      --      --     --     --  Down           --     --
g25      1G-Copper    Full    100   Enabled  Off  Up          Disabled On
g26      1G-Copper      --      --     --     --  Down           --     --
g27      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g28      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g29      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g30      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g31      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g32      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g33      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g34      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g35      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g36      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g37      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g38      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g39      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g40      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g41      1G-Copper      --      --     --     --  Down           --     --
g42      1G-Copper      --      --     --     --  Down           --     --
g43      1G-Copper      --      --     --     --  Down           --     --
g44      1G-Copper      --      --     --     --  Down           --     --
g45      1G-Combo-C   Full    1000  Enabled  Off  Up          Disabled On
g46      1G-Combo-C   Full    1000  Enabled  Off  Up          Disabled On
g47      1G-Combo-C   Full    1000  Enabled  Off  Up          Disabled On
g48      1G-Combo-C   Full    1000  Enabled  Off  Up          Disabled On

                                          Flow    Link
Ch       Type    Duplex  Speed  Neg      control  State
-------- ------- ------  -----  -------- -------  -----------
ch1         --     --      --      --       --    Not Present
ch2         --     --      --      --       --    Not Present
ch3         --     --      --      --       --    Not Present
ch4         --     --      --      --       --    Not Present
ch5         --     --      --      --       --    Not Present
ch6         --     --      --      --       --    Not Present
ch7         --     --      --      --       --    Not Present
ch8         --     --      --      --       --    Not Present
console#

And for switch B:

console# show spanning-tree


Spanning tree enabled mode STP
Default port cost method:  short

 

  Root ID    Priority    32768
             Address     00:21:9b:a7:e3:84
             Cost        4
             Port        g17
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    32768
             Address     00:25:64:33:7f:0f
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Number of topology changes 2 last change occurred 82:41:26 ago
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15

Interfaces
 Name   State   Prio.Nbr   Cost     Sts   Role PortFast       Type
------ -------- -------- --------- ------ ---- -------- -----------------
  g1   enabled   128.1       4      Frw   Desg    No        P2P (STP)
  g2   enabled   128.2       4      Frw   Desg    No        P2P (STP)
  g3   enabled   128.3       4      Frw   Desg    No        P2P (STP)
  g4   enabled   128.4      100     Dsbl  Dsbl    No            -
  g5   enabled   128.5      19      Frw   Desg    No        P2P (STP)
  g6   enabled   128.6      100     Dsbl  Dsbl    No            -
  g7   enabled   128.7       4      Frw   Desg    No        P2P (STP)
  g8   enabled   128.8      100     Dsbl  Dsbl    No            -
  g9   enabled   128.9       4      Frw   Desg    No        P2P (STP)
 g10   enabled   128.10      4      Frw   Desg    No        P2P (STP)
 g11   enabled   128.11      4      Frw   Desg    No        P2P (STP)
 g12   enabled   128.12      4      Frw   Desg    No        P2P (STP)
 g13   enabled   128.13      4      Frw   Desg    No        P2P (STP)
 g14   enabled   128.14      4      Frw   Desg    No        P2P (STP)
 g15   enabled   128.15     100     Dsbl  Dsbl    No            -
 g16   enabled   128.16     100     Dsbl  Dsbl    No            -
 g17   enabled   128.17      4      Frw   Root    No        P2P (STP)
 g18   enabled   128.18      4      Frw   Desg    No        P2P (STP)
 g19   enabled   128.19     100     Dsbl  Dsbl    No            -
 g20   enabled   128.20     19      Frw   Desg    No        P2P (STP)
 g21   enabled   128.21     100     Dsbl  Dsbl    No            -
 g22   enabled   128.22     100     Dsbl  Dsbl    No            -
 g23   enabled   128.23     100     Dsbl  Dsbl    No            -
 g24   enabled   128.24     100     Dsbl  Dsbl    No            -
 g25   enabled   128.25     19      Frw   Desg    No        P2P (STP)
 g26   enabled   128.26     100     Dsbl  Dsbl    No            -
 g27   enabled   128.27      4      Frw   Desg    No        P2P (STP)
 g28   enabled   128.28      4      Frw   Desg    No        P2P (STP)
 g29   enabled   128.29      4      Frw   Desg    No        P2P (STP)
 g30   enabled   128.30      4      Frw   Desg    No        P2P (STP)
 g31   enabled   128.31      4      Frw   Desg    No        P2P (STP)
 g32   enabled   128.32      4      Frw   Desg    No        P2P (STP)
 g33   enabled   128.33      4      Frw   Desg    No        P2P (STP)
 g34   enabled   128.34      4      Frw   Desg    No        P2P (STP)
 g35   enabled   128.35      4      Frw   Desg    No        P2P (STP)
 g36   enabled   128.36      4      Frw   Desg    No        P2P (STP)
 g37   enabled   128.37      4      Frw   Desg    No        P2P (STP)
 g38   enabled   128.38      4      Frw   Desg    No        P2P (STP)
 g39   enabled   128.39      4      Frw   Desg    No        P2P (STP)
 g40   enabled   128.40      4      Frw   Desg    No        P2P (STP)
 g41   enabled   128.41     100     Dsbl  Dsbl    No            -
 g42   enabled   128.42     100     Dsbl  Dsbl    No            -
 g43   enabled   128.43     100     Dsbl  Dsbl    No            -
 g44   enabled   128.44     100     Dsbl  Dsbl    No            -
 g45   enabled   128.45      4      Frw   Desg    No        P2P (STP)
 g46   enabled   128.46      4      Frw   Desg    No        P2P (STP)
 g47   enabled   128.47      4      Frw   Desg    No        P2P (STP)
 g48   enabled   128.48      4      Frw   Desg    No        P2P (STP)
 ch1   enabled   128.49      4      Dsbl  Dsbl    No            -
 ch2   enabled   128.50      4      Dsbl  Dsbl    No            -
 ch3   enabled   128.51      4      Dsbl  Dsbl    No            -
 ch4   enabled   128.52      4      Dsbl  Dsbl    No            -
 ch5   enabled   128.53      4      Dsbl  Dsbl    No            -
 ch6   enabled   128.54      4      Dsbl  Dsbl    No            -
 ch7   enabled   128.55      4      Dsbl  Dsbl    No            -
 ch8   enabled   128.56      4      Dsbl  Dsbl    No            -


console# show interface status
                                             Flow Link          Back   Mdix
Port     Type         Duplex  Speed Neg      ctrl State       Pressure Mode
-------- ------------ ------  ----- -------- ---- ----------- -------- -------
g1       1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g2       1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g3       1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g4       1G-Copper      --      --     --     --  Down           --     --
g5       1G-Copper    Full    100   Enabled  Off  Up          Disabled Off
g6       1G-Copper      --      --     --     --  Down           --     --
g7       1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g8       1G-Copper      --      --     --     --  Down           --     --
g9       1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g10      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g11      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g12      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g13      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g14      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g15      1G-Copper      --      --     --     --  Down           --     --
g16      1G-Copper      --      --     --     --  Down           --     --
g17      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g18      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g19      1G-Copper      --      --     --     --  Down           --     --
g20      1G-Copper    Full    100   Enabled  Off  Up          Disabled Off
g21      1G-Copper      --      --     --     --  Down           --     --
g22      1G-Copper      --      --     --     --  Down           --     --
g23      1G-Copper      --      --     --     --  Down           --     --
g24      1G-Copper      --      --     --     --  Down           --     --
g25      1G-Copper    Full    100   Enabled  Off  Up          Disabled On
g26      1G-Copper      --      --     --     --  Down           --     --
g27      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g28      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g29      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g30      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g31      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g32      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g33      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g34      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g35      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g36      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g37      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g38      1G-Copper    Full    1000  Enabled  Off  Up          Disabled On
g39      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g40      1G-Copper    Full    1000  Enabled  Off  Up          Disabled Off
g41      1G-Copper      --      --     --     --  Down           --     --
g42      1G-Copper      --      --     --     --  Down           --     --
g43      1G-Copper      --      --     --     --  Down           --     --
g44      1G-Copper      --      --     --     --  Down           --     --
g45      1G-Combo-C   Full    1000  Enabled  Off  Up          Disabled Off
g46      1G-Combo-C   Full    1000  Enabled  Off  Up          Disabled Off
g47      1G-Combo-C   Full    1000  Enabled  Off  Up          Disabled On
g48      1G-Combo-C   Full    1000  Enabled  Off  Up          Disabled On

                                          Flow    Link
Ch       Type    Duplex  Speed  Neg      control  State
-------- ------- ------  -----  -------- -------  -----------
ch1         --     --      --      --       --    Not Present
ch2         --     --      --      --       --    Not Present
ch3         --     --      --      --       --    Not Present
ch4         --     --      --      --       --    Not Present
ch5         --     --      --      --       --    Not Present
ch6         --     --      --      --       --    Not Present
ch7         --     --      --      --       --    Not Present
ch8         --     --      --      --       --    Not Present
console#

Thank you!

Roman

0 Kudos
8 Krypton

Re: VLAN across 2 5448 switches

You have a loop.  Port 2 on switch A is descarding, so there is no logical connectivity to switch B.

By default, the switch runs a single spanning tree.  This means it detects physical loops even if a logical loop does not exist (i.e. there is no loop because of vlan segmentation of your network).

To resolve your issue, first understand your network to see if you meant to have physical loops.  Resolve the issue by removing loops or adjust spanning tree priorities to get the topology you need.

0 Kudos
rtumaykin
Not applicable

Re: VLAN across 2 5448 switches

Hi,

Thank you very much for pointing me to a right direction! I will read more on the STP and make all necessary changes

Roman

0 Kudos