can not create Channel-Group between two switches PC5524

Hi there!
i've two switches Dell PC5524, and i want to create portchannel between them.

The configuration of two switches are as below:

SW01:

!
interface vlan 5
name USERS
!
interface vlan 6
name SERVERS
ip address 192.168.6.1 255.255.255.0
!
interface gigabitethernet1/0/1
channel-group 1 mode on
switchport mode trunk
switchport access vlan 6
!
interface gigabitethernet1/0/2
channel-group 1 mode on
switchport mode trunk
switchport access vlan 6

SW02:

!
interface vlan 5
name USERS
!
interface vlan 6
name SERVERS
ip address 192.168.6.2 255.255.255.0
!
interface gigabitethernet1/0/1
channel-group 1 mode on
switchport mode trunk
switchport access vlan 6
!
interface gigabitethernet1/0/2
channel-group 1 mode on
switchport mode trunk
switchport access vlan 6

Before, the ports gi1/01 and gi1/02...were part of vlan 6.
now, i tried to remove that configuration:
switchport access vlan 6

BUT I CAN NOT DELETE IT.

i tried again, when i put the configuration

channel-group 1 mode auto.

If i use only one port, with no portchannel configuration, and make it run in trunk mode, the two switches communicate normally with each other.

Now, what is my problem? and how can i fix it?
Regards!

0 Kudos
9 Replies
Moderator
Moderator

RE: can not create Channel-Group between two switches PC5524

Once individual ports have been added to a channel group, they ignore the individual port settings and follow the port-channel settings. So to set channel group 1 to access mode for VLAN 6, you would run the following commands.

# interface  port-channel 1

# switchport mode access

# switchport access vlan 6

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos

RE: can not create Channel-Group between two switches PC5524

Hi Daniel!

The problem is that i'm not forming port-channel between two switches.

I don't want those ports to be part of any VLAN...but i can not remove that settings.

So, my two switches, fail to form portchannel with each other.

0 Kudos
Moderator
Moderator

RE: can not create Channel-Group between two switches PC5524

So you want one port from one switch to connect to one port on the other switch? I am not real clear on what you want to accomplish here.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos

RE: can not create Channel-Group between two switches PC5524

I've said it by words:

i want to configure portchannel between two switches PC5524.

THe portchannel must be configured on two ports gi1/01 and gi1/02 (for redundancy and loadbalancing).

The problem is that with configuration i've listed on my frist post, this portchannel is not running.

See the image below.

0 Kudos
Moderator
Moderator

RE: can not create Channel-Group between two switches PC5524

That is what I thought you were trying to do but then you said "i'm not forming port-channel between two switches." At that point I was unsure.

Once a port is placed in a channel-group it ignores all other config settings applied to that specific port.  So in your config:

interface gigabitethernet1/0/1

# channel-group 1 mode on

# switchport mode trunk (this part is ignored because the port is in a channel-group)

# switchport access vlan 6 (this part is ignored because the port is in a channel-group)

If to clean up the config you want to remove those settings from the port, you first need to remove it from the channel-group. Then remove the setting you want.

# interface gigabitethernet1/0/1

# no channel-group 1 mode on

# no switchport mode trunk

# no switchport access vlan 6

# channel-group 1 mode on

# exit

To place a port into a channel-group and then configure the channel group the config would look similar to this.

# interface gigabitethernet1/0/1

# channel-group 1 mode on

# exit

# interface gigabitethernet1/0/2

# channel-group 1 mode on

# exit

# interface  port-channel 1

# switchport mode access

# switchport access vlan 6

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos

RE: can not create Channel-Group between two switches PC5524

why you suggest this on last:

# interface  port-channel 1

# switchport mode access

# switchport access vlan 6

i thought we have to put the command:

# switchport mode trunk

not access.

also...what about the command

# channel-group 1 mode on

it must be like that or like this:

# channel-group 1 mode auto?

0 Kudos
Moderator
Moderator

RE: can not create Channel-Group between two switches PC5524

You can use Access, General, or Trunk mode. What i gave was just an example. The point to take away is that the config needs to be given to the port-channel, not the individual interface.

On = static

Auto = LACP

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos

RE: can not create Channel-Group between two switches PC5524

which is recommended...ON or Auto???

0 Kudos
Moderator
Moderator

RE: can not create Channel-Group between two switches PC5524

Auto, LACP is what i would recommend.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos