Networking General

Last reply by 04-05-2021 Solved
Start a Discussion
2 Bronze
2 Bronze
1466

m1000e no traffic between A2 and blades with esxi

Enivornment: m1000e with m6220 switches in the A1/A2. Blades are M630

our ESXI hosts are teamed between A1 and A2. A1 and A2 are not stacked. The interfaces for vmnic0(a1) and vmnic1(a2) on the m6220 are configured the same.

Right now, all the blades function when only assigned to vmnic0(a1), however traffic stops when we add in vmnic1(a2) as a redundant link. if we just use vmnic1 and remove vmnic0, they also do not send traffic.

Running show interface counters gi1/0/9, i'm seeing minimal traffic, with all traffic being discarded on transmit.

 

Port InTotalPkts InUcastPkts InMcastPkts InBcastPkts
--------- ---------------- ---------------- ---------------- ----------------
Gi1/0/9 2685 434 58 2193

Port OutTotalPkts OutUcastPkts OutMcastPkts OutBcastPkts
--------- ---------------- ---------------- ---------------- ----------------
Gi1/0/9 158902 2380 48510 108012

FCS Errors: ................................... 0
Single Collision Frames: ...................... 0
Late Collisions: .............................. 0
Excessive Collisions: ......................... 0
Multiple Collisions: .......................... 0
Received Oversize Packets: .................... 0
Transmitted Oversize Packets: ................. 0
Internal MAC Rx Errors: ....................... 0
Received Pause Frames: ........................ 0
Transmitted Pause Frames: ..................... 0
Receive Packets Discarded: .................... 0
Transmit Packets Discarded: ................... 559886

I'm having trouble identifying if there is a configuration issue on the ESXI host, or the m1000e, or if there is a hardware failure.

Everything was working fine until some weeks ago. The server admin noted that no changes were made on his end in ESXI or in the dell CMC, and no configuration changes were made on the switches.

The A2 switch shows as connected, and no errors in the Dell CMC for it. CDP is successful over the link between the A2 and the blades.

I'm trying to find out why the transmits are all being discarded. Any help is appreciated

Labels (2)
Replies (24)
573

It was updated in one of our troubleshooting steps. We still have the old version saved under the 2nd image.

 

I don't have evidence for it, as I'm not very familiar with the m1000e, however I'm suspecting an issue on the Chassis A2 slot. The VM we have attached to it currently is able to get a DHCP address, but no ICMP or other traffic is passing. First I need to rule out any possible network issues.

558

Do you have any blades that are not running ESX or can have downtime? so we can rule out the vswitch as the issue.


Thanks,

DELL-Josh Cr
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#IWork4Dell

Did I answer your query? Please click on ‘Accept as Solution’. ‘Kudo’ the posts you like!

545

I'm running my tests on blade 9, it is running a separate instance of esxi from the rest of my blades so I have a workable test environment, It can be taken offline as needed 

540

Hi,

 

Do you have any additional slot in the chassis that you can swap the M630 into? Alternative, could you run show spanning-tree detail on A1 to compare the configuration with A2 switch port. 


DELL-Joey C
Social Media and Communities Professional
Dell Technologies | Enterprise Support Services
#IWork4Dell

Did I answer your query? Please click on ‘Accept as Solution’. ‘Kudo’ the posts you like!

538

Hi Joey,

 

The issue can be replicated on every slot in the chassis, they are all using m630s.

We're just using blade 9 for testing, so we can continue running production services on the remaining blades, without the redundant a2 connection. 

Here is the detail for the A1

Spanning tree Enabled (BPDU flooding : Disabled) Portfast BPDU filtering Disabled mode rstp
CST Regional Root: 80:00:5C:26:0A:C6:B3:5F
Regional Root Path Cost: 0
ROOT ID
Address 80:00:00:1F:9A:3E:A0:00
Path Cost 2004
Root Port Po1
Hello Time 2 Sec Max Age 20 sec Forward Delay 15 sec TxHoldCount 6 sec
Bridge Max Hops 20
Bridge ID
Priority 32768
Address 80:00:5C:26:0A:C6:B3:5F
Hello Time 2 Sec Max Age 20 sec Forward Delay 15 sec

Number of topology changes 1 last change occurred 188d0h28m40s ago
Times: hold 6, hello 2, max age 20, forward delay 15

Port Gi1/0/9 Enabled
State: Forwarding Role: Designated
Port id: 128.9 Port Cost: 20000
Root Protection: No
Designated bridge Priority: 32768 Address: 5C26.0AC6.B35F
Designated port id: 128.9 Designated path cost: 2004
CST Regional Root: 80:00:5C:26:0A:C6:B3:5F CST Port Cost: 0
BPDU: sent 8122435, received 0

 

533

Hi,

 

I didn't real difference between these logs except the point :

For A2 :  This Switch is the Root.
For A1 : Root Port Po1 / Designated path cost: 2004 (0 for A2)

 

At this step, as Josh mention, this problem seems to be more related to a Vswitch configuration issue than a pure hardware issue. Have you tried to reboot the switch and/or swap the blade?

 

Regards,


Stéphane Thiallier
Business Intelligence Advisor

To reach support please post a public message into
English Enterprise Community or French Enterprise Community
531

Hey Stephane,

 

For the physical switch, we've rebooted, and also swapped it with a spare.

For the blades, we've tried different blades, some running different instances of esxi, and therefor different vswitches. all the same issue still.

522

Is the port group teaming policy set to "Route based on originating virtual port"?  This is probably what you want.  Since the two switches are not in stack, make sure it's not set to MAC hash or IP hash. 

On the affected switch, does "show mac address-table" show anything?

Also, what is the connectivity like between this switch and the other one?  What does this switch uplink to, etc? 

513

The Teaming policy is set to "Route Based on Originating port ID" for both the port group and the vswitch.

 

Here's the mac address-table, surprisingly small. Only shows it's own interface for vlan1.

 

BldChs1A2#show mac address-table

Aging time is 300 Sec

Vlan Mac Address Type Port
-------- --------------------- ----------- ---------------------
1 0025.6413.AB70 Management Vl1

 

 

the A2 uplinks to a Cisco C9500. originally it was port channeled, but we removed it during the trouble shooting process, so it is just a single link running at 10g. config is simple for both sides:

A2:

interface Te1/1/1
duplex full
channel-group 1 mode active
spanning-tree disable
switchport mode trunk
switchport trunk allowed vlan 1,1101
exit

 

Cisco


interface TenGigabitEthernet1/0/30
description Rack 8 DellBladeChassis fabric A2
switchport trunk allowed vlan 1,1101
switchport mode trunk
no cdp enable
channel-protocol lacp
channel-group 30 mode active
end

 

I added in the channel-protocol LACP at one point during troubleshooting, it needs to be removed.

 

 

507

I would start by verifying the blade NIC can communicate to the switch.  On your test blade, make sure the only active uplink is the one mapped to switch A2.  Take a VLAN that is on both the ESXi host and the Switch, and work with that:  On the switch, if there isn't one already, put an IP address on that VLAN (I think the 6220 is a L3 switch, I can't remember).  At that point try to ping the VLAN IP (SVI) from the blade.  So just a simple layer-2 check here.  You will be able to see the MAC address in the output of "show mac address-table" if this is working.  Once you get that working, you can move on to troubleshoot upstream connectivity.

Latest Solutions
Top Contributor