Highlighted
xtrusion0
1 Copper

two powerconnect 6248 vlan routing

I'm trying to figure out VLAN/IP routing between 2 powerconnect 6248 switches over a single fiber cross connect.

Switch1 has 3 VLANs(12,13,14) and Switch2 has 3 different VLANs(22,23,24). To eliminate complexity with my question I'm only concerned with routing traffic between VLAN 12 & 22. VLAN 12 has the network 10.0.200.0/24 and VLAN 22 has the network 10.0.201.0/24. Both networks/VLANs(12 & 22) do not have a default gateway because this is a private network where nodes can communicate without having any network hops. 

How would I go about configuring routing between these separate VLANs between these two switches? Originally I was going to set an IP address on VLAN 12(10.0.200.1) & 22(10.0.201.1) then setup IP routes, but since I don't have a default gateway on either network would I need to assign a static IP address on the fiber interface port for both switches? Let me know if you need clarification. Any help would be appreciated.

Thanks,
Brent 

0 Kudos
5 Replies

Re: two powerconnect 6248 vlan routing

Once you enable routing for the each switch globally and on each vlan you will need a separate IP network on the ports connecting the 2 Layer 3 switches.

Console(config)# ip routing

These interfaces could have static ip addresses like you mentioned.  They would need to have some other class C network of subnet with a /30 mask if you are limited to what IP addresses you have available.

Then you can set up routes to the networks.

Sample:

The following example identifies the next-hop-ip

console(config)#ip route 192.168.10.10 255.255.255.0 192.168.20.1

Get Support on Twitter @DellCaresPro

Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

xtrusion0
1 Copper

Re: two powerconnect 6248 vlan routing

Willy, thanks for the reply and sorry for the delay in my response.

I later realized that it won't allow me to assign a static IP address to an ethernet interface on the PC62xx. I'm somewhat of a intermediate-advanced user when it comes to switching/routing, but new to VLAN routing. I have a similar setup for testing VLAN routing in a non production environment and I've attached a basic config from either switch to include changes from what I think you are suggesting. On both switches I have a ethernet cable attached to port 24(to simulate a fiber cross connect). I may be in the ballpark with my configuration, but it is not working.

switch1:

!Current Configuration:
!System Description "Powerconnect 6248, 3.2.0.7, VxWorks 6.5"
!System Software Version 3.2.0.7
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 12-14,4090
vlan routing 12 1
vlan routing 4090 2
exit
hostname "switch1-6248"
stack
member 1 2
exit
ip address 10.0.100.20 255.255.255.0
logging console info
ip routing
ip route 10.0.200.0 255.255.255.0 10.10.10.11
interface vlan 12
name "noc1-priv"
routing
ip address 10.0.200.1 255.255.255.0
exit
interface vlan 13
name "noc1-pub"
exit
interface vlan 14
name "noc1-maint"
exit
interface vlan 4090
name "xconnect"
routing
ip address 10.10.10.10 255.255.255.0
exit
no spanning-tree
!
interface ethernet 1/g21
switchport access vlan 12
exit
!
interface ethernet 1/g22
switchport access vlan 13
exit
!
interface ethernet 1/g24
switchport mode general
switchport general pvid 4090
switchport general allowed vlan add 12
exit
exit

switch2:

!Current Configuration:
!System Description "Powerconnect 6224F, 3.2.0.7, VxWorks 6.5"
!System Software Version 3.2.0.7
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 22-24,4090
vlan routing 22 1
vlan routing 4090 2
exit
hostname "switch2-6224"
stack
member 1 3
exit
ip address 10.0.100.21 255.255.255.0
logging console info
ip routing
ip route 10.0.201.0 255.255.255.0 10.10.10.10
interface vlan 22
name "noc2-priv"
routing
ip address 10.0.201.1 255.255.255.0
exit
interface vlan 23
name "noc2-pub"
exit
interface vlan 24
name "noc2-maint"
exit
interface vlan 4090
name "xconnect"
routing
ip address 10.10.10.11 255.255.255.0
exit
no spanning-tree
!
interface ethernet 1/g21
switchport access vlan 22
exit
!
interface ethernet 1/g22
switchport access vlan 23
exit
!
interface ethernet 1/g24
switchport mode general
switchport general pvid 4090
switchport general allowed vlan add 22
exit
exit

0 Kudos

Re: two powerconnect 6248 vlan routing

I think I over complicated things for us.  So let’s back up just a little.

What we need to do is enable routing on just one switch.  You can decide it really does not matter unless you have a certain reason to have one or the other that needs to be the router in your environment.

Then on interface 1/g24 on both switches we need to set up a trunk to allow the vlan traffic to cross over instead of the general.

console(config)# interface ethernet 1/g24

console(config-if)# switchport mode trunk

console(config-if)# switchport trunk allowed vlan add XX, XX (all vlans that are communicating switch to switch)

console(config-if)# end

Then no ip route should be needed. You will keep all the vlans the same on both switches and all the client devices that are connected to a vlan would have the default gateway of the vlan interface IP

Get Support on Twitter @DellCaresPro

Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

0 Kudos
xtrusion0
1 Copper

Re: two powerconnect 6248 vlan routing

Just so I'm following you correctly...

switch1(routing enabled) --

interface vlan 12

name "noc1-priv"                    

routing

ip address 10.0.200.1 255.255.255.0

exit

interface vlan 22

name "noc2-priv"                    

routing

ip address 10.0.201.1 255.255.255.0

exit

interface ethernet 1/g24

switchport mode trunk

switchport trunk allowed vlan add 12,22

exit

switch2 --

interface vlan 12

name "noc1-priv"                    

exit

interface vlan 22

name "noc2-priv"                    

exit

interface ethernet 1/g24

switchport mode trunk

switchport trunk allowed vlan add 12,22

exit

This configuration change would allow traffic from switch2 vlan22(10.0.201.0) talk to nodes residing on switch1 vlan12(10.0.200.0) and visa versa?

0 Kudos

Re: two powerconnect 6248 vlan routing

That looks good except you will need to enable routing globally on switch 1, unless that is what you are referring to at the beginning.

console(config)#routing

Then you would set up the individual interfaces for switchport access to a particular vlan.

This way you have one router and a switch.  It can be referred to as "Router on a Stick" all the routed traffic will traverse the trunk up and back down to reach another Vlan or Subnet.  All traffic inside the same vlan will stay on the switch.

Let us know the results of the set up.

Thanks

Get Support on Twitter @DellCaresPro

Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)