Highlighted
ethaniel86
1 Copper

vlan setup 6224/5448

Jump to solution

Hi

I am planning to get colocation service from ISP and i need some advice for below simple diagram as i'm not really good in networking. 

L3 switch = 6224

L2 switch = 5448

Blue vlan = management

Green vlan = KVM host. VM will use this to connect internet

I have created all three vlans but i have a few questions

1. Do i need 3 cables from L3 to L2? One for connecting two switches, other two for vlan10 & 20?

2. If i assign port 1 to vlan10 and port 2 to vlan20, under GUI 'vlan membership' page what do i set for each vlans?

3. How do i assign the /24 IPs to green vlan? 

Appreciate for any help i can get 🙂

Thank you

eth.

0 Kudos
1 Solution

Accepted Solutions
Anonymous
Not applicable

RE: vlan setup 6224/5448

Jump to solution

No need for 3 cables unless you are creating a LAG. To carry multiple VLAN across one connection you will use Trunk/General settings.

 

Example:

console(config)# interface ethernet 1/e7

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 2,3,4,5 tagged

console(config-if)# switchport general pvid 99

 

It depends on what ports 1 and 2 plug into. If they plug into a server and that server is VLAN unaware you would set it to untagged. You can also accomplish this by setting the port to access mode for the VLAN.

Example:

console(config)# interface ethernet 1/e1

console(config-if)# switchport mode access

console(config-if)# switchport access vlan 2

 

But if it plugs into another network device that is VLAN aware, you may consider Tagged especially if there will be multiple VLANs across the connection.

 

On the 6224 you assign an up address to the VLAN with these commands.

Example:

console(config)#interface vlan 5

console(config-vlan)#ip address 192.168.1.1 255.255.255.0

0 Kudos
3 Replies
Anonymous
Not applicable

RE: vlan setup 6224/5448

Jump to solution

No need for 3 cables unless you are creating a LAG. To carry multiple VLAN across one connection you will use Trunk/General settings.

 

Example:

console(config)# interface ethernet 1/e7

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 2,3,4,5 tagged

console(config-if)# switchport general pvid 99

 

It depends on what ports 1 and 2 plug into. If they plug into a server and that server is VLAN unaware you would set it to untagged. You can also accomplish this by setting the port to access mode for the VLAN.

Example:

console(config)# interface ethernet 1/e1

console(config-if)# switchport mode access

console(config-if)# switchport access vlan 2

 

But if it plugs into another network device that is VLAN aware, you may consider Tagged especially if there will be multiple VLANs across the connection.

 

On the 6224 you assign an up address to the VLAN with these commands.

Example:

console(config)#interface vlan 5

console(config-vlan)#ip address 192.168.1.1 255.255.255.0

0 Kudos
ethaniel86
1 Copper

RE: vlan setup 6224/5448

Jump to solution

Do you know why when i set a port to vlan 10 for example the server with public IP assigned not able to reach the internet?

In this case i leave everything default for the L3 switch, set vlan on L2 switch accordingly. All vlan ports are using 'access' mode.

eth.

0 Kudos
Anonymous
Not applicable

RE: vlan setup 6224/5448

Jump to solution

On the layer 3 switch you may need to add a static route directing the traffic out.

The following example identifies the ip-address subnet-mask, next-hop-ip

console(config)#ip route 192.168.10.10 255.255.255.0 192.168.20.1

0 Kudos