MrBobC
1 Nickel

vrrp virtual address not responding to ping

I understand this has been a known issue and am interested in seeing if there has been a fix or work around.

Platform is PC 6224
Version 3.2.0.9

Example:

interface vlan 452
routing
ip address 172.22.52.254 255.255.255.0
ip vrrp 52
ip vrrp 52 mode
ip vrrp 52 ip 172.22.52.1
ip vrrp 52 priority 250
ip vrrp 52 timers advertise 180

T#show ip vrrp interface vlan 452 52

Primary IP Address............................. 172.22.52.1
VMAC Address................................... 0000.5E00.0134
Authentication Type............................ None
Priority....................................... 250
Configured Priority............................ 250
Advertisement Interval (secs).................. 180
Pre-empt Mode.................................. Enable
Administrative Mode............................ Enable
State.......................................... Backup

Both L3 devices are responding to the hard addresses, but not the virtual.

 

Tags (1)
0 Kudos
7 Replies

Re: vrrp virtual address not responding to ping

Looks like you may need the accept mode added.

Use the vrrp accept-mode command to enable the virtual router ip address to accept ping packets

console(config-if-vlan452)# vrrp 52 mode

console(config-if-vlan452)# vrrp 52 accept-mode

console(config-if-vlan452)# vrrp 52 priority 250

console(config-if-vlan452)# vrrp 52 timers advertise 180

console(config-if-vlan452)# exit

console(config)#

Hope this information is helpful.  Let us know if you have further questions.

Get Support on Twitter @DellCaresPro

Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

0 Kudos
MrBobC
1 Nickel

Re: vrrp virtual address not responding to ping

In which release was The accept option incorporated?
Our switch is a generic PCT6224 with version 3.2.0.9.  Also I noticed the commands didn't include ip prior to vrrp.

TajDC_Gaming_202(config-if-vlan452)#ip vrrp 52 ?
<cr>                     Press enter to execute the command.
authentication           Set authentication details.
ip                       Set IP Address associated with this Virtual Router.
mode                     Enable/disable the VRID on the interface.
preempt                  Set preemption mode.
priority                 Set the priority for a virtual router.
timers                   The timer used for VRRP advertisement.
track                    Add/Delete tracking of interface/route.

 

Our Config as implemented


interface vlan 452
routing
ip address 172.22.52.253 255.255.255.0
ip vrrp 52
ip vrrp 52 mode
ip vrrp 52 ip 172.22.52.1
ip vrrp 52 priority 253
ip vrrp 52 timers advertise 180
exit

 

Thanks for your assist

Tags (1)
0 Kudos

Re: vrrp virtual address not responding to ping

You should be able to set the accept-mode from the vlan interface.  If you type vrrp 52 ?   Do you get the option for accept-mode.

We have these options with the latest firmware.

You might take a look at updating the firmware.  Here is a link for the current firmware for the 62xx switches.

www.dell.com/.../DriverFileFormats

Let us know if you have further questions.

Get Support on Twitter @DellCaresPro

Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

0 Kudos
Highlighted
MrBobC
1 Nickel

Re: vrrp virtual address not responding to ping

We have these options with the latest firmware.
You might take a look at updating the firmware.  Here is a link for the current firmware for the 62xx switches.
www.dell.com/.../DriverFileFormats

Following the link to current firmware I upgraded a test system to 3.3.2.3 _ 1

===========================================================================

You should be able to set the accept-mode from the vlan interface.  If you type vrrp 52 ?   Do you get the option for accept-mode.

The cli for the configuration of the vrrp is exactly the same 3.2.0.9
I replicated the settings and the virtual ip address is unable to be pinged.

FYI, I find no option for accept-mode.

I reviewed the release notes

Date: November 2011

System Firmware Version 3.3.2.3

and there are no mentions of accept-mode.

 

0 Kudos

Re: vrrp virtual address not responding to ping

I got access to a 6248 physical switch.  You are correct the option is not in the current firmware.  I also looked at a 7024 switch and that cli has the options for vrrp 52 accept-mode.  The documentation that I was referencing stated that option was on the 62xx.  I'm sorry for any inconvenience this may have caused.  

It does not look like that option is available on the 62xx switch.  I will continue to research and update this post with any new information on the subject.

Get Support on Twitter @DellCaresPro

Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

MrBobC
1 Nickel

Re: vrrp virtual address not responding to ping

Thanks for the investigation, and that is good news / bad news to us.

Good news:  Dell recognizes that being able to ping the virtual address is desired and modified the vrrp config to allow a reachable default gateway.

Bad News: it is not implemented on the PC6200 line.

Any way to reachout out and find when this desireable code enahancement will be implemented on the PC6200 series?

0 Kudos
DaneRuyle
1 Nickel

RE: vrrp virtual address not responding to ping

Fix this.

0 Kudos