Highlighted
belboy3
3 Argentium

Bluetooth 350 not working after Win 7 upgrade

Just upgraded XPS M2010 (clean install new HDD) to win 7 64bit. Now bluetooth (BT) will not hook up mouse. Everything works fine except BT.  Can get keyboard to hook up ,not pinned,  but no BT icon on lower right task bar. Followed the forum post 'Re: 1-TB raid 0 on XOS M2010" for upgrade which says use Microsoft generic BT driver in win 7 OS. I did not ,as directed by the forum, download any Dell drivers for the BT. Device manager does 'not" show any BT radio or devices. 

Would appreciate any help.

Thanks

 

XPS8300, i7-2600, 12GB DDR3 Ram, AMD HD 6770 Video, ST2420L Monitor, WIN 7 64bit Home Premium

 

 

 

 

0 Kudos
6 Replies
slangen
1 Copper

Re: Bluetooth 350 not working after Win 7 upgrade

I have exactly the same problem with the bluetooth but on 32 bit win 7 - also i cannot get the dell premium remote drivers either - so if anyone has the answer (as dell have not proved helpful as yet) i would be grateful.

0 Kudos
belboy3
3 Argentium

Re: Bluetooth 350 not working after Win 7 upgrade

I assume you have a M2010 also. Did you do a clean install or an upgrade? I had not checked my Premium remote but just did and it works. Is your  MediaDirect working? I have found in device manger an unknown driver which I'm told is the ACPI dell 8010 function controller. This is a problem  left to dell and the future to get it to wwork. No drivers, at least for 64bit. I did not download any bluetooth driver from dell but used generic from in 7. I just can't get a BT icon and mouse working. Haven't helped you much but good luck.

XPS8300, i7-2600, 12GB DDR3 Ram, AMD HD 6770 Video, ST2420L Monitor, WIN 7 64bit Home Premium

 

 

 

 

0 Kudos
belboy3
3 Argentium

Re: Bluetooth 350 not working after Win 7 upgrade

I read in another post of this being fixed. The premium remote post is as follows:

: http://www.avsforum.com/avs-vb/showthread.php?p=17534210?s=44c2f2133bf5cb494854ac365e93d3c3

You may have to do some reading but hope it helps.

Good luck

XPS8300, i7-2600, 12GB DDR3 Ram, AMD HD 6770 Video, ST2420L Monitor, WIN 7 64bit Home Premium

 

 

 

 

0 Kudos
Tonasket
1 Copper

Re: Bluetooth 350 not working after Win 7 upgrade

After switching to Windows 7 I noticed that there was no bluetooth Icon or reference anywhere.  I turned on my bluetooth headphones and nothing happened, so I assumed that the bluetooth wasn't working.  But thanks to you post, I tried the bluetooth keyboard and mouse, both of which worked just by turning them on!  So apparently the bluetooth is working on my computer, there just is no control, settings or options, due to the lack of any representation in control panel or anywhere else.  So I guess it is not a driver that I need but something else......not sure how exactly to describe it tho.

Did you happen to find a solution to missing BT icon in either the taskbar, control pannel, or anywhere else for that matter?

0 Kudos
belboy3
3 Argentium

Re: Bluetooth 350 not working after Win 7 upgrade

Hi Tonasket,

 Glad to see you got some help from the post. I am still in the same boat. NO BT in device manager, nor task bar, or control panel. This is a driver problem that at this time, Dell has not or will not fix. I have not found any othr solution at this time.

I can not explain why the keyboard and mouse works which means bt is functioning, we just can't see it nor control it. It's still a driver. Did you go to 7x32 or 7x64? Was it a clean install or upgrade?  Do you have MediaDirect and is your remote working IR?

Good luck 

XPS8300, i7-2600, 12GB DDR3 Ram, AMD HD 6770 Video, ST2420L Monitor, WIN 7 64bit Home Premium

 

 

 

 

0 Kudos
Tonasket
1 Copper

Re: Bluetooth 350 not working after Win 7 upgrade

Hi Belboy3, Thanks for the reply.  I did a clean install of 7x64 Ultimate.  I don't have MediaDirect (not installed anyway. The computer came with a remote control and a tv tuner card, but I have never used that feature, even when it was running vistax64 which it came with), so I don't know about that.  The bh200 BT headset won't connect and function tho, so the keyboard & mouse are the only BT things that I have that function.  If I ever find a solution I will post it here, and you do the same (let's just not hold our breath, lol)

0 Kudos