Highlighted
2 Bronze

Cannot connect to internet, but WiFi Network connection seems OK

Jump to solution

Hi All,

 

I have a 7 month old Dell XPS 17 which has a Intel® Centrino® Advanced-N 6230 (2x2 b/g/n+ Bluetooth Combo Card). I have been using the wireless internet connection via my BT broadband package for months, everything OK, then suddenly the laptop can no longer connect to the internet.

All the diagnostic tools say everything is OK but the broadband modem is having problems. The other laptops on the home WiFi network can all access the internet fine, so the BT broadband IS working, so it must be the DELL Laptop, right?

 

The laptop keeps telling me to reset the modem, which I have done, but to no avail...it is still working with theother laptops, so this can't be the problem.

Am guessing that this is a hardware fault in my Dell laptop?

any suggestion would be greatly appreciated.

0 Kudos
2 Solutions

Accepted Solutions
Highlighted
2 Bronze

Re: Cannot connect to internet, but WiFi Network connection seems OK

Jump to solution

Hi, I tried the antimalware software...no result.

I use 'Webroot Secure Anywhere Essentials', which was auto updated on 25th December2011...hhhmmm was that the time that the internet stopped working...why yes, what a shock!

Basically, long story short, I have got it sorted out, and the internet is working again! Hooray.

In the network properties, on the networking tab, there is a 'Privacyware Filter Driver' which when de-selected, allows the 'internet' to work. A little investigative work on the internet brought up the link between this and Webroot. It appears that Webroot is making things a little too private!

Anyway, all sorted now. I guess Webroot need to be informed of this problem?

Big thanks to The George for coming up with the fix!

Cheers buddy!!!

View solution in original post

Highlighted
2 Bronze

Re: Cannot connect to internet, but WiFi Network connection seems OK

Jump to solution

Here's the response from Webroot about this, and how to permanently remove the offending driver:

View solution in original post

28 Replies
Highlighted
3 Argentum

Re: Cannot connect to internet, but WiFi Network connection seems OK

Jump to solution

rugton,

 

You powered down the isp modem/router and the wirless router for 30 seconds. Then power on the isp modem/router. Wait 15 seconds, then power on the wireless router(if any) Restart the problem computer and try to connect?

 

Did you try disabling the wireless n on the wireless adapter?

 

 

Rick

#DellRockStar

What is a Dell Service Tag and how do I locate it? 

 

 

Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

Welcome to Dell Community!

0 Kudos
Highlighted
2 Bronze

Re: Cannot connect to internet, but WiFi Network connection seems OK

Jump to solution

Many thanks, but no luck.

I tried everything you suggested but the laptop still won't connect to the internet.

It CAN connect to the wireless network fine, and indeed accessed a document on another computer on the wireless network, and also printed to a wireless printer, but it just cannot access the internet. The wifi router seems to be working fine and the other network computers can access the internet, just not the Dell machine.

Is this likely to be a software 'setting' somewhere or is it likely that (...please excuse me getting all technical...) the bit of hardware that accesses the internet is broken?

All the Windows7 network diagnostic tools tells me is that the router needs to be reset, so it isn't really getting the right picture because the router seems fine. Here's what the tool says:

"the connection between your access point, router, or cable modem and the internet is broken. The network gateway is accessible, but Windows couldn't receive network traffic from the internet" it then goes on to give the same advice as Rick, above.

Does anyone else have any further suggestions?

many thanks

Rugton

0 Kudos
Highlighted
2 Bronze

Re: Cannot connect to internet, but WiFi Network connection seems OK

Jump to solution

I am now getting the message that the DNS server is incorrect or doesn't exist. Not sure how to check that the Dell laptop is looking at the correct DNS name, or what it even should be!

0 Kudos
Highlighted
8 Krypton

Re: Cannot connect to internet, but WiFi Network connection seems OK

Jump to solution

rugton,

 

Start, control panel, network and sharing center, click on your network, then properties.

 

Look for TCP/IPv4 and TCP/IPv6 and click on properties for each. Have your settings match mine.

 

 

 

Rick


#DellRockstar

Welcome to Dell Community!

#DellWorld 2012
#DellWorld 2015
#Dell EMC World 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

This is a Dell User Forum. I am a Dell user, just like you are.
0 Kudos
Highlighted
2 Bronze

Re: Cannot connect to internet, but WiFi Network connection seems OK

Jump to solution

all the suggested settings already reflect your settings.

Still no success.

🙂

0 Kudos
Highlighted
8 Krypton

Re: Cannot connect to internet, but WiFi Network connection seems OK

Jump to solution

rugton,

 

Scan for malware? Download Malwarebytes Anti-Malware and do a quick scan. Report back if it finds anything.

 

What virus program are you using?

 

 

Rick


#DellRockstar

Welcome to Dell Community!

#DellWorld 2012
#DellWorld 2015
#Dell EMC World 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

This is a Dell User Forum. I am a Dell user, just like you are.
0 Kudos
Highlighted
2 Bronze

Re: Cannot connect to internet, but WiFi Network connection seems OK

Jump to solution

Hi, I tried the antimalware software...no result.

I use 'Webroot Secure Anywhere Essentials', which was auto updated on 25th December2011...hhhmmm was that the time that the internet stopped working...why yes, what a shock!

Basically, long story short, I have got it sorted out, and the internet is working again! Hooray.

In the network properties, on the networking tab, there is a 'Privacyware Filter Driver' which when de-selected, allows the 'internet' to work. A little investigative work on the internet brought up the link between this and Webroot. It appears that Webroot is making things a little too private!

Anyway, all sorted now. I guess Webroot need to be informed of this problem?

Big thanks to The George for coming up with the fix!

Cheers buddy!!!

View solution in original post

Highlighted
1 Copper

Re: Cannot connect to internet, but WiFi Network connection seems OK

Jump to solution

Hey there can u pleaae show me where to find those settings by using screenshots thank you.

0 Kudos
Highlighted
8 Krypton

Re: Cannot connect to internet, but WiFi Network connection seems OK

Jump to solution

rugton,

 

Interesting. Glad you got ti working! emoticon.Yes.title Thanks for posting back.

 

Take care,

 

 

Rick


#DellRockstar

Welcome to Dell Community!

#DellWorld 2012
#DellWorld 2015
#Dell EMC World 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

This is a Dell User Forum. I am a Dell user, just like you are.
0 Kudos