Highlighted

DELL XPS 12 Ultrabook with Intel AC 7260 Network adaptor does not work

WIFI turns off intermittently for no apparent reason.

So I have now done the all of the following:

 

Didn't make any difference:

-I have tried connecting to different networks

-Several operating reinstalls (from you, me and DELL themselves)

- Used a different USB network adaptor card

-Replacement of brand new wireless adaptor, (same model) 

- Ran a fresh PC with no additional software (no antivirus, VPN any software changes etc)

-Changed power settings to not disable adaptor

-Completely uninstalled network device and reinstalled from Intel website both updating all drivers and running with an out of date previous driver.

 

Seems to be working currently with these changes:

 

-Reset driver to factory oldest version

- Set transmit power network setting to max performance, highest

 

- Set 11n channel Width for 2.4Ghz connections to 20mhz ONLY (Default is Auto)
- Set Preferred Band 2.4Ghz (Default is Auto)
-Set Roaming Aggressiveness 1. Lowest (Default is 3. Medium)
- Set Wireless mode 802.11b/g (Default is 802.11a/b/g)
-Set HT mode to VHT mode
- Login into router settings and disabled P2P settings and Enabled CAM.
- Opened “Wireless Settings” and disabled auto connecting to wireless hotspots.

 

 

Any other ideas to do if this breaks again, I feel like i have tried all!

Reply
1 Reply
Highlighted
1 Copper

Re: DELL XPS 12 Ultrabook with Intel AC 7260 Network adaptor does not work

Started out with issues of Intel Wiifi getting turned off after random amount of time, light would go out on dash. Setting all power-savings settings in Windows AND in driver to never sleep did no good. I upgraded to Proset 19, no change. Upgraded to Proset 20 when it came out and things got WORSE! Now Wifi doesn't work at all due to Code 10 driver can't start error.

Then I remembered something our CIO mentioned, "If it's not broken, don't break it!" So I figured this Wifi card worked when laptop came out, what changed to break it? AHAH!!! I went through update list in reverse order using WMI command to see items that ControlPanels hides from you. There's usual app updates, Windows updates, security updates, and there it was DRIVER UPDATE!!!

So I uninstalled driver update and rebooted. I went back to driver working, but still had issues with Wifi turning off. I figured I'd uninstall Proset software, but that still left current driver in place. I removed that by uninstalling NIC in DeviceManager and choosing to delete device driver as well. Rebooted and it reinstalled NIC with older driver. Which I uninstalled and deleted driver as well, rebooted. Repeated until everything was uninstalled and it was asking for driver disk.

At this point, I tried various drivers from around time laptop was released. What finally worked to:

- start driver without Code 10 error and

- not randomly turn off Wifi was

DRIVER ONLY install using .inf using version 17.0.6.1. Date was from around time I bought laptop and it works 100% all time! Connects at full AC speeds and no disconnects!!! i've since disabled all driver-updates and all Windows updates. Only security-updates are allowed!

Reply