Networking, Internet, & Bluetooth

Last reply by 08-14-2013 Unsolved
Start a Discussion
4 Beryllium
59333

DHCPNACK

Hi guys.

Could not get my comp to fix an IP. I get in Event Viewer:

"The IP address lease xxx.xxx.x.x for the Network Card with network address
XXXXXX has been denied by the DHCP server x.x.x.x. {The DHCP Server
sent a DHCPNACK message}"

This thing has been pestered my local net, 3 PCs hardwire connected by a network switch. No router, for a while now. I changed modem and networkswitch and still, once in awhile, one or all the comps can not get an IP. I have to turn off modem and power up the whole thing again.

Today was the worst. I could not get an IP in my comp. Right now I am using USB connection.

I know it has something to do with 2 comp trying to share the same IP but I thought that was something from the past when HUB switches were used. I also starting to believe it could be my NIC (integrated). If it is something, I have to report to my ISP to get fix, the service here sucks.

Any ideas or tests. My DeLL diagnostic does not test the NIC, just the driver, and it is OK.

Thanks.

Hernan.

Dim9200/XPS 410.C2D 2.40GHz.2GB RAM.XP Pro_86 SPk3. IE8 & FF38

Avast!Free 2015. CIS 5.12(FW/D+). MBAM Premium. MCShield. WinPatrol +. WOT. OpenDNS. SAS(o/d)

"We are all ignorant, but we don't all ignore the same things..." Albert Einstein

"When you've excluded the impossible, whatever remains, however improbable, must be the truth..." Sherlock Holmes.

Replies (8)
9 Palladium
2088

Hernan,

 

Make and model of the computer and opertaing system is helpful. An ipconfig /all log may help.

 

What virus program and firewall are you using?

 

Did you power cycle the routers?

 

Power off your ISP modem/router and your wireless router(if any) for 30 seconds. Then power on the ISP modem/router. Wait 15 seconds, then power on the wireless router(if any)

Restart the computer and try to connect.

What happens?

 

 

Rick

 


#DellRockstar

Welcome to Dell Community!

#DellWorld 2012
#DellWorld 2015
#Dell EMC World 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

This is a Dell User Forum. I am a Dell user, just like you are.
4 Beryllium
2088

Hi Rick.

My set my sig.

Ipconfig / all just give 0.0.0.0.

I have gone through all that. ipconfig /release. ipconfig /renew

The procedure that seems to work better is to power cycle the red. No router though, just modem and network switch. Live in a prebuilt viposa house. Walls are concrete with wire mesh inside so wireless ( wifi ) almost useless.

Any other ideas?

However like I said, not even the power cycle helped me out this time. I was talking to my cousing and he was telling me that he had the same problem and he thought it was the NIC so he bought a new red card and he got conneted again. By accident, a couple of day later, he connected the old NIC and it worked again. So now when he gets this " Limited or no connectivity, he switches the cards and all is good again. I think it is an ISP problem allocating IPs. Hey! I live in a third world country . What else is new ? They just increased the Intenet connection to 6 MB like a bit deal, and it is very expensive.

Let me see if this issue is still happening tomorrow. For now I am connecting through the modem USB. I will report back.

Thanks Rick.

Hernan.

Dim9200/XPS 410.C2D 2.40GHz.2GB RAM.XP Pro_86 SPk3. IE8 & FF38

Avast!Free 2015. CIS 5.12(FW/D+). MBAM Premium. MCShield. WinPatrol +. WOT. OpenDNS. SAS(o/d)

"We are all ignorant, but we don't all ignore the same things..." Albert Einstein

"When you've excluded the impossible, whatever remains, however improbable, must be the truth..." Sherlock Holmes.

9 Palladium
2088

Hernan,

 

Avast would not be a problem. Look at SAS and see if anything there may cause this. A long time ago, this happened with SAS and maybe something happened again.

 

Try...

Start, all programs, accessories, right click on command prompt, left click run as administrator. Type

netsh winsock reset catalog

This will reset the winsock catalog

 

 

Rick

 

 


#DellRockstar

Welcome to Dell Community!

#DellWorld 2012
#DellWorld 2015
#Dell EMC World 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

This is a Dell User Forum. I am a Dell user, just like you are.
4 Beryllium
2088

Thanks Rick.

SAS althoug Pro is deactivated, I only have it for a third opinion scanner and its tools. I thought on applying SAS  winsock repair tool, but since I got on the web, I discarded te idea. However I implemented:

netsh int ip reset resetlog.txt and it did not work.

If tomorrow my NIC still does not get an IP, I will implement your winsock reset.

Thanks again.

Hernan.

Dim9200/XPS 410.C2D 2.40GHz.2GB RAM.XP Pro_86 SPk3. IE8 & FF38

Avast!Free 2015. CIS 5.12(FW/D+). MBAM Premium. MCShield. WinPatrol +. WOT. OpenDNS. SAS(o/d)

"We are all ignorant, but we don't all ignore the same things..." Albert Einstein

"When you've excluded the impossible, whatever remains, however improbable, must be the truth..." Sherlock Holmes.

9 Palladium
2088

Hernan,

 

It was...

Start, all programs, accessories, right click on command prompt, left click run as administrator. Type

netsh winsock reset catalog        (NOT netsh int ip reset resetlog.txt)

This will reset the winsock catalog

 

How to repair a connection

 

If you already installed Windows Updates, use system restore and go back before the updates. Maybe one of the updates caused the connection problem.

 

You can try looking in Avast's Virus chest to make sure something wasn't quarenteened.

 

 

Other option is start, network and sharing center, click on your connection, properties. Look for TCP/IPv4 and TCP/IPv6 and click on properties for each. Have your settings match mine.

 

 

Rick


#DellRockstar

Welcome to Dell Community!

#DellWorld 2012
#DellWorld 2015
#Dell EMC World 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

This is a Dell User Forum. I am a Dell user, just like you are.
4 Beryllium
2088

I know Rick. It was another way to reset IP logs, no the winsock. I will try the wisock repair tomorrow or later tonight.

No, I have not done my MU yet. Since they come in Spanish, they some time take 2 more days to be available.

Yes, all my settings are in auto; IP and DNS.

That is why I thought it could be my NIC, cause everything is like it is supposed to be.

Thanks.

Hernan.

Dim9200/XPS 410.C2D 2.40GHz.2GB RAM.XP Pro_86 SPk3. IE8 & FF38

Avast!Free 2015. CIS 5.12(FW/D+). MBAM Premium. MCShield. WinPatrol +. WOT. OpenDNS. SAS(o/d)

"We are all ignorant, but we don't all ignore the same things..." Albert Einstein

"When you've excluded the impossible, whatever remains, however improbable, must be the truth..." Sherlock Holmes.

4 Beryllium
2088

Well. It seems that it was not my NIC after all. I am conneted with it right now. This must be some issues my IPS has at plataform level since my cousin has had this problem too. I would have to power cycle when this happens again and if this does not fix it, to be patient and try again later.

Rick. Thanks a lot for your time and trobleshooting trying to figure this out.

Hernan.

Dim9200/XPS 410.C2D 2.40GHz.2GB RAM.XP Pro_86 SPk3. IE8 & FF38

Avast!Free 2015. CIS 5.12(FW/D+). MBAM Premium. MCShield. WinPatrol +. WOT. OpenDNS. SAS(o/d)

"We are all ignorant, but we don't all ignore the same things..." Albert Einstein

"When you've excluded the impossible, whatever remains, however improbable, must be the truth..." Sherlock Holmes.

9 Palladium
2088

Hernan,

 

Glad you got connected. Thanks for posting back.

 

Take care,

 

 

Rick


#DellRockstar

Welcome to Dell Community!

#DellWorld 2012
#DellWorld 2015
#Dell EMC World 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

This is a Dell User Forum. I am a Dell user, just like you are.
Latest Solutions
Top Contributor