Highlighted
ramk_s
1 Nickel

Dell DW1520 Wireless Lan is not enabled on startup

Hi!

I seem to have a problem with my Dell DW1520 wireless LAN card installed on a Studio 1747 laptop.

The LAN card seems to have a mind of its own and is rarely enabled at start up. Repeatedly restarting the laptop a few times somehow magically enables the network card though.

When disabled, I can see the red cross on the task bar (network connection). The network card is not even detected and is not visible in device manager. However, when I restart the laptop a few times, the bars appear, the LAN card appears in device manager and I can connect to the wireless network.

I logged a call with Dell Technical support for this and a different issue (BSOD and restart). They replaced my motherboard and asked me to monitor the situation. While the BSOD/restart issue seems to have disappeared with the motherboard replacement, the wireless LAN card issue still remains. The person that came to install the motherboard also tried installing new drivers for the LAN card but that hasn't helped. Dell tech support now say that I must reinstall the whole Operating System (Windows 7), drivers etc from scratch.

I haven't yet got around to it but thought I will look for alternative solutions before taking the extreme step of backing up, formatting and reinstalling everything. Any help with this will be really appreciated.

Regards

 

0 Kudos
16 Replies
8 Krypton

Re: Dell DW1520 Wireless Lan is not enabled on startup

Hi

So sory u had to go through all this trouble with your Studio 1747.

I do agree that you need to try all possible alternatives before considering re-installation of the OS.

Firstly lets try removing the software for the wireless card completely.

Go to Add/Remove programs and check if the Dell Wireless utility is installed, if yes go ahead and remove it and restart the system, If not proceed to next step.

Go to system restore and create a restore point (All Programs>Accessories>System tools>System Restore) <This Step Is Critical as if anything goes wrong later on you can always restore to this point.>

 

After that check your device manager and see if the card is detected, if it is, then right click and uninstall, if given an option put a check mark in front of 'Uninstall Driver Software'.

Restart the system.

Check your device manager again.

IF your device is detected and has a yellow exclamation mark, then right click and click on 'Update Driver Software'. Select check online for updates, let windows install the driver software for the card. Once done, restart the system.

If windows is unable to install the driver software, Download the wireless drivers from the Support Site for your Studio 1747 <Click Here to Download> <ADMIN NOTE: Broken link has been removed from this post by Dell>

Monitor the system for a while and let me know what happens.

 

 

Forum Member Since 2010

0 Kudos
ramk_s
1 Nickel

Re: Dell DW1520 Wireless Lan is not enabled on startup

Hello Telson,

Thank you very much for the response. I followed the instructions mentioned above but unfortunately, still have the same issue i.e. WLAN card isn't always enabled at startup. 

Any other suggestions?

Regards

 

0 Kudos
8 Krypton

Re: Dell DW1520 Wireless Lan is not enabled on startup

Try something simple first. In the Properties of the card, Power Management tab, check that 'Allow the computer to turn off this device....etc.' is selected. Then Windows knows to wake the card after Hibernation and Sleep as well as Shutdown.

0 Kudos
8 Krypton

Re: Dell DW1520 Wireless Lan is not enabled on startup

Try Mary's method if it does not work try these.

Follow the screen shots carefully.

1)  Click on start and in the search box type 'Services'. Click on the service application listed on top. {Sory for the red paint 🙂 }

 

2) Then a windows will open up, in this window find 'WLAN Autoconfig'

         

 

3) Right click on WLAN Autoconfig and click on properties.

 

4) Then a window similar to the one below will be in front, make sure the startup type is 'Automatic' If any other would only mean this was why cause of this problem. Also check if the service state is 'Started'. Proceed to the next screen shot.

  

 

Also make sure you have the 'Recovery' Tab same as the one below.

  

 

Click on Apply and then OK, restart your system.

Forum Member Since 2010

0 Kudos
ramk_s
1 Nickel

Re: Dell DW1520 Wireless Lan is not enabled on startup

Hi Telson,

Again, thank you very much for the response and the detailed steps! I checked service manager and followed the steps mentioned in your post. The settings on my laptop are all as mentioned above.

I must mention though that the occurrence of this failure has reduced since I did the remove and install of the drivers based on your earlier suggestion. While in the past the WLAN adapter would never start up after a prolonged period of inactivity (i.e. computer shut down), I do notice that nowadays, it is sometimes active even when the laptop is started after a few hours of inactivity.  However, there are still some instances when the adapter isn't enabled and the computer has to be restarted to enable the adapter. It is a strange behaviour and I seem to have no clues as to why it behaves likes this sometimes while at other times it seems perfectly ok.

Any more suggestions? Really appreciate your help.

Regards

0 Kudos
ramk_s
1 Nickel

Re: Dell DW1520 Wireless Lan is not enabled on startup

Mary,

Thanks for the response! The power management options are already set as mentioned in your post i.e. "allow the computer to turn off this device to save power". So that doesn't seem to be the issue.

Thanks for the suggestion anyway.

Regards

0 Kudos
8 Krypton

Re: Dell DW1520 Wireless Lan is not enabled on startup

Hi Telson,

Again, thank you very much for the response and the detailed steps! I checked service manager and followed the steps mentioned in your post. The settings on my laptop are all as mentioned above.

I must mention though that the occurrence of this failure has reduced since I did the remove and install of the drivers based on your earlier suggestion. While in the past the WLAN adapter would never start up after a prolonged period of inactivity (i.e. computer shut down), I do notice that nowadays, it is sometimes active even when the laptop is started after a few hours of inactivity.  However, there are still some instances when the adapter isn't enabled and the computer has to be restarted to enable the adapter. It is a strange behaviour and I seem to have no clues as to why it behaves likes this sometimes while at other times it seems perfectly ok.

Any more suggestions? Really appreciate your help.

Regards

Mary,

Thanks for the response! The power management options are already set as mentioned in your post i.e. "allow the computer to turn off this device to save power". So that doesn't seem to be the issue.

Thanks for the suggestion anyway.

Regards

There must be a mistake, the "allow the computer to turn off this device to save power"  Should NOT have a check mark.

Forum Member Since 2010

0 Kudos
ramk_s
1 Nickel

Re: Dell DW1520 Wireless Lan is not enabled on startup

Thanks for the clarification! Have removed the check from the power management option.....but I still had to restart the laptop 3 times to get the wireless adapter enabled. emoticon.Crying.title

0 Kudos
8 Krypton

Re: Dell DW1520 Wireless Lan is not enabled on startup

Something is not right.

Walk me through this again would you ?

Does the wireless adapter ever when working fine get disabled automatically?

When you start the system the wireless gets disabled, right ? have u checked in device manager as well as network and sharing center and tried enabling the device there? If not try this the next time you restart when the card is disabled click on the signal bar select network and sharing center, then on the left hand side you will see change adapter settings.

In this page is the wireless adapter shown as disabled?. if so, double click on it see if it re-enables and connects to ur wireless network

 

 

Forum Member Since 2010

0 Kudos